Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Razer Tartarus V2 controller D-pad sticking / glitch

Discussion in 'Razer Support' started by cpoChiD, Dec 10, 2020.

  1. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    Thanks for this response. And yes, it may take time to launch this update globally, but the team will endeavor to pull it off. Feel free to submit a case or sending me a PM so our team can track and use your sample logs in their investigation.
     
  2. Seegeth

    Seegeth New Member


    What I did:

    I created a new local Windows account (no password), after logging into Windows, I started Synapse 3, I logged into my Razer account and I started playing the game, After two hours of playing the problem did not occur even once.

    Next:
    I changed my primary online microsoft account (user in windows) to local account.
    Now all works fine.(2 days)
    I will do more testing tomorrow.
     
    Last edited: Jan 7, 2021
  3. the_novena

    the_novena New Member

    This sounds quite promising! I regard it with guarded optimism though, because after running the Windows DISM tool and the System File Checker and doing a clean reinstall of Synapse, mine ALSO seemed to behave better for a short while … but it didn’t last.

    I think I ended up getting a couple days of shorter 1.5hr gaming sessions, plus another day of a longer 2-3hr gaming session without problems. … And then, on about the fourth day, after a couple/few hours of gaming, the ‘repeating’ happened again.

    After all of the testing/troubleshooting I have performed, I think that was the third time I had begun to enjoy this false sense of security.

    I feel like, even though the issue takes a while to recur again, once it does – then it will go back to happening as frequently as it was before…? Does this make any sense?

    As far as frequency goes, typically, it’s honestly hard to gauge. I want to say that, on average it happens once every couple hours. Having said that however, there are days where it happens within 25 minutes of starting to game. And there are days when I can go almost three hours before it happens. As @NoahArk620 pointed out, this is part of why I’m sure it must be difficult for the Razer techs to duplicate the issue.

    I’m wondering about something though. Going back to what I mentioned before: about it taking a while for the issue to recur after each of the following individual actions:

    • Standard uninstall/reinstall of Synapse
    • Running the DISM and System File Check tools, and clean reinstall of Synapse
    • Logging in to a different Synapse user account (razertest)

    I’m sure for someone who is more tech-savvy than myself, that this might imply something about the issue possibly being gradual/cumulative, so to speak? Obviously, this is only a hypothesis, but perhaps this is something @Razer.SpeedCr0ss can communicate to the devs/tech team?

    While you’re communicating with them, @Razer.SpeedCr0ss , please pass along the following tips they should note if/when trying to duplicate the issue:

    I think the easiest way to reliably notice when it happens is to utilize the buttons on the D-Pad as they were designed: directional control of a character through an in-game world. This is because it’s easy to see when your character continues running after you had meant to stop. On the other hand, if you bound one of the D-Pad buttons to ‘drink potion’ instead for example, it could be more difficult to tell when the function begins to loop (repeat). If there is no character animation for drinking a potion, then you wouldn’t be aware of your over-drinking until you notice a whole stack of health pots missing :oops: from your inventory! Or if a potion is on cool-down, your character would simply fail to consume the subsequent potions, and the repeated iterations wouldn’t be noticed at all. I’m sure this same type of analogy could be drawn somehow with FPS games, as with MMORPG’s – I just used potions as an example. My main point being: use the D-Pad strictly for character movement (lots of it!), to best notice the issue.

    Razer techs should also be aware that frequency is difficult to gauge as I’ve mentioned in the preceding paragraphs. With this in mind, the techs may have to test for a couple/few/several hours per day, over the period of a couple days. In fact, (as per my hypothesis), if there has never been a previous occurrence on your test system, then you may have to continue testing over the period of a few/several days. Once it happens, then it will likely continue to happen approximately once every couple hours (give or take).​

    @Seegeth , please do continue your testing and be sure to keep us posted here; I'm pretty eager/happy that you might be on to something! If your success becomes a bit more sustainable, then perhaps the Windows account does indeed have something to do with it! :)four_leaf_clover: fingers crossed for continued good performance!)
     
    Razer.SpeedCr0ss likes this.
  4. Seegeth

    Seegeth New Member

    For now all works fine.

    Day 1: 2 hours of WoT - 0 stuck keys
    Day 2: 1 hour of WoT, 3 hours of Vallhala - 0 stuck keys
    Day 3: 3 hours of WoT - 0 stuck keys
     
    the_novena likes this.
  5. NoahArk620

    NoahArk620 New Member

    Interesting. Is it still under 3.5.1215.121019?

    --

    Most of the stuff I am experiencing were all very similar to what @the_novena had experienced. Just a very few minor differences.

    The frequency of the issue cropping up has always been random for me. It can go on for weeks without notice, or it can happen within minutes between each other. Most of the time, it went unnoticed because I wasn't actively trying to replicate the issue, and/or I was spamming the WASD movement very fast.

    It doesn't matter what game or application it was running. I can get it to show up on Keyboard Tester on Chrome, but only while Synapse is still running.

    Unlike WASD movement, using D-pad to test is probably the easiest way for it to reproduce the issue without it having it being unnoticed, simply due to how you cant exactly spam it like a keyboard to cancel the stuck key. But i personally don’t use the D-pad for movement, so during my tests i only had one instance where it showed up repeating the binded action. Most of my testing still suggest that ANY key on the gamepad can get stuck on the gamepad, so it is all about how the driver and/or firmware communicated with the Synapse software.

    I believe the Razer Huntsman Elite and Huntsman Mini both had stuck key issues in the early stages as well. Surprisingly, the issue back then can also be temporarily fixed by close off Synapse altogether. I think these product lineup later received Firmware updates (I only read Huntsman Mini) and that solved the problem. I am hoping Tartarus v2/Pro both received similar treatments as well.
     
    Last edited: Jan 8, 2021
  6. Seegeth

    Seegeth New Member

    Still on 3.5.1215.121019.

    For me green a most used keys.
    Only the red ones were stuck.

    tar.jpg

    For now all works.
    Has anyone tested new local account?
     
  7. NoahArk620

    NoahArk620 New Member

    The third PC at my workplace I used to test on were all local accounts, and under guest account in Synapse. Sadly for me, that did not work well for long.
     
  8. KAWAiiSONG

    KAWAiiSONG New Member

    Everything is bad, still on both computers there are sticking . and very often it became!
     
  9. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    Hey everyone! I appreciate your cooperation and for continuously updating this thread.

    If there's progress Seegeth, please let this thread know.

    Hi the_novena. I'll ensure to cascade your message to the team. I am currently collating all recurring concerns on our support board, and this thread is part of it.
     
  10. Seegeth

    Seegeth New Member

    What i did step by step:
    1. a. Run System File Checker.
    • 1. In the search box on the taskbar, type command prompt, press and hold (or right-click) Command Prompt, then select Run as administrator > Yes.
    • 2. At the command prompt, type SFC /scannow (note the space between SFC and the /). Scanning will take a few minutes.
    • 3. If SFC finds corrupted files and replaces them, restart your PC and check if the issue persists.
    2. Restart computer.
    3. Start testing (the problem reappeared several times within an hour).
    4. b. Replicate the issue by creating another local Windows user account..

    5. I created new local account, and logged in to it. Then i started Synpase 3 a login on my Razer account.
    6. Start testing. (no issue).
    7. I logged in to my administrator account and converted it from an online Microsoft account to a local account.
    8. Start testing (no issue).
    9. I deleted new test local account.
    10. Start testing (still no issue).

    That's all i did.

    Maybe someone try to create a new local account and test.
    I will continue to test.
     
    Last edited: Jan 13, 2021
    Razer.SpeedCr0ss likes this.
  11. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    Good work Seegeth! Thanks for sharing this. I'll show this to our team.

    Hey everyone! Please check if the steps above worked for your computer/setup too.
     
  12. KAWAiiSONG

    KAWAiiSONG New Member

    Please make a video of what to do and how to do it
     
  13. the_novena

    the_novena New Member

    I'm so glad to hear that the 'Windows user account' thing still seems to be working for almost a week now -- that's awesome, @Seegeth ! :cool_:

    I'd like to give it a try, and I think I should be able to fumble my way through recalling how to do Step #4 -- creating another local Windows account. You mentioned that you had included a full manual on how to do this in an earlier post, but your screenshot/quote seems to be cut off at the point that mentions this step.

    For the benefit of the greater good, maybe you or @Razer.SpeedCr0ss can post the instructions you mentioned? Just so that I (and other users) can be confident that we're doing it correctly.

    My bigger confusion however is about Step #7. Can you, or @Razer.SpeedCr0ss please provide some guidance on how to do Step #7 ... I'm uncertain of how to convert my (online) admin account to being a local account.

    Thanks! With some more guidance on these steps here, I will look forward to giving this a try!
     
  14. Seegeth

    Seegeth New Member

    @KAWAiiSONG I edited my previous post, there is now a detailed instruction on how to do it. You just need to run command lines in windows and add new user. Nothing more.
    Just take step 1 to 6 and see if anything changes.
    If you have a problem with a specific step in the manual, please let me know and I'll try to explain it.

    @the_novena I play an hour or two every day and it still works.
    Step #4: Please let me know if the image is displayed now.
    Step #7: In windows you can use the microsoft account (e-mail) as a user or create a local account. I used a microsoft account, so I had the option to convert to a local account.



    Please just take steps 1 to 6.
     
    Last edited: Jan 13, 2021
    the_novena likes this.
  15. KAWAiiSONG

    KAWAiiSONG New Member

    I did some testing ! there are no integrity violations
     
  16. Seegeth

    Seegeth New Member

    Any progress?
    Someone tried creating new account in windows?
     
  17. CptCraptacular

    CptCraptacular New Member

    it's all fine and dandy but having to go through all the steps, when all what needed to be done was install internal memory. to be able to save 3profiles or so with binds etc on the keypad esp something what costs £130/$130. How much would a 32mb or less chip add to price of something what already costs so much.
    considering £28 keypads have internal memory not much i guess. All the mice i have allow me to do so with custom sens etc ofc much less info but glorious cooler master etc don't force their bloatware on you at least, set it up then uninstall jobs done.
     
  18. Seegeth

    Seegeth New Member

    In my opinion, internal memory is a needed accessory, but it is not the solution to the problem. Some people have multiple Razer devices and want access to all features like multiple profiles, RGB, etc.
    I think we found a solution to the problem, maybe Razer support will be able to do some update to Synpase 3 so that you do not have to do all these things to make everything work fine.

    P.S. As for Synpase 3, I have a small problem with the program detecting an active application and change profile. I need to minimize and maximize a game or program for Synapse to detect and change the profile.
     
    the_novena likes this.
  19. KAWAiiSONG

    KAWAiiSONG New Member

    1. a. Run System File Checker.
    • 1. In the search box on the taskbar, type command prompt, press and hold (or right-click) Command Prompt, then select Run as administrator > Yes.
    • 2. At the command prompt, type SFC /scannow (note the space between SFC and the /). Scanning will take a few minutes.
    • 3. If SFC finds corrupted files and replaces them, restart your PC and check if the issue persists.
    I did it! there are no errors.
     
  20. KAWAiiSONG

    KAWAiiSONG New Member

    The 1 key on the Naga Pro sidebar just got stuck. there is a button F
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >