Razer Tartarus V2 controller D-pad sticking / glitch

Discussion in 'Razer Support' started by cpoChiD, Dec 10, 2020.

  1. KAWAiiSONG

    KAWAiiSONG New Member

    my Orbweaver is rejected! I may soon be forced to buy a Razer Tartarus Pro
     
  2. NoahArk620

    NoahArk620 New Member

    It is good to hear that the team is monitoring this thread! Thank you very much!

    In other news, the Razer Support team that has been assisting me thus far just sent me another message suggesting the issue is out of their control for the 3rd time now. I do not know their testing methodology, but reproducing the problem on their end is definitely difficult.
     
  3. CptCraptacular

    CptCraptacular New Member

    yeah it may take 10 mins to do the fault or ever 10-15 hours of gameplay it's such bitch to find a fix for something what seems so random
    i thought my fix worked, it did for around 20 hours of game play. then it did it once and hasn't done it since it's just so random :slightly_sad:
     
    Last edited: Jan 20, 2021
  4. libelulu

    libelulu New Member

    Just bought Tartarus v2, 2 weeks ago. First time using a gaming keypad and I can say I love it so far. Also first time using a Razer product.
    BUT...this issue is getting ridiculous. My character just keeps walking...At first, I thought I'm doing something wrong...and it wasn't happening that often, like once every 2-3 hours(definitely annoying, but manageable). But today it drove me mad. I've played wow for 3 hours, raiding, and it happened every 15-20 minutes. Even got kicked out of raids because I was randomly walking and pulling mobs :)

    I've already spent half a day reading about this issue online and it seems it's quite old and there is no solution for it...
    Should I return the product? Has anyone tried Tartarus Pro? All the people with this issue are on tartarus v2...maybe the pro version is working, I dunno.
     
    gruviboy likes this.
  5. NoahArk620

    NoahArk620 New Member

    It is entirely up to you whether you want to return the product or put your trust into Razer finding a solution to release a fix for this.

    If you do want to stick around, then by all means join us! There is already a temporary solution, and that is to use a program called reWASD to rebind your keys while closing off Synapse. (Except scroll wheel) This software is most effective when you have only 1 Razer product in your setup that relies on Synapse 3. Do keep in mind that reWASD is a paid software with a 14 day free trial.

    The Razer Tartarus/Orbweaver (and by that extension, Belkin) is an incredible gamepad product. It is jusy rather unfortunate the current Tartarus v2 and Pro series are currently being held back by the software/driver issues at the moment.
     
  6. pgk920

    pgk920 New Member

    I'm just going to add my voice to the growing list. I have the tartarus v2. I've had it since early last year or so. It just began doing the button-sticking behavior in the last several weeks.
     
  7. CptCraptacular

    CptCraptacular New Member

    unless you got it cheap return it, if they ever fix it buy it again. You should not have to pay for a "temp" fix when razer should fix their software. This bug has been know about for over a year imho at this point razer should pay for the temp fix because they are to slow

    TLDR: return unless you got it cheap.
     
  8. yes that happen and at razer tartarus pro ....
     
  9. the_novena

    the_novena Member

    Wow -- I think this is the longest I've heard of anyone going without having the issue! You've had it for nearly a year before it began this behaviour? ... So, I'm dying to know what changed to trigger it, after so long of successful use!

    I'm so sorry to welcome you to our disappointing club, @libelulu but yes -- it most definitely happens with the Tartarus Pro as well. As for whether or not you should return your brand new device, that's honestly a hard call. Once you've tried one (especially for MMORPGs), the quality of life it brings to your gaming experience is nothing short of amazing! I honestly can't hardly imagine gaming without a gaming keypad now. Having said that ... gaming keypads seem to be a fairly niche market. As much as I love Razer, there is a very subtle note of resentment in my voice when I say that (to the best of my knowledge), there isn't anything currently in production by any other manufacturer, to rival Razer's keypads. There are a small handful of low/mid-grade keypads, but the ones I have scoped out end up falling short in two or three key areas:
    • Capability (none, or almost no others, provide the capability of custom keybinds/macros)
    • Design (the others are not as ergonomically comfortable looking/sexy)
    • Well-established industry performance reputation/standards
    Logitech used to come the closest to providing a truly competitive product, but theirs seems to be discontinued. It would be interesting to know if they have any plans under development to bring anything new to market.

    Without any close competitors to keep Razer on top of their game (so to speak, hehe), the lack of support for this longstanding Tartarus/Synapse 3 issue disappoints that much more bitterly.

    With all of this in mind, my own personal philosophy is that I would rather continue to tolerate, and compensate for, this very annoying performance bug than to go without a gaming keypad entirely. I do so with a certain amount of resentment because it's an expensive device, but ... once I became accustomed to compensating for the glitch quickly enough (able to re-press that same affected button again), I've usually been able to recognize and react quickly enough (most times) to avoid going all Leeeeroy Jenkins and pulling a roomful of adds during the final boss fight. I absolutely feel your frustration though; I genuinely do!


    I've posited the theory that the issue might be gradual/cumulative over time, and I've noticed that the frequency also seems to ramp up over time as well. The issue has been occurring more frequently for me again this past week. It's now been nearly a month since I ran the system file checker and did the clean uninstall/reinstall. It's been nearly three weeks since I used a Razer test account on Synapse 3 instead of my own. These were the last successful "short term fixes" I undertook (see page 4 of this forum thread). Based on this, I might end up trying another clean uninstall/reinstall of the Synapse software again, but damn ... am I really going to have to keep doing that once a month or so, when the issue becomes more and more frequent to the point where it's unbearable??
     
  10. pgk920

    pgk920 New Member

    I've been trying to think of what that could have been. It began so intermittently at first I didn't pay much attention. But, around that same time I got a new computer desk and had unplugged everything from my old pc and then plugged it back in. Maybe I switched usb ports during that time? Not sure. However, a couple weeks later I also got a new pc (so can't test that theory on the old pc) and the problem persists on this new pc as well.
     
  11. CptCraptacular

    CptCraptacular New Member

    always nice and to the point, the windows driver work around has slashed my key sticks from multiple times a day to once ever 3-4 days so i am happy with that. I indeed think it is the windows keyboard drivers and synapse clashing but the question is where is the clash what is causing the problems :slightly_sad:
     
  12. the_novena

    the_novena Member

    Are you talking about disabling the HID-compliant device for the Tartarus, as you mentioned earlier on this thread? If so, it sounds great that it has minimized the occurrences that much! I will definitely try that, before resorting to another clean uninstall/reinstall, then. Thanks!
     
  13. CptCraptacular

    CptCraptacular New Member

    yeah i am, though i may just be getting lucky, which is what is making this even more annoying to deal with. because in 4 days it may decide to do it 4 times in hour again. ohwell i wish you the best of luck

    also we are being to soft, on razer this issue has been know about since 2018.(it's not tartrus it's synapse being a pos)
    It has been on other razer products and they have been fixed them as this post explains and a razer rep did respond so it should be able to be fixed with a download like the keyboards
    https://www.reddit.com/r/razer/comments/jw9l6r/still_driver_update_for_razer_tartarus_pro/
     
    Last edited: Jan 25, 2021
    NoahArk620 and the_novena like this.
  14. NoahArk620

    NoahArk620 New Member

    Nice find! How did I miss this reddit post is beyond me, but it is good to see that there is indeed a method to uninstall the necessary drivers to prevent Synapse from detecting the Tartarus Pro if no fixes are in sight in the future!

    I briefly posted a reply in his reddit post to see if he would like to come join us in this little community of ours, hehehe. xD
     
  15. CptCraptacular

    CptCraptacular New Member

    still sad how they fixed the 60% opti keyboard so fast but left this for dust. ohh yeah, it's because tech tubers have reviewed that and would make a video calling out razer. but because not many big tech tubers reviewed this it's not gonna happen. Need to try get a tech tuber or someone with some clout to get involved because, i don't see them pulling their finger out otherwise.
     
  16. jjdenver

    jjdenver New Member

    I have tried the troubleshooting steps mentioned in this thread. The issue persists for me. After doing extensive research across the internet I'm convinced that:
    1) it's wide spread and in fact experienced by all user
    2) it's due to the synapse software (I've tried uninstalling synapse and the issue goes away)

    I don't want to have to buy rewasd software because it costs money and I don't want to lose ability to map my scroll wheel.

    Razer can you please address this?
     
    NoahArk620 likes this.
  17. Seegeth

    Seegeth Member

    I tried driver fix. (disable HID)
    Works for one day. Now issue occur few times in hour.
     
  18. NoahArk620

    NoahArk620 New Member

    Oh no... That is truly sad to hear. :< I wonder if there is a specific driver that I can delete so that I can install Synapse 3.0 to let me use my other devices in peace.

    Welcome to the thread, @jjdenver ! I personally like reWASD software very much, but yeah, we shouldn't be relying on 3rd party software to retain 'most' of our product functionality. There is actually no need to 'uninstall' Synapse, just turn it off entirely, and the issue will go away temporarily for as long as the program is not running.

    By all means keep a close tab on this thread, as we do various different methods of testing to check for a potential workaround while we wait for a proper driver/firmware fix from the developer team! (I am still eagerly awaiting good news, @Razer.SpeedCr0ss !)
     
    gruviboy likes this.
  19. CptCraptacular

    CptCraptacular New Member

    yeah mine started doing it again, :slightly_sad: it's like you need to repair the install ever 3-4 days it's annoying af ¬¬
    and i think they should at least stop sales of the device till they fix this bug, because it's show how little f..s they give. because it will happen to everyone at some point, it just takes time. and for them to fix that i don't think they are going to leave the product in a pc for over a few weeks constant to see the bug appear, "we tested for like 2 days nothing happened"
     
    gruviboy likes this.
  20. KAWAiiSONG

    KAWAiiSONG New Member

    when the problem occurs again, check the latest Synapse sync time with the cloud!I think it might be related!
     
    gruviboy likes this.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >