Razer Tartarus V2 controller D-pad sticking / glitch

Discussion in 'Razer Support' started by cpoChiD, Dec 10, 2020.

Thread Status:
Not open for further replies.
  1. the_novena

    the_novena Member

    mic drop.jpg
    NoahArk620 and SunjyKamikaze like this.
  2. SunjyKamikaze

    SunjyKamikaze New Member

    No Answer from Logitech @the_nova ?
  3. NoahArk620

    NoahArk620 New Member

    It is 'reassuring' that even on an older Windows 7 operating system can still show the issue as well. This suggests the issue lies in driver/firmware moreso than the operating system itself.

    If it makes anybody feel any better, I just got my hands on my friend's Razer Blade 15" Advanced Model (2019) which he bought very recently, and the issue showed up within 1 hour right after a fresh install of Windows under Guest account in Synapse 3.0. (Fully updated) The version of Windows 10 was at 1909, and the only software installed were Steam, Battle.net (Used this for testing for Overwatch), and Geforce Experience.

    To be quite honest, this experience has stopped me from purchasing any Razer Product without an integrated memory in it.
    Daisame likes this.
  4. SunjyKamikaze

    SunjyKamikaze New Member

    Sorry but why you think an integrated memory would solve the problem?

    KAWAiiSONG New Member

    Because it is in Naga Pro! this makes it possible to work without Synapse and it helps!
    the_novena likes this.
  6. the_novena

    the_novena Member

    Wow! Seriously?! ... C'mon Razer!

    Because without on-board memory, we rely upon the Synapse 3 software to program and store our custom keybindings on the Tartarus keypad.

    For example: on my own Tartarus, personally, I have remapped the [08], [12], [13] and [14] keys to be M (opens my game map), J (opens my quest journal), I (opens my inventory), and H (to mount up on my horse).

    The factory default for those [08], [12], [13] and [14] keys are W, A, S, D ... but I personally prefer to use the D-Pad to control movement, so I don't need W, A, S, D. Instead, especially since those keys are within such easy reach, I would prefer them to be programmed some of the more common in-game functions that I use frequently.

    Now, if I was exit out of the Synapse 3 software entirely, because it's the source of all the buggy performance ... then the good news is that my Tartarus will function beautifully with no more 'stuck' keys! But the bad news is that I am limited to using the factory default keybindings. So ... [08] will no longer open my map; instead it will move my character forward. The [13] key will no longer opens my inventory; instead it will move my character right. Etc, etc.

    If we had on-board memory, then we could exit Synapse 3 (eliminating the buggy behaviour entirely), and still have all of our own individual custom keybindings stored on the device itself.

    (Note that exiting Synapse 3 solves the buggy behaviour, but it might eliminate some other conveniences or features of your other Razer peripherals, if you have more than one Razer device. For example: without the Synapse 3 software, you won't be able to play around with all the cool RBG settings; you won't be able to fine-tune all the preferences for your Razer headset; you might lose some button configurations on your Razer mouse if you own a model of Razer mouse that doesn't have on-board memory; etc., etc.)

    They replied yesterday with a generic, noncommittal response that didn't really answer the question. "We advise you to visit our page from time to time for new product information, and have forwarded your question to the appropriate department as a suggestion/feedback." ... I'm honestly considering phoning them and asking to speak to someone in their Product Development department, but the whole world seems to be operating at reduced capacity right now due to Covid-19, so it might not be the best time for me to go chasing this.
  7. Daisame

    Daisame New Member

    I have been using the Tartarus Pro for a few months now, and always get stuck key input. The keys themselves don't stick, just the input stays on until I hit that key again. Also happens on d-pad. I have not tried removing the sympse software, since I sort of needed this to remap default keys.

    I actually just rebuilt a brand new gaming rig. It happened on my old system, and my brand new system with fresh installs of OS, drivers, and games. It will do it in any title. Not sure if the problem is with the synapse software or firmware on the Tartarus Pro, but regardless, it has cost me in game progress many times. I am like many others. I will not buy another Razer product if they are not willing to fix issues like this.
  8. CptCraptacular

    CptCraptacular New Member

    foward the wasd bill to razer. They have fixed other keyboard with the same issue and are lagging on this one because it is more niche, sucks but it is how it is.

    just waiting on badseed tech to do a razer vid and ask him if he can chime in at all but i don't think that will happen but it's worth a shot, dudes one of the best people for honest reviews on products
    Last edited: Feb 7, 2021
    the_novena likes this.
  9. Daisame

    Daisame New Member

    I had to read those attachments to understand our response, but thanks. So there is a WASD software that does some keyboard remapping, which 'can' work in place of synapse, but without supporting things like RGB and the scroll wheel. But it may fix the 'stuck input' of the Tartarus Pro. I may look into that. I don't really care about RGB and while the mouse wheel would be nice to be able to use, I don't currently need it.

    I love this keypad in every other respect, but this stuck input behavior has given be catastrophic results in some games and made it nearly unusable. If it can be fixed through the software, I would imagine even though it may be troublesome to recreate, it should be easy to see and solve through some debugging. Surely a company the size of Razer can fix this? I certainly don't trust any of their products now. This is the only thing I currently use from them, and it will stay that way until they can demonstrate they care about quality.
  10. Daisame

    Daisame New Member

    I did just DM Razer Suport on Twitter with my model and SN. I hope they can help resolve this issue, but if it is as widespread as it appears, if they have not fixed it yet, I doubt it will get fixed now.
  11. NoahArk620

    NoahArk620 New Member

    I had been with the Razer Support team since last April. Not much has changed other than sending me an RMA unit, and countless ‘we cant really find the problem on our end’ responses.
    the_novena likes this.
  12. CptCraptacular

    CptCraptacular New Member

    side note if you press the same key on your other keyboard it also stops the the input, just thought i would try it earlier when it happened

    also tried dcing other keyboard. that did not change anything either
  13. Daisame

    Daisame New Member

    Thanks for the idea. I never hit a key on my keyboard at the same time as a key on the Tartarus. I do though click mouse buttons at possible the same time. But not often.

    I just had it happen a couple of times in the last hour in Space Engineers. There was no other input but perhaps more than one key on the Tartarus itself. It certainly does happen dozens of times per hour, but probably once every hour or two. So if there was some debugging, they SHOULD be able to see it happen. I could probably do it on a word processor and see it 'stick' after an hour or two. As much as it happens, I would think Razer would be able to find it. This is a critical function of the Tartarus... so it needs to be identified and corrected. Razer should be applying reasonable resources to getting this fixed as quickly as possible.
  14. CptCraptacular

    CptCraptacular New Member

    spent a bit more time looking into the razer mini and well i have no hope now.
    July 14 2020 was the release date for the huntsman mini
    firmware to fix the bug was released on 24 Sep 2020

    so yeah over a year for the tartrus . When it took them 72 days to fix the problem FROM the release of the product. not the first topic on the fault, so it prob took them lets say 40-50 days max to fix. now that is kind of crazy, kind of shows how little they care about this product if they can fix the same fault on that so fast

    it's the firmware if you wanted to see for yourself
    the_novena likes this.
  15. Daisame

    Daisame New Member

    It did it a couple more times just now, and then a few minutes later Synapse software crashed, making all inputs cease, since even detault keystrokes don't work when the software crashes aparently.
  16. MichaelMok5

    MichaelMok5 New Member

    The issue is Synapses software. If you use the the damn thing with out the software and map the tarturas from the games instead of the synapses you get no issues. Unfortunately most of us are invested with alot of mapped key through synapses so re doing all of this in game sucks hard but it will get rid of the issue. well at least for me. havent tried the reWASD yet because i often use the scroll wheel mapping, but will give it a go.
    Last edited: Feb 8, 2021
  17. Daisame

    Daisame New Member

    I agree. I tweeted at Razer today and they had me 'update' the Razer Synapse software. This is a brand new install on a brand new PC. And it did it on my old rig too. So definitely local to the keybad or software. I have not tried to do without the software. I may try that next, since they don't seem to care about fixing their software.
  18. There are some other software to control separate devices other then rewasd. Scroll is configurable too.

    Hid macros


    KeytoKey keytokey-dev.net/

    OpenRGB for backlit. But it cant into per profile or per keymap lighting. Only once and for all
  19. Seegeth

    Seegeth Member

    I sent my device for a RMA. I have very low expectations that it will help, but I want to be sure that I have done everything I could.
  20. NoahArk620

    NoahArk620 New Member

    I did the same last year in November, I still have the same problem, haha.
Thread Status:
Not open for further replies.
Sign In with Razer ID >

Don't have a Razer ID yet?
Get Razer ID >