Razor Blade Stealth 13 (2020) + Core Chroma X - Freezes (Solution)

Discussion in 'Razer Support' started by Sapota, May 9, 2020.

Thread Status:
Not open for further replies.
  1. Sapota

    Sapota New Member

    Was experiencing regular full-system freezes during any low-load, non-gaming activities.

    Config:
    Razor Blade Stealth 13" (2020), GTX 1650
    Core X Chroma
    NVIDIA GeForce RTX 2070 Super in the Core

    All drivers and available updates installed.

    Found solution in a thread at egpu.io:
    Power Options -> PCI Express -> Link State Power Management (LSPM) turned OFF.

    Long way around to get there:
    - Settings
    - Power & Sleep
    - Additional Power Settings
    - Change Plan Settings
    - Change Advanced Settings
    - Expand "PCI Express: Link State Power Management"
    - For "Plugged In", set to "Off"
    - "OK"

    Apologies if cross-posted elsewhere, hope this helps others.
     
    PHSBarrett likes this.
  2. PHSBarrett

    PHSBarrett New Member

    Thanks !
    I have seen this nowhere and the Razer support team has been struggling to help me out...
    I've given your solution a try so hopefully it stops freezing.

    I still have an issue with my eGPU graphics card not managing to reconnect after unplugging and replugging the Thunderbolt 3 cable. The rest of the IO works fine but the GC can only be recognised again once I reboot.
    Did you experience similar issues ?

    My config is the same but with an RTX 2070
     
  3. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Do you mind sharing your ticket number via PM? I'd like to check what troubleshooting steps our Support Team have shared with you so far, so I can help you try other possible solutions.
     
    PHSBarrett likes this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >