Synapse 3 doesn't detect BlackWidow Chroma V2 and Mamba Elite after two updates

Discussion in 'Razer Synapse' started by Anshies, Feb 11, 2019.

Thread Status:
Not open for further replies.
  1. Anshies

    Anshies New Member

    Hello,

    since the last update (I guess it was about two weeks ago), my Synapse 3 stopped detecting my keyboard BlackWidow Chroma v2 and my mouse Mamba Elite. Everything was working fine and I had no issue with it until I updated the app.

    Today it updated again to version 3.4.215 and I thought that would solve the problem, but it didn't.

    I tried to do everything listed at the forums and reddit, like unplugging the devices, restarting, restore the application, uninstalling, uninstall and update drivers from device manager, etc... But nothing worked for me. I have Windows 7 Home Premium, but I don't think that's the problem because two updates ago everything worked fine.

    I don't know how to fix this and I'm really annoyed for not having my lights in sync /: (?)

    Thanks in advance!
     
    SpartanBeard likes this.
  2. Den_ver

    Den_ver New Member

  3. Neozgred

    Neozgred New Member

    I already write there that it is related to Windows 7. On Windows 8/10 there is no issues. Anyway on the box Windows 7 is supported and it was working before update so they just broke it.
     
  4. FiszPL

    FiszPL Well-Known Member

    I'd repeat myself, but in MOST cases this help: uninstall Synapse, delete devices from device manager in OS (with drivers - IMPORTANT), then do an OS cleanup with CCleaner (also with registry).
    Reboot OS, and after reboot install Synapse again.

    If it's not helping - you can submit a case via Synapse - and describe your problem.
     
  5. metamaterial.-

    metamaterial.- New Member

    I've tried this several times, still doesnt detect.
     
  6. Senthynel

    Senthynel New Member

    Actually you´re wrong there is the same issue for me on Win10
     
  7. BlackFireDragon

    BlackFireDragon Well-Known Member

    Can you cheack what version of windows build you have ?
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >