Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Synapse 3 Installation Not Working (Error Code: 528040)

Discussion in 'Razer Synapse' started by tonmoyajize, Aug 30, 2019.

Thread Status:
Not open for further replies.
  1. tonmoyajize

    tonmoyajize New Member

    Hey Everyone,

    2 days ago Synapse 3 updated automatically as it always do and after that when I restarted PC my Razer devices was not being detected / listed by Synapse 3. So I decided to uninstall Synapse 3 completely and then install again.

    But Synapse 3 is not being installed successfully anymore. Please note that I've deleted all folders, registries, device drivers of old installation and disconnected my devices, restarted PC multiple times but I'm still not able to install Synapse 3. it always shows this error while trying to install -

    [​IMG]

    Anyone here faced similar issue? Can you help me to fix this issue? It's horrible for me to work without the macros :frown_:

    N.B. I've already contacted Razer Support and provided them all info ... they're looking into it and will get back to me in 48 hours. I posted this thinking that maybe someone else can help me with this issue in the forum.

    Thanks.

     
    pancholr and FBro56 like this.
  2. sgt_nantz

    sgt_nantz New Member

    I've the same anoying issue without any reason.
     
    pancholr likes this.
  3. Maximilian_Anderson

    Maximilian_Anderson New Member

    Same here, trying to do a fresh install of it and it gets to this window every time.
     
  4. UNCLE_CLARKY

    UNCLE_CLARKY New Member

    Did anybody find a solution to this error code? Would be much appreciate if so....before I have to call razer.
    Thanks in advance
     
  5. billdal7

    billdal7 New Member

    hi friend...i had the same problem too but i solve it..listen me you can put your keyboard to another pc who you need to download synapse 3...then you need to go to setting and there is an option reset...here you can reset your keyboard to factory reset...after that your problem solved...you can connect your keyboard back to your pc
     
    Last edited: Nov 8, 2019
    jakw0lf likes this.
  6. jakw0lf

    jakw0lf Well-Known Member


    The workaround by @billdal7 works well and fixes the issue. :point_up_2:
     
    billdal7 likes this.
  7. UNCLE_CLARKY

    UNCLE_CLARKY New Member

    ok thanks I will try this.
     
  8. sevenEST

    sevenEST New Member

    can you explain in more detail? I can't understand a word your saying tbh
     
  9. Решил ли кто-нибудь эту проблему , скажите пожалуйста?)
     
  10. jakw0lf

    jakw0lf Well-Known Member

    You can try what @billdal7 mentioned, its a good work around for the reported issue.
     
  11. Davincitk

    Davincitk New Member

    The problem with @billdal7 method is my keyboard is attached to the laptop in my case since I am using a 15in blade.
     
  12. jakw0lf

    jakw0lf Well-Known Member

    Didn't get you, what was your question ?

    15inch blade is again the laptop, you can try resetting it by connecting to another computer as well.
     
  13. Zulunation

    Zulunation New Member


    Any response yet? I just picked up the Trinity and can't get the app to open. Getting the same error code. Mouse is working fine but I'd like to change the RBG setup. Thanks!
     
    0V3R_K1LL likes this.
  14. TheK1ng

    TheK1ng New Member

    I have same problem, got the solution?
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >