Synapse 3's Equalizer stops functioning

Discussion in 'Razer Synapse' started by Nicholas9, Apr 24, 2020.

Tags:
Thread Status:
Not open for further replies.
  1. JaRhodo

    JaRhodo New Member

    Any fixes yet? Recently got the Nari Essential and they worked perfectly. Then out of nowhere EQ doesnt work and THX surround is flat and awful.
     
  2. iguana46

    iguana46 New Member

    Lately it does not fail, and I found a pattern on my pc, turn on the headset before the pc, at the moment it has been a week without failure
     
    JaRhodo likes this.
  3. JaRhodo

    JaRhodo New Member

    Thanks for replying! I tried this and so far so good.
     
  4. soimu_08

    soimu_08 New Member

    My Nari's work fine if I restart the PC /
    If I close every razer service + GameManagerService.exe in the taskManagerDetails
     
  5. CptTwinkie

    CptTwinkie New Member

    I got a driver update today. It took forever to install. When it finished the THX outputs were missing so I rebooted and OMFG it's back. The quality!!! :) :) :) :)
     
  6. EugeneDrm

    EugeneDrm New Member

    Same issue with Razer Nari. None of the sound enhancements work. THX doesn't work either.

    Re-installing / rebooting / cleaning registry doesn't help at all. I tried everything described in this thread. Can't even think about anything else to do.

    Sound is worse than on wired Razer Kraken (which doesn't provide any great sound tbh). But maybe it's because of this Synapse issue.

    Looking at folks here who are having this problem for months(!!), I'm thinking about returning my Nari and giving up on Razer.
     
    CptTwinkie likes this.
  7. CptTwinkie

    CptTwinkie New Member

    Thanks for posting @EugeneDrm
    It's good to know that my recent success is not universal and there is still an issue. I'll try to put off future updates for as long as possible on this PC while it's working
     
  8. theception

    theception New Member

    I also got my Razer kraken TE and got the same issue. Also the surround sound is not working. Still reinstalled everthing and does not work. Also the 7.1 surround app is not working. No output!!!!!!!!
     
  9. NuclearSpider

    NuclearSpider New Member

    Razer nari owner here, Been having this issue for a year now since i bought it. Doesn't seem like razer is ever gonna bother fixing it.
     
  10. I fixed it by installing the realtek drivers from the official realtek website
     
  11. vargasama

    vargasama New Member

    EQ and Synapse are a complete mess...
    Repairing Synapse resolved my EQ problem. BUT ...... After Restarting my PC, the problem came back again and again.
    It's a SHAME.
    Nothing is done to help customers or correct this Synapse bug.....


    Fist time with Razer already the last time for me I think.
     
    scott.nguyen likes this.
  12. DTRHSr

    DTRHSr New Member

    Don't know if this thread is dead yet, but my eq is working again after I set my playback device to the (THX spatial - synapse) option. Hope it helps :)
     
    scott.nguyen likes this.
  13. scott.nguyen

    scott.nguyen New Member

    Thank you, it works for me!

    If this method does not work for some people, I would highly suggest to uninstall your current Synapse 3, disconnect your headset, restart PC/Laptop and reinstall the latest Synapse 3 version on Razer website.
     
  14. Galactic_Cat

    Galactic_Cat New Member

    That's my problem as well, also whenever i start a THX game it just stops working again. the annoying part is that when synapse is not working the audio becomes muffled and sometimes keeps cutting out. Razer please fix
     
    scott.nguyen likes this.
  15. scott.nguyen

    scott.nguyen New Member

    It happens to me again. Anything I mentioned previous is just a temporary fix. I will re-install the software again to see how it works.
     
  16. Galactic_Cat

    Galactic_Cat New Member

    yeah i'll do so as well
     
    scott.nguyen likes this.
  17. Stizzy1

    Stizzy1 New Member

    Two versions of windows, two different PC's. Whether it's Synapse or Windows, I don't even care anymore. As soon as it's worth buying a different brand of headphones, I will do so. This set of Razer Nari Ultimate headphones was supposed to be great with that haptic intensity and sound enhancements. But instead I got a turd sandwich wrapped in Wonder Bread. Their software made my windows audio device go haywire on the last pc. My current PC as I write this, doesn't do that but all the enhancements don't work including the equalizer. (Yes I enabled them in properties.) Bound to be some better cans out there that let me adjust the freaking bass and treble. Jesus H Christ! That Haptic Intensity was a joke. Battery can't hold up to it, even when plugged in. Razer got the big head and started not delivering. You put one freaking Nostromo device in the Ender's Game movie and now your products are double the price and half the value. The Tartarus will be the last product I buy Razer. Thanks for reading my rant if you made it this far =D
     
  18. Epicarusick

    Epicarusick New Member

    This is the worst headset of all time. Never buy these products. Useless software that stops working after an hour

    They are quite comfortable, but otherwise they are not worth a penny
     
  19. scott.nguyen

    scott.nguyen New Member

    EQ seems to be non-responsive after a few days. I guess the fix(es) are temporary and the problem lies within the software itself.
     
  20. Doc8Ball421

    Doc8Ball421 New Member

    Hey guys only fix ive found without rebooting is if the EQ isnt working exit synapse, open task manager and force quit any Razer related stuff, then re launch synapse. Ive been successful more often then not with this method running the Nari Essentials here.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >