Synapse not loading - just a grey screen

Discussion in 'Razer Synapse' started by gpapaiko, Sep 22, 2022 at 6:23 AM.

  1. gpapaiko

    gpapaiko New Member

    Hi,

    I am new to this. Just got a Razer blackwidow V3 ( RZ03-03542600 model).
    Installed the Synapse 3 software and when I start it all i get is a grey screen as belo image.
    I have followed the instructions on this page How to perform a clean re-installation of Razer Synapse 3 & 2.0 on Windows and still the same, even after a reboot.
    I have tried this about 3 time and still no luck.

    Any help is greatly applicated.

    THanks
    George.



    upload_2022-9-22_23-19-12.png
     
  2. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Are you connected to a VPN or a company network? If you are, please join another internet connection and see if the behavior persists. You may also check your computer's firewall or anti-virus and see if it is blocking any Razer-related files.
     
  3. gpapaiko

    gpapaiko New Member

    Hi,

    I have checked all of the above and none are in affect.
    The PC firewall has been disable and the apps are not being blocked by the firewall or the virus scanner.

    Not sure were to from here.
    Is there any kind of debug mode and logging that can be enable to see where it is being stopped.

    When i install the app the RGB LED on the keyboard are cycling through the different colors and i have no way of changing that. .

    Thank you
     
  4. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Thanks for confirming. Can you send me your Razer Synapse logs so I can initiate a support ticket? Save the files via Google Drive or any online drive, then paste the shareable link in your PM or you can submit a case to our Support Team here.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >