Synapse problems with MacOS Catalina

Discussion in 'Razer Synapse' started by Deftknot, Oct 9, 2019.

Thread Status:
Not open for further replies.
  1. aciddaddy

    aciddaddy New Member

    Same for me. Default colour for Mamba TE and lights doesn't want to light at BlackWidow Chroma V2.
    MacOS Catalina.
     
  2. RipperPT

    RipperPT New Member

    My Razer Synapse doesn't detect my Razer Firefly and my Razer Kraken 7.1 V2. However it detects my Razer Blackwidow Chroma and my Razer DeathAdder Elite. What the hell... Screenshot 2019-11-16 at 18.51.31.png
     
    0V3R_K1LL likes this.
  3. istvn.urbn

    istvn.urbn New Member

    Hi All,

    Razer Synapse does not seem to recognize my Mamba Wireless. It works, but I cannot see it in the app.
     
  4. Mr_Nickel

    Mr_Nickel New Member

    I'm facing the same problem....
     
  5. JoeyAnthony

    JoeyAnthony New Member

    My Naga Trinity and Nommo speakers will show up in Synapse for a brief period of time after rebooting (and unplugging in the case of the mouse). However my Goliathus Extended Chroma doesn't show up at all no matter what I do.

    Unfortunately, even the devices that do show up are flakey. I can only loop the colors and the looping doesn't sync between devices — so my desk is a permanent kaleidoscope of colors. Likewise the mouse constantly forgets the settings and sometimes only a reinstall of synapse will fix the issue.

    It's a shame, I love the hardware but it's clear that Razer doesn't actually support macOS. I just wish I knew that before buying all this stuff. I feel like I'm stuck now.
     
  6. Donninno

    Donninno New Member

    Pleas update Razer Synapse 2 for macOS Catalina Razer team!
     
  7. useMyEmailSilly

    useMyEmailSilly New Member

    Gah. Bought a Naga Trinity for my Mac because they said they support Mac, only to find out Razer is way behind the times. Very disappointing Razer.
     
  8. gogobizkit

    gogobizkit New Member

    Recently bought a Naga Trinity to replace my Naga 2014 (which still worked fine after the Catalina update) only to find that none of the buttons/lights can be configured.
    Synapse just ignores the changes.
     
  9. soleluna

    soleluna New Member

    Man im still using High Sierra LOL there is no way im gonna update to Catalina and fucked up everything..!!
     
    PT.Singer likes this.
  10. Ramune_Club

    Ramune_Club New Member

    Thank you Razer, for creating this complication.

    Just spent 120+ euros for a new gaming setup for mac, near useless after one day when i updated.
    Please fix this. Might even return my mouse after christmas, tbh.

    Thank you again, for this pain
    around Christmas, as well.
     
    jmsrw likes this.
  11. synsityr

    synsityr New Member

    YRMY but There's one more thing you guys might want to try. (I thought I had enabled it, but it didn't stick)

    Turn on Input Monitoring, as above (although mine now says both RzUpdater.app AND RzDeviceEngine.app)

    Screenshot 2019-12-30_16-03-09-307.png


    but also:
    In Activity Montitor, Force Quit the RzUpdater app. It should restart the Synapse app. It will ask you (well, it did for me) to enable allow the app to control you Mac. Turn it on. (it's under Acessibility - RzDeviceEngine.app)

    Screenshot 2019-12-30_15-55-09-735.png

    This finally let me properly re-map my DeathAdder Elite buttons.
     

    Attached Files:

    aciddaddy likes this.
  12. ZtereoHYPE

    ZtereoHYPE New Member

    for me it still asks to enable razer USA ltd under system preferences but I already did that
     
  13. GreyGecko

    GreyGecko New Member

    Ok, I think I figured it out. I tried the previous thing on the larger post above, but RzUpdater.app was already on the approved list, so that wasn't my problem. What I ended up doing was manually adding Razer Synapse itself to the approved list on Security & Privacy. To do it, press the plus button below the approved list, then select Razer Synapse from the app list. I added the app itself as well as RzDeviceEngine.app to the list and it works perfectly. Looks like it is a security issue with Mac.
     
    Klaudejr likes this.
  14. uhohuhoh

    uhohuhoh New Member

    I have a 2012 Mamba that connects to Synapse, but a Firefly that I just bought two days ago does not. I tried adding both Razer Synapse and the RzDeviceEngine to Input Monitoring and neither worked unfortunately.
     
    Last edited: Jan 11, 2020
  15. Klaudejr

    Klaudejr New Member

    This worked for me. Thanks
     
  16. aciddaddy

    aciddaddy New Member

    This worked for me. Thanks a lot!
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >