Synapse won't start

Discussion in 'Razer Synapse' started by Simons_graffiti, Sep 12, 2022.

  1. Simons_graffiti

    Simons_graffiti New Member

    Restarting the PC did not help. Reinstalling too.Everything was tried.
     

    Attached Files:

  2. champpp24

    champpp24 New Member

    Please help my brother, you've already lost me as a loyal customer, but you have a chance to keep my brother as one, help him ASAP :mad_: @Razer.Speedcr0ss @Razer.Zionzedd
     
    Razer.Speedcr0ss likes this.
  3. FiszPL

    FiszPL Well-Known Member VANGUARD

    Be sure, that you have the newest .net and visual c++ redistributable installed. If not install them, and restart PC, then check if Synapse is running.

    If it's still not running do few more steps:
    • Uninstall Synapse
    • Download & run this tool: https://rzr.to/Tf53xj to remove any razer drivers/leftovers
    • Then restart your PC
    • After reboot install Synapse again (as administrator).
     
  4. Simons_graffiti

    Simons_graffiti New Member

    @FiszPL I did everything but it didn't help.
     

    Attached Files:

  5. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Are you connected to a VPN? If yes, please disable and connect to another network that is not admin-restricted and see how it goes.
     
    FiszPL likes this.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >