Synapse3 does not recognize TartarusV2.

Discussion in 'Razer Synapse' started by AxolotRazer, Sep 2, 2022.

  1. AxolotRazer

    AxolotRazer New Member

    As of version 3.7.831.83015 Synapse 3 has stopped recognizing my Tartarus V2 device. I already followed the steps of the video that exists on youtube and nothing. I've already tried all the steps that tech support people always recommend, I can't claim my warranty because it's expired. They should disappear Synapse3 is bad software, I'm sorry that Razer has invested money in that driver that has given me problems all my life.
     
    pancholr likes this.
  2. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Did you try downloading and installing the Razer Device Detection Troubleshoot tool? Otherwise, uninstall the Razer Synapse and other Razer-related files by running the Razer Driver Clean-up tool: https://rzr.to/Tf53xj. Once done, please restart your computer and reinstall the Razer Synapse 3.0.
     
    pancholr likes this.
  3. AxolotRazer

    AxolotRazer New Member

    Hello, thanks for attending. Yes, I tried those 2 things and the problem persists.
     
  4. JunaNougsan

    JunaNougsan New Member

    Re-install Synapse. If that doesn't work, reach out to Razer Support and let them know that this problem exists so that they can fix it for the next update.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >