Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Tartarus Pro doesn't get recognized

Discussion in 'Razer Support' started by LeoSLamas, Jul 28, 2020.

  1. LeoSLamas

    LeoSLamas New Member

    Hi all,

    I already have a Razer Mamba Elite and it's working perfectly. I also own a Redragon Mitra rgb keyboard.
    So now I've bought a Razer Tartarus Pro and was so excited to use it!

    It arrived today, and when I plugged in my PC usb port it didn't do anything... I mean, nothing happened like the Mamba Elite which starts to shine with all its leds.
    Then I tried another USB port and finally it got recognized, blinked a few leds, Synapse showed the Tartarus Pro and started loading something that took forever, so I tried rebooting.

    Now everytime I plug it in the USB port Windows instantly shows an error 43 in the Device Manager. Something like "Device Descriptor Request Failed".

    Can anyone help me? Does that mean my device is broken?
     
  2. shubhankarsahu

    shubhankarsahu New Member

    try on different USB Port and hope you are not using it with USB hub that causes problem in working. connect tartartus pro directly to the PC
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >