Tartarus Pro - Synapse 3 not saving key changes

Discussion in 'Razer Synapse' started by metis1, Nov 1, 2019.

  1. metis1

    metis1 New Member

    My Tartarus Pro just landed, and I'm trying to set up profiles, but several reboots later Synapse 3 is not saving any changes to the device. My V2 works fine, and I can edit it and chroma settings for the Pro, but no key mapping.

    Anyone have any thoughts?
     
    pancholr likes this.
  2. BlackFireDragon

    BlackFireDragon Well-Known Member

    Try to reset device from synapse settings window. From what i remember Pro version only have local and cloud profiles so if make change change to settings should sync with cloud. When you reset device make sure to delete old profiles and just leave default make change sync this profile and reboot and see if something change.
     
  3. It may be different from your device problem, but in my case the key mapping is not applied after Windows wakes up from sleep mode and will be in the default key state. In Synapse 3, the device is displayed.
    Therefore I need to restart Synapse 3 after sleep mode.

    Other bugs I noticed
    The secondary actuation point is not functioning properly.
     
  4. metis1

    metis1 New Member

    Synapse 3 works just fine for my Tartarus V2. It just does nothing but change the color of the Pro.
     
  5. xARACHN1D

    xARACHN1D Well-Known Member

    could you send over some pictures? That would help.
     
  6. metis1

    metis1 New Member

    upload_2019-11-5_8-54-2.png
    after I click "save" the button stays dimmed, but it never does anything. using the V2, the key programmed turns green and I can move on to program the next key. On the Pro, if i click away I get this:
    upload_2019-11-5_8-55-41.png
     
  7. xARACHN1D

    xARACHN1D Well-Known Member

    Try setting a keymap. On the pulldown bar below the profile name.
     
  8. metis1

    metis1 New Member

    Nope. Still hangs. And still works fine with my V2.
     
  9. JR0nin

    JR0nin Well-Known Member

    The Tartarus is connected directly to the PC ports or via docking station ?
     
  10. xARACHN1D

    xARACHN1D Well-Known Member

    I was about to say this, Sometimes when using a USB hub Things wont work.
     
  11. metis1

    metis1 New Member

    PC directly, tried multiple USB ports, I'm thinking it's something with my profile on the server side, both my V2 and Pro can be edited for lighting and that works fine, but something with editing keys just doesn't work.
     
    0V3R_K1LL likes this.
  12. Thank you JR0nin and xARACHN1D.
    The problem with sleep mode was caused by USB HUB.
    This HUB has no problems with Tartarus V2, so I didn't think this was the cause.
     
  13. metis1

    metis1 New Member

    It's gotta be my profile. Tried the Pro on a different machine, and my profile doesn't work, but if I make a new profile, it works just fine on either machine.
     
  14. metis1

    metis1 New Member

    ... and the support email is bouncing because their mailbox is full.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >