Undervolting the Stealth 2019? (XTU and Throttlestop not working)

Discussion in 'Systems' started by figrin1, Feb 14, 2019.

  1. figrin1

    figrin1 Active Member

    Hey all.

    I'm trying to figure out how to undervolt this new Blade Stealth. It was piece of cake on my 2017 Blade 14, but so far XTU refuses to install ("platform not supported"), Throttlestop refuses to open ("mfc120u.dll was not found").

    Any ideas?

    Cheers
     
    pancholr likes this.
  2. hiddensanctum

    hiddensanctum New Member

    The XTU refusing to install is a known issue. There is a workaround to get it to install that seems to work. You can follow the directions in this article that worked for me. As for Throttlestop, haven't run into the mfc120u.dll. It worked without me having to do anything to it.
     
  3. figrin1

    figrin1 Active Member

    Thanks for this response. Motivated me to dig a little deeper into Throttlestop and it turns out I just need to install a Visual C++ update. Cheers! Now to see if I can enable undervolting in the BIOS...
     
  4. ShawnCroft

    ShawnCroft New Member

    Undervoting actually works,but tdp could be only controled by EC.There is a unchangable package pl1 in EC.
     
    figrin1 likes this.
  5. figrin1

    figrin1 Active Member

    Do you mean you were able to get an undervolt set in the BIOS? I wasn't able to get my modded firmware to show it--but maybe there were one or two things I failed to set to USER. Any guidance about how you got it to work would be much appreciated!
     
  6. ShawnCroft

    ShawnCroft New Member

    Yes,you can enable it in bios.Just enable ‘overclocking perfermance ’ in user by AMIBCP.
     
  7. Joikansai

    Joikansai Well-Known Member VANGUARD

    Wait do you have Blade stealth 2019? I don’t, but happy to know if you found how to unlock it on 2019 stealth. I didn’t succeed on 2018 Blade 15 model, it’s quite secured by Razer, unlike 2017 model. Probably it’s deleted.
     
  8. figrin1

    figrin1 Active Member

    That was the only setting you had to enable? I'm surprised. Usually you have to go line by line for each setting you want to be able to tweak. I'm pretty sure that I enabled that one, and I was able to get settings like SpeedStep to show up, but for some reason nothing has shown up for voltage adjustment.
     
  9. Joikansai

    Joikansai Well-Known Member VANGUARD

    I see. Btw cpu vr setting like imon etc, speedstep is unlock able on Blade 15 and only what I really need overclocking menu, cpu undervolting and peg port ASPM setting aren’t. Probably it’s due to keep system cool, let users manage them self may bring heat issues that brings to other parts defective like on 2016 and 2017 Blade 14. In fact I think there’s some improvement, less power limit throttling and clock frequency is more stable on 3,9 GHz with cooler system temperature on Blade 15 2018. Even though undervolting is still needed. With default setting and undervolt only and no clock limitation (Turbo Boost on), I get similar temperatures with my old Blade 14, mostly mid to low 80ish cpu. So I’m pretty happy with default Bios.
     

    Attached Files:

  10. ronthekid

    ronthekid New Member

    Do you have any idea? I tried to run on my Stealth 4k Kaby lake and failed everytime, was missing dll files, I downloaded them, and now this... been 2 days :slightly_sad:
    upload_2019-5-4_11-39-23.png
     
  11. figrin1

    figrin1 Active Member

    I'd make sure you have the latest version of Throttlestop, and make sure that you installed the Visual C++ updates that I mentioned in my earlier post. Errors like this have to do with .NET Framework, DirectX and C++.
     
  12. ronthekid

    ronthekid New Member

    Thing is, I checked everything and reinstalled/updated everything you mentioned and still ran into the problem. I guess I give up the topic of UV on this :slightly_sad:
    The C++ I installed from 2010 to 2017 version both x86 and x64 no help as well

    Oh before I gave up, last search gave me this: https://www.techpowerup.com/forums/threads/throttlestop-not-working.246574/
    Turn out to be not any version of C++ but the 2013 in particular, repairing the package fixed the problem ;)
     
    Last edited by a moderator: May 15, 2019
    figrin1 likes this.
  13. figrin1

    figrin1 Active Member

    ronthekid likes this.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >