New Huntsman v2 optical keyboard unresponsive | Razer Insider

New Huntsman v2 optical keyboard unresponsive

I got the Huntsman v2 Analog optical keybaord for Christmas because I wanted a new keyboard that would be a solid step up from my older keyboard where many of the letters on the keys have all but disappeared from all the typing and usage over the years. I'm not really a gamer but I've seen the Huntsman keyboard online and thought it looked awesome to have with the underlight effects on it and how it would also make it easier to see when typing on it. I tried setting it up today and I plugged in the USB cables but for some reason, it's completely unresponsive. I have a quite small Asus HDMI computer running Windows 11 so I figured the OS would be compatible at least. I'm not really sure what I'm doing wrong and I'm feeling quite frustrated. I've gone back to the old keyboard to type this until the issue is solved and I've been switching back and forth between the two keyboards during the setup attempt. I've also downloaded the Razer Synapse software to see if that would get the keyboard working but still no response from it when trying to type on it. What am I doing wrong?

Any help greatly appreciated! 🙂

This topic has been closed for comments

10 Replies

I have an issue too with my huntsman v2, as soon as windows 10 loads synapse 3 by start, it gets unresponsive, i can use it in bios or unistall synapse 3 and it works fine. Hackers??? 270$ keyboard and not working fine, hmpf!!!
Userlevel 7
You can try updating firmware if you haven't done it yet.
Also you can try removing synapse, and use this tool to remove all razer drivers:
Then restart your PC and install Synapse again.
Its not solved, tried this morning, and after shutdown last night, and boot this morning the huntsmam v2 not responding as soon as i activate razer synapse 3.0, pc is clean!!
Userlevel 7
One question - do you have Intel or AMD CPU?
AMD 1950x the old beast, its very anoying to unplug and reconnect, i always tought razer is pro hardware!!! There is no firmware update avaible for the huntsman v2!!! Grrr
Userlevel 7
I'd try updating AMD chipset drivers from AMD website.
Also try updating your BIOS to the newest version.
I did just update the AMD chipset drivers, there is no newer Bios for my computer, after restart and install the chipset drivers, the same issue, thats not good sign, thanks for try helping me. cya and thanks
So update on my keyboard situation: It still shows no sign of life, seemingly no matter what I try to make it work. I tried this tutorial for my specific model today with the following steps, as per the official manual:

1. Unplug the keyboard.
2. Press and hold the "Escape" button (Esc), "Caps Lock" button (Caps), and Space Bar.
3. Plug-in the keyboard to a USB port.
4. Release all keys

It still doesn't work. I also saw a YouTube video where someone tried this and made it work, which leaves me completely puzzled as to why it won't work when I try it. Another video on YouTube suggested I should hold the space bar and the fn key in for three seconds to make the keyboard turn on, but alas, no luck there either. At this point I'm tempted to go to the store where the keyboard was purchased and get a new one but seeing as I was already there earlier this January to tell them about the issue, they tried it on a computer of theirs and made it work supposedly (they tried it in another room for staff members only so I couldn't see for myself that they made it work) and the fact that it's quite an expensive gift I got for Christmas, I should preferably keep it but it just won't seem to work for me no matter what method I try.

What do you guys here suggest I should do?
As of March 1st, the keyboard still won't work when plugging it into my computer and it still frustrates me to no end. Am I alone in experiencing this or has anyone else here encountered this and found a way to solve it? I've tried literally every trick in the book I've come across but nothing seems to work at all!
Happy update: I FINALLY got my keyboard to work today, after having decided I wasn't gonna give up on it seeing as it was a rather expensive Christmas gift from my mom and I didn't wanna have it completely go to waste just lying around. So I took it back to the store today along with my computer so the staff there could see for themselves what my issue was. And after having explained my issue and months long frustration to a staff member, he took the keyboard and my computer in a "staff members only" room (like staff has done with the keyboard in the past) and he got it to work! When he came back out to the counter, he told me specifically which cable needed to go where (it was the thin little cable that needed to go in the back of my computer, not the bigger USB cable) and on my way back home, I was excited to see if it would actually work this time but I also set myself up for disappointment again because I didn't wanna get my hopes up too much after having been disappointed twice before. But now when I got home, I set the keyboard up and inserted the small cable in the back and it FINALLY worked!! I don't know why it took this long for it to work but it's now officially up and running and I'm typing this post on the keyboard right now!

This definitely made my Saturday! 🙂