How do you sync Thermaltake RGB Plus with Chroma? | Razer Insider

How do you sync Thermaltake RGB Plus with Chroma?

  • 24 December 2018
  • 17 replies
  • 127 views

As the title says. I see all over that Thermaltake RGB Plus is advertised to sync with Chroma, but I see no option to do so and there's no instructions. Anyone know how to do this?

This topic has been closed for comments

17 Replies

It was stated in sub-text that it was coming in December, but I'm guessing that date is going to slip. Looking forward to when it works.
Userlevel 6
All will be answered at CES, in little over a week. 😉
Userlevel 3
RazerThe_Fiend
All will be answered at CES, in little over a week. ;)


Really looking forward to it! But can't find anything regarding it even though CES starts today, can we expect to hear about it before the CES is over on the 11th?
I would also like to know, on the main page of razer it talks about it. but when you click on it, it doesnt give you any info on how to download or when it will come out
Userlevel 6
TheFranubian
Really looking forward to it! But can't find anything regarding it even though CES starts today, can we expect to hear about it before the CES is over on the 11th?

KTheory
I would also like to know, on the main page of razer it talks about it. but when you click on it, it doesnt give you any info on how to download or when it will come out

The update is now live. You should see a new module called "Chroma Connect" in Synapse. Please ensure you have updated the partner software as well to a version that supports Chroma Connect (I've personally verified that Thermaltake software has been updated to make use of this).
okay now how do I get it to work it just keeps telling me that chroma is not installed
Aeserath
okay now how do I get it to work it just keeps telling me that chroma is not installed


I had this issue. TT software would tell me that chroma needs to be setup. So I went to control center to delete razer synapse. Then it prompted me I can either repair/install chroma connect. which I did. Then it started to work.
RazerThe_Fiend
The update is now live. You should see a new module called "Chroma Connect" in Synapse. Please ensure you have updated the partner software as well to a version that supports Chroma Connect (I've personally verified that Thermaltake software has been updated to make use of this).

How about Ducky? i see the option but it makes the keyboard go black and stays that way.
Userlevel 6
ocp15k
How about Ducky? i see the option but it makes the keyboard go black and stays that way.

Which Ducky keyboard are you using specifically? Are you using Advanced effects? If so, make sure to apply some lighting to it inside Chroma Studio in at least one of the layers. Quick effects should just work without any further configuration.
RazerThe_Fiend
Which Ducky keyboard are you using specifically? Are you using Advanced effects? If so, make sure to apply some lighting to it inside Chroma Studio in at least one of the layers. Quick effects should just work without any further configuration.

Shine 7. Yep tried that also, nothing is working
Userlevel 6
ocp15k
Shine 7. Yep tried that also, nothing is working

I see. I assume you have tried restarting your PC once as well.

I don't have a Shine 7 at hand to test this myself. If you could PM me the screenshots of how the 2 software look in the final state, I can definitely escalate this issue to Ducky.
RazerThe_Fiend
I see. I assume you have tried restarting your PC once as well.

I don't have a Shine 7 at hand to test this myself. If you could PM me the screenshots of how the 2 software look in the final state, I can definitely escalate this issue to Ducky.


Hi there, thanks for taking a look for me. Here is another thread that I started : /ducky-shine-7-chroma-connect-doesnt-work.45927/

one of the users posted a gif of exactly what I did. Mines the same but I have no lights.

on reddit : https://www.reddit.com/r/DuckyKeyboard/comments/ae9u7q/razer_releases_update_for_chroma_connect_but/

works for some but me.

Funny thing is, after a reboot, Synapse doesn't detect the ducky keyboard anymore.
edit: repaired it and its detected the ducky keyboard but still no lights
RazerThe_Fiend
I see. I assume you have tried restarting your PC once as well.

I don't have a Shine 7 at hand to test this myself. If you could PM me the screenshots of how the 2 software look in the final state, I can definitely escalate this issue to Ducky.

so I have restarted my pc and that did not work I tried reinstalling both programs and that did not work it detects the fans but thermal takes software says that chroma is not running or installed chroma can see the fans but cant change anything
Everything is syncing for me! Thank you!

I will add a couple minor bugs to this post that I discovered:

1. The TT Riing 120mm RGB fans appear to have either a higher brightness, or a lighter color than the TT Riing 240mm RGB fans.

2. I would love it if the TT RGB Plus software would not require me to go in and turn on the sync after my computer restarts erach time. Right now, I have to enable it i nthe settings menu each time. Obviously, this might be a bug to give to Thermaltake, but at least it's out there.
Aeserath
so I have restarted my pc and that did not work I tried reinstalling both programs and that did not work it detects the fans but thermal takes software says that chroma is not running or installed chroma can see the fans but cant change anything


A Ducky rep responded with: Hi
The shine 7 will support Razer Chroma, You can use razer synapse functions as long as you own a razer chroma product ( Razer headset or mouse for example ). do you have any razer chroma products?
Userlevel 6
VizardXY
Everything is syncing for me! Thank you!

I will add a couple minor bugs to this post that I discovered:

1. The TT Riing 120mm RGB fans appear to have either a higher brightness, or a lighter color than the TT Riing 240mm RGB fans.

2. I would love it if the TT RGB Plus software would not require me to go in and turn on the sync after my computer restarts erach time. Right now, I have to enable it i nthe settings menu each time. Obviously, this might be a bug to give to Thermaltake, but at least it's out there.

Thanks for the report. Unfortunately, neither of those are in our control.

1. Synapse doesn't send brightness values to the devices, only RGB color values, which would be the same for all TT devices. The difference in visible color might be because of LED density or difference in construction materials (just speculating here).

2. That's definitely a feature that TT would need to implement. We'll pas on this request to them.
No luck. Razer Synapse 3 is version 3.4.109.10405 and TT RGB Plus is version 1.2.6. I have Riing Plus Trio+Floe AIO pump, TT X1 RGB keyboard, TT RGB Iris mouse and they work just fine with TT RGB plus. Chroma Connect option does not want to work. I tried reinstalling the program, repairing synapse, and multiple reboots. Nothing seems to be working for me. I may have to wait for RS to get out of beta or TT to update again