Razer Blackshark v2 Pro 2023 does not get detected on Synapse 3.0 | Razer Insider
Question

Razer Blackshark v2 Pro 2023 does not get detected on Synapse 3.0

  • 19 July 2023
  • 35 replies
  • 5933 views


Show first post

35 Replies

Userlevel 1

Hey,

 

They sent a message 3 days ago

 

“We attempted to reproduce the issue that you are experiencing, but we are unable to do so. This means that your issue maybe isolated due to external factors such as third-party software, device configuration/settings, or corrupted files/Operating System.”

 

And their final solution is that formatting the PC. (Even though I already told them I tried with Windows 11 & freshly formatted Windows 10)

 

Time to say good bye.

Sadly I have to confirm:
I got the same issue with my brand new Blackshark V2 Pro 2023 and the descibed workaround did help (3rd attempt).
This is absolutely ridicolous (and I’m coming from Logitech G Hub!!!)
Seriously considering a return on this otherwise nice headset.

Hey Guys,

I bought the Blackshark V2 PRO (2023) yesterday.

Had the same problem.

But I found a quick solution.

Go to the BLackshark V2 PRO (2023) Firmware Updater

https://mysupport.razer.com/app/answers/detail/a_id/13081/

 

(download the firmware updater, the program does not care if you need an update for your headset or not. Just run the program)

 

While starting the program, synapse will close itself. 

Do the update (or not, if it says you are up to date)

close the updater and start synapse again.

 

It worked for me

 

Greetings

This workaround solved the issue for me. Million thanks!

Nonsense.
It's horrible that there are so many people all over the world having the same problem, that they still blame operating systems and don't doubt themselves. I did the right thing by returning the headset.
This will be the first and last razer device I've used and I'll be talking about it to anyone considering buying a razer.

Userlevel 1

Since I did not get any reply from Zionzedd through PM, can any other Razer Support Member assist me  about the issue? 

 

I can share the logfiles if it helps. 

 

Or can anybody assist me about how to create a support ticket?

 

Hey,

 

They sent a message 3 days ago

 

“We attempted to reproduce the issue that you are experiencing, but we are unable to do so. This means that your issue maybe isolated due to external factors such as third-party software, device configuration/settings, or corrupted files/Operating System.”

 

And their final solution is that formatting the PC. (Even though I already told them I tried with Windows 11 & freshly formatted Windows 10)

 

Time to say good bye.


This must probably be a joke, we 2 friends bought the headset at the same time, and 2 have the same problem. A solution offered by a company like Razer should not be to format your pc. I can't even use own software for that much money. I don't think this issue is caused by a software on my computer, because when I watched the videos on youtube, those who installed the old version were able to use the application without any problems. Maybe I don't know, is there a way to install the old version? If you can't fix the new one, at least share the old version that works properly.

Userlevel 7

Hi @Wxzu2017,

 

I already responded to your message asking further information so I can properly document your concern and escalate it to the relevant team. I also apologize for the late reply, I just returned from my day off and missed your message. Your cooperation and patience are greatly appreciated. 

I had the same issue. What I found after going through tons of threads and troubleshooting is other USB 3.0 devices/cables interfering the signal. I used the extension cable that came with the headset and placed the dongle away from CPU and other USB cables and it worked.

 

https://mysupport.razer.com/app/answers/detail/a_id/5550

Hi, I have the same problem….
Impossible to detect my headset (the same headset as you) so impossible to have the Audio tab….
I have already tried uninstalling/reinstalling etc.
Nothing works.

EDIT:i finally succeed! It was painful tbh…

There is my steps:

(clean every install you did even in your appdata)

1 - Install synapse 3  (DON’T PLUG THE DONGLE! It’s very important!) => https://www.razer.com/fr-fr/synapse-3
2 -  Install THX Spatial Audio => https://www.razer.com/fr-fr/thx-spatial-audio
3 - Plug the dongle, it will propose you to update your software, then it will detect your headset.

i hope it will work for you….

 

Thank you so much. this worked. I’ve been troubleshooting all day, no progress. I was at the store to buy a new headset when I found your post. 
 

Thank you a million times.

Seems like there is no certain solution for this.

Reply