Razer Blackshark V2 Pro (2023) static while streaming on discord | Razer Insider
Question

Razer Blackshark V2 Pro (2023) static while streaming on discord



Show first post

68 Replies

I had this same issue streaming in discord and I tried it in another USB slot and my friend said it was solved.  

Userlevel 3

Same issue.  I switched to another headset and the static disappeared.  Definitely related to the headset somehow.

Userlevel 7

Hey 8 days later got my headset recently and i have the exact same problem as everyone above. Seems to be a common issue glad to see there's workarounds and a solution on the way

 

 

Hey bob31702 and to everyone on this thread! There's no confirmation yet of the official fix/workaround to the concern. I’ll keep monitoring this thread until our Devs Team relays the resolution. Thanks for your patience.

Userlevel 1

Still using this headset, keeping up the confidence for the Razer Dev Team because this headset has already hit feats for gaming headsets never seen before. The mic is spectacular and audio is great, so I am hopeful that the fix for the issue is released eventually with a firmware update to allow us to use the headset to its fullest!

Hello, I just received the headset today as well and after having a friend experience very loud unbearable static while viewing my Discord streams I did some troubleshooting and found a setting that fixed the issue for me.

This fix is obviously specifically for Discord.
Make sure that this Setting is unticked, restart your stream and have someone confirm that the static noise is gone.

 

 

Userlevel 1

Hello, I just received the headset today as well and after having a friend experience very loud unbearable static while viewing my Discord streams I did some troubleshooting and found a setting that fixed the issue for me.

This fix is obviously specifically for Discord.
Make sure that this Setting is unticked, restart your stream and have someone confirm that the static noise is gone.

 

 

The issue with this solution is the audio does not pick up from Google or any other web browser, only from certain games it seems. The issue is only on this specific headset, not any I have used before, so something Razer is using in the headset’s firmware is interfering with the experimental method Discord uses, which no other headset has a problem with. I’m sure Razer will find out the issue and resolve it in time, but this is only a temporary fix for now.

Hi everyone! Razer is aware of this issue and is working on a fix. Our Devs Team confirmed the behavior last May 22, 2023, that a popping/buzzing sound was heard from the live stream in Discord or any other platform while using the BlackShark V2 Pro. There’s no exact date when the official workaround/fix will be released. I’ll keep everyone posted. You may check your Razer Synapse 3.0’s update section from time to time. Feel free to submit a case to our Support Team or send me a PM. Thanks for everyone’s cooperation and understanding. 

 

Hello, is there an update on the progress of this fix?

This is happening to me on OBS. It's such an annoying issue and is quite literally impacting my stream of revenue. I hope this is fixed quickly.

Also I know it’s the V2 Pro's 2023 since when I disable the device the issue is no longer there :) that and I have to use my Karen V2 TE just so I can stream. It really is issue after issue and it makes me want to go to the competition.

Userlevel 1

Hey 8 days later got my headset recently and i have the exact same problem as everyone above. Seems to be a common issue glad to see there's workarounds and a solution on the way

 

 

Hey bob31702 and to everyone on this thread! There's no confirmation yet of the official fix/workaround to the concern. I’ll keep monitoring this thread until our Devs Team relays the resolution. Thanks for your patience.

Thanks for staying in touch but this should've been corrected by now considering it’s been almost a month. This problem is going to be a deal breaker for a lot of people. I’ve already returned a previous headset so I'd hate to have to return another

Userlevel 1

Hey 8 days later got my headset recently and i have the exact same problem as everyone above. Seems to be a common issue glad to see there's workarounds and a solution on the way

 

 

Hey bob31702 and to everyone on this thread! There's no confirmation yet of the official fix/workaround to the concern. I’ll keep monitoring this thread until our Devs Team relays the resolution. Thanks for your patience.

Thanks for staying in touch but this should've been corrected by now considering it’s been almost a month. This problem is going to be a deal breaker for a lot of people. I’ve already returned a previous headset so I'd hate to have to return another

This looks to only be an issue with OBS / Discord at the moment (although I have only had issues with the latter, OBS seems to be fine for me). I don’t see it as a deal breaker, and I am sure Razer is working on a fix for these specific areas of use, but it shouldn’t deter people from buying the headset either because it seems largely like a software issue rather than a hardware issue. It’s new tech from Razer and bugs allow them to fix it for current and future products using the newer microphone, so I’m willing to wait for a fix. For now, I have just disabled experimental sound methods on Discord and it works for all the games I screen share.

any update? very troubled.

Hi everyone! Razer is aware of this issue and is working on a fix. Our Devs Team confirmed the behavior last May 22, 2023, that a popping/buzzing sound was heard from the live stream in Discord or any other platform while using the BlackShark V2 Pro. There’s no exact date when the official workaround/fix will be released. I’ll keep everyone posted. You may check your Razer Synapse 3.0’s update section from time to time. Feel free to submit a case to our Support Team or send me a PM. Thanks for everyone’s cooperation and understanding. 

 

Many people rely on Discord screen share for their occupations.  As a loyal customer I expect this issue to be resolved quickly.  

Userlevel 2

is this going to be fixed or not????

I re-enabled experimental method to capture audio from apps in discord (also using legacy audio subsystem) and re-tested and streaming seemed to work without crackling. Not sure if there was a fix on Razers side or discords side, but I figured I would throw it out there if anyone else hasn’t  re-tested lately.

Userlevel 1

Hi everyone! Razer is aware of this issue and is working on a fix. Our Devs Team confirmed the behavior last May 22, 2023, that a popping/buzzing sound was heard from the live stream in Discord or any other platform while using the BlackShark V2 Pro. There’s no exact date when the official workaround/fix will be released. I’ll keep everyone posted. You may check your Razer Synapse 3.0’s update section from time to time. Feel free to submit a case to our Support Team or send me a PM. Thanks for everyone’s cooperation and understanding. 

 

Any news about this?

I’ve been told when I share my stream on discord that there is a very loud static, they have to mute my stream if they want to watch.

I’ve also noticed a slight hum (static) when opening new tabs or when playing certain games, this is a great headset, just sucks that these issues are bringing it down.

Userlevel 2

Hi everyone! Razer is aware of this issue and is working on a fix. Our Devs Team confirmed the behavior last May 22, 2023, that a popping/buzzing sound was heard from the live stream in Discord or any other platform while using the BlackShark V2 Pro. There’s no exact date when the official workaround/fix will be released. I’ll keep everyone posted. You may check your Razer Synapse 3.0’s update section from time to time. Feel free to submit a case to our Support Team or send me a PM. Thanks for everyone’s cooperation and understanding. 

 

Any news about this?

your devs have know about this issue for a long time so it should have been fixed by now if its a software issue, if it is a hardware issue then you need to let people know so they can return this headset and get another one that actually works to a satisfactory level

Userlevel 1

AGREED, LET US KNOW WHAT IS GOING ON

Userlevel 1

It's just about time to start flooding Social Media about this. Let EVERYONE know.

Junk headphones

I’ve had a decent time with razer products thus far, would be a shame to have to take my business elsewhere.

Userlevel 2

seems like they don't care 2months no fix and generic responses. This was my first razor product and it will be my last gg razor

Userlevel 2

FOR GAMERS , BY GAMERS…….. really??? i think alot of gamers stream so may want to rebrand. NOT FOR GAMERS , BY LAMERS

Userlevel 1

I'm extremely surprised this issue hasn't been resolved by Razer given the time frame. I went through support which was just a never ending cycling of different agents asking me to do the the same steps. I even asked them to stop requesting me to do more testing, and for their technical department to do it themselves - which they ignored. I eventually just gave up and let the ticket close by itself.

 

This is my first time buying a Razer product - very happy with the product quality, but their software and support system is extremely disappointing. Please solve this Razer or I'll be returning my product.

Userlevel 1

I won’t be returning this headset because the only negative is Screensharing on a platform that intentionally uses EXPERIMENTAL methods to pick up audio from sources like Google and Chromium-based web browsers, but I do hope the developers push out a patch soon because there isn’t a single headset other than the Blackshark V2 Pro that has this loud bussing issue when sharing game audio on Discord. 

Disappointed that it has taken this long for a fix as I was a headset pre-release tester for the headset itself through BestBuy, with my only complaint being this issue, so I hope it can be resolved in a more caring and timely fashion than what has already been seen. This headset has been great and has hit every mark, but developer support has been very lackluster and not a single software update has been pushed to date attempting to fix issues.

Reply