Razer devices constantly disconnecting and reconnecting | Razer Insider

Razer devices constantly disconnecting and reconnecting

  • 29 December 2022
  • 77 replies
  • 40647 views

Userlevel 3
My razer devices disconnect and reconnect out of nowhere. When it starts this cycle of disconnects and reconnects, it usually happens for several minutes straight.

This is not a USB or motherboard problem. It happens to my razer keyboard and mouse at the same time. My Chroma lighting on my keyboard will revert to default color design when it disconnects, and then back to my preferred chroma settings when it reconnects. It disconnects and reconnects every couple of seconds until I reboot. Even if I plug my keyboard and mouse into different pots, the problem persists. I've tried plugging my mouse and keyboard into USB ports that I know don't have a problem, because I have other devices plugged into them that stay connected all the time. However, the problem persists no matter which USB ports I use.

My mouse experiences the exact same problem at the same time, which makes it nearly impossible to use, because when it disconnects, I obviously have no input. It reconnects for a second or 2, but then immediately disconnects again.

I have tried to hard-close the synapse software while it's doing this, but it gets stuck. Even if I close the software when its doing this, it continues doing it until I reboot.

I have my synapse drivers up to date. I downloaded and installed the new Viper Ultimate firmware. Everything is up to date.

Currently using Razer Blackwidow Chroma V2 keyboard, and Viper Ultimate Wireless mouse.

(IMPORTANT) The only way I can avoid this problem is to uninstall synapse completely, rendering most of the features obsolete. I want Razer to be aware of this, because these products are expensive, and most of the features of the products are built into a software bundle that does not work for me. There are other threads on this forum about this exact same problem, that were left open with no resolution from 2021. Razer must be aware of this, if they aren't, I will continue posting about it until they are.

77 Replies

Userlevel 2
I have the same problem, the software is bad, very bad! Having to many bugs to use. Sometimes it just skips keys while I'm typing or repeating one continuesly until I hit another key.

Razer knows about the bad softwae, makes updates egularly, but each and every update still has the main problems: disconnectings, skipping and repeating keys!

These are truly the last Razer devices I will ever buy!

Please help to get this to Razer!
Userlevel 1

Same issue, Please help!!

Userlevel 7

Hey BasedShadyBright_Light, and Deanduffus! Does the issue happen while plugging the devices into another computer? Please try removing all Razer-related files from your PC through the Razer Driver Clean-up tool: https://rzr.to/Tf53xj. Once done, please restart your computer and install the Razer Synapse 3.0 and its supplemental updates. Let me know how it went.

Hello,

I have the same problem. Through some research I was able to find that this has been a problem for years. It is something related to the Synapse 3 program. If I exit out of Synapse and all of its’ apps then my keyboard will function as a normal keyboard. The moment Synapse is up and running my keyboard will disconnect and reconnect every 4 seconds, making it practically unusable.

Razer support has given out the basic troubleshooting steps to everyone with about the same amount of success. It doesn’t seem to be an issue with the Windows OS, or USB hubs, and will recreate if you connect the products to a different computer the moment Synapse is up and running and loads your information. It even persists through a complete Windows reinstallation, including a complete Synapse wipe and reinstallation. 

The link below has a couple of solutions that might work for people, including lowering your RGB settings below 50%, and running Synapse 3 under Windows 8 Compatibility settings:

 

A work around that I have figured out so far is to let Synapse get up and running, and then log out. I continue as a guest and it loads a blank slate for my keyboard. I mostly use it for the keyboard macros which I can export from my profile and import using the guest profile. A more permanent solution might be to tinker settings down in the peripherals until they stop disconnecting every few moments, and then working up from there. Hopefully they actually fix this problem.

Hopefully this helps someone!! 

Userlevel 7

Hello,

I have the same problem. Through some research I was able to find that this has been a problem for years. It is something related to the Synapse 3 program. If I exit out of Synapse and all of its’ apps then my keyboard will function as a normal keyboard. The moment Synapse is up and running my keyboard will disconnect and reconnect every 4 seconds, making it practically unusable.

Razer support has given out the basic troubleshooting steps to everyone with about the same amount of success. It doesn’t seem to be an issue with the Windows OS, or USB hubs, and will recreate if you connect the products to a different computer the moment Synapse is up and running and loads your information. It even persists through a complete Windows reinstallation, including a complete Synapse wipe and reinstallation. 

The link below has a couple of solutions that might work for people, including lowering your RGB settings below 50%, and running Synapse 3 under Windows 8 Compatibility settings:

 

A work around that I have figured out so far is to let Synapse get up and running, and then log out. I continue as a guest and it loads a blank slate for my keyboard. I mostly use it for the keyboard macros which I can export from my profile and import using the guest profile. A more permanent solution might be to tinker settings down in the peripherals until they stop disconnecting every few moments, and then working up from there. Hopefully they actually fix this problem.

Hopefully this helps someone!! 

 

Thanks for sharing, 22Kairi

Hi  BasedShadyBright_Light, and Deanduffus. Please let me know if  any of the above steps posted made any difference. Thanks for your cooperation.

Same problem. Definitely an issue stemming from Razer Synapse. Uninstalled it and no issues now.

Even though this thread is 6 months old… theses particular issues still persist. I had purchased a new Naga Pro wireless mouse & Blackwidow V4 Pro keyboard. Both devices would randomly disappear from Synapse.

 

I don’t have time to waste nor am I getting paid to beta test these items, so I returned both products. I wish it were as easy to return/uninstall Synapse from a PC (without the use of third party registry & file cleaners). 

Same thing happening with Synapse last version 3.8.731.72514
Blackshark USB sound card disconnecting/reconnecting and freezing PC.
It happens even if the hardware is disconnected, so the problem is this trash software.
This problem is aleatory to me, sometimes happens and I need to restart the pc, then sometimes works…
My synapse is running without any addon.

Userlevel 1

The best solution i found for this is deleting razer synapse, its been fixed ever since, heres what i did :
1. Fully Uninstall Razer Synapse in either control panel or “Apps & Features” (restart after)
2.Locate the hidden Razer synapse apps and delete them usually in “C:\Program Files (x86)\Razer”
3. do a DISM after uninstalling razer synapse 
heres a video that shows how to properly do a DISM :


4. After the DISM is complete uninstall the Razer Device from device manager and then restart
5. I wouldnt recommend reinstalling the synapse app again it might just bug out again after a few weeks

I have the same problem. But it's not the software, it's the cheap USB connector. I have a Razer Base Station V2 Chroma and whenever I wiggle the USB connection very slightly I have reconnects. I have the same thing with my Huntsmann V2 keyboard. The USB plugs of the Razer devices are very very cheap!

My razer devices disconnect and reconnect out of nowhere. When it starts this cycle of disconnects and reconnects, it usually happens for several minutes straight.

This is not a USB or motherboard problem. It happens to my razer keyboard and mouse at the same time. My Chroma lighting on my keyboard will revert to default color design when it disconnects, and then back to my preferred chroma settings when it reconnects. It disconnects and reconnects every couple of seconds until I reboot. Even if I plug my keyboard and mouse into different pots, the problem persists. I've tried plugging my mouse and keyboard into USB ports that I know don't have a problem, because I have other devices plugged into them that stay connected all the time. However, the problem persists no matter which USB ports I use.

My mouse experiences the exact same problem at the same time, which makes it nearly impossible to use, because when it disconnects, I obviously have no input. It reconnects for a second or 2, but then immediately disconnects again.

I have tried to hard-close the synapse software while it's doing this, but it gets stuck. Even if I close the software when its doing this, it continues doing it until I reboot.

I have my synapse drivers up to date. I downloaded and installed the new Viper Ultimate firmware. Everything is up to date.

Currently using Razer Blackwidow Chroma V2 keyboard, and Viper Ultimate Wireless mouse.

(IMPORTANT) The only way I can avoid this problem is to uninstall synapse completely, rendering most of the features obsolete. I want Razer to be aware of this, because these products are expensive, and most of the features of the products are built into a software bundle that does not work for me. There are other threads on this forum about this exact same problem, that were left open with no resolution from 2021. Razer must be aware of this, if they aren't, I will continue posting about it until they are.

yes it stops after i end the task on the task manager and it used to start recording macros outa nowhere and i couldnt type, move or do anything with the keyboard until i went to the app and stopped the recording

Hi everyone,

I managed to fix the issue by uninstalling all the Razer software and then updating the firmware for my new Blackwidow Chroma V3 keyboard because that’s the pheripheral that was causing issues with the driver.

Just go to this website and download the firmware update for all of your devices and make sure to have the latest version installed: https://mysupport.razer.com/app/answers/detail/a_id/4166

Apparently Synapse 3 doesn’t install the required drivers as I originally thought

 

Userlevel 1

still disconnecting every few minutes, pain in the ass. done all updates, even ones that don’t apparently update through synapse cant use razer wireless products if you want to use their software as well. wtf hardwire everything and it works fine

I’m having the same issue.  The firmware I was on before on my Black Widow v3 Pro was 2.x (Sorry, I don’t have the exact version) and had issues with double key presses.  Last week I figured I’d do an update and saw v3.02.01_r1 was out.  It seems that was a mistake to jump to the latest.  While the double key presses appear to be gone, now I’m having issues with the stupid thing staying connected.  I also noticed that the led indicators for num lock/caps lock, ect randomly turn off and back on as well as a delay that I hadn’t noticed before if I press something like num lock the led will take 1-3 seconds to respond to the change. Super frustrating for how much I paid for this thing.

Adding to this… I’m finding even more frustrating things after the update.  I can no longer charge the keyboard with a power bank and have it work via wireless.  Battery life is MUCH worse and only getting ~1 day on a charge.  This keyboard is pretty much garbage on this version for wireless.  Is it possible to downgrade?

I’m having the same issues, and as I also produce and master music, having my headphones keep disconnecting and reconnecting every few minutes is VERY annoying. My razer Krakan’s have excellent sound quality, but when the software is shockingly bad, WHY???? Come on Razer, get it together! I use your keyboard, mouse, headphones and mouse mat, they should all work seamlessly on Synapse but they don’t, with the sound being the most annoying! Uninstalling Synapse for now, it shouldn’t have to be this way.

I have the same problem with Huntsman v2 TKL.

No matter what I tried, every time I launch certain games the keyboard keeps disconnecting.

Tried clean installation on Synapse and such, tried on another pc, same issues everywhere.

This is so bs to be honest.

Userlevel 1

I unfortunately had made the same experience with Razer wireless products but the problems the Synapse software produces are far worse than devices constantly disconnecting and reconnecting.

I bought a Blackwidow V3 Pro wireless keyboard and Viper Ultimate wireless mouse back in January 2023 and was frustrated by the problems with this keyboard clearly placed in the premium segment with it’s not so premium Synapse software causing it to randomly disconnect. I also had a Siren Mini, Blackshark V3 Pro wireless and a Mouse Dock Chroma.

The keyboard would randomly disconnect (especially annoying mid-game or mid-working) for one second or two. This led to me not being able to do any inputs and the keyboard changing LED’s to the standard configuration (RGB mode, while my configuration was red). Sometimes it looked like the keyboard just derped out and the first 3 rows of keys from the top went black and the rest remained in the configured colour. In the Synapse software the keyboard under devices indicated it’s loading and was darkened for those one or two seconds.
There was a solution to this problem with downgrading the version of Synapse to a version which wouldn’t install the newest update (unfortunately I cannot remember the version). This version didn’t have any bugs and the problem with the keyboard disconnecting was gone.

Because I was quite happy with the situation I bought the Blackshark V3 Pro headset to round up my periphals to only consist of Razer and not having lot’s of bloatware on my desktop. Unfortunately that was a big mistake as The problems I had with the keyboard disconnecting now happened to my headset. It would randomly disconnect and even more annoying is the fact that everytime the headset disconnected there was this beep-boop playing. I tried everything in my power but with no success. By accident I then installed the newest version of Synapse and experienced the full force of this bad programme. Now both my keyboard and headset would disconnect randomly and I couldn’t find the version I had installed earlier. Every downgraded version of Synapse I could find on the internet would automatically install the newest Synapse version. 

This was the first time I was reading all those threads and forums with ppl reporting the same problem. As I couldn’t find any fix for my issue I began searching for programms controlling the RGB of other devices and found OpenRGB which unfortunately couldn’t control the RGB of the Blackwidow V3 Pro. At this time I gave up and uninstalled Synapse as this would fix all the problems mentioned above but I cannot get over the RGB of the keyboard, the dock and mouse being completely random and not matching in colour.

That’s when I installed Synapse again after 2 weeks and I noticed for the first time that Synapse for some reason significantly affected the games performance. I am regularly playing Arma Reforger and I noticed that when Synapse was on I was getting around 40 FPS and with Synapse off 60 FPS. When I first noticed that issue I thought that I was doing something wrong or some other game was running in the background but after further testing I have not doubt that Synapse significantly effects game performance. 

But now to the end: I have now found no further solution to this problem, nor will I try to deal with it any longer, because I am a customer here of a company that places its products with its prices in the premium segment and the software ruins everything. I wish so much that Razer would release an official application (a kind of Synapse Lite) that controls the RGB'S alone. Just Razer posting a sign of life on these discussion forums and telling their customers that they are working on a fix would be nice, but I don't see it in a conversation that is 9 months of of a problem that is known for years and I think many who have posted here have been very patient and helpful, but I feel so screwed by Razer and if there is no fix here in the next 2 weeks I will get rid of all my Razer products, replace them with others and never think of buying from this company again.

I have the same problem, it keeps disconnecting all devices, whenever synapse starts. making it impossible to play any game.

pls fix it now.

Userlevel 5

Synapse 2 doesn't cause the disconnect problems, probably cause it doesn't recognize I have any of my razer stuff connected (synapse, not the PC)

I have 2 razer mice, razer keyboard, razer V1 headphone hub, razer firefly mat, razer mouse chord holder thingy & razer wireless charger (all of them chroma) I also have your RP2 & og chroma wireless charger (but that doesn't matter in this context)

 

Since synapse 2 doesn't recognize ANY of these, it has set them to default lighting (none of it synced together! Making your products look like cheap trash)

And NONE of the special keys do anything on keyboard or the mice.

 

As soon as I update to synapse 3, the constant usb disconnect issue happens. Downgrade to synapse 2 or a complete uninstall, and usb issues stop. (My win 10 is 100% up to date)

 

HOW ARE WE SUPPOSED TO USE YOUR OVERPRICED PRODUCTS, IF YOUR SOFTWARE IS ABSOLUTE TRASH?!?

 

RAZER YOU ABSOLUTELY ARE THE WORST OF THE WORST!!!!! This was the last straw, I'm moving on to your competition..

I bought a BlackWidow v3 Pro today, because i wanted to go wireless. It just doesn’t work, it keeps disconnecting all the time. 

I’m considering returning it and getting somethong from SteelSeries intstead.

Same issue here with Mamba TE

 

Userlevel 1

To everyone who is looking for a solution to only control the RGB search for SignalRGB. All my above mentioned problems are gone.

Same issues I have the speaker, gaming pad, mouse and keyboard. This is really getting old  Razer what is the deal ?? and how about a time frame for when you are going to FIX THIS ! 

+1 I’ve been running a wired Blackwidow KB, Nari Essentials BT headset for several years and was running synapse v2 for the main reason that it kept RBG set on the devices when you lock the PC - I would prefer to not see rainbow puke. It was 100% rock solid, zero issues.

 

My non-Razer mouse kicked the bucket and I decided to grab a Basilisk Ultimate as a replacement which isn’t supported by v2, so that forced my hand to reluctantly upgrade to v3 (or see rainbow puke on it constantly). Since then I’ve had constant battles with the headset randomly reconnecting making the booboop sounds which actually transmits into the calls if I’m not muted so everyone else hears this… I work from home so this gets super annoying in daily meetings etc.

 

When it reconnects I see the same symptoms described previously in this thread, the RBG for the KB and Mouse briefly resets as well which leads me to believe this is related to the software, not the hardware. Like most other people here I’ve tried different USB ports etc etc… it doesn’t help. I also have no issues with any of my other USB devices disconnecting randomly. Plus everything is rock solid connection wise on v2.

 

Often Synapse v3 just randomly completely crashes during startup and you need to kill and restart the app or it’ll brick on loading one of the devices (usually the mouse) where it’s stuck with the loading icon on that particular device so it’s just puking rainbows, generally only a full PC reboot fixes that.

 

I’m at the point where if something like SignalRGB allows me to set the RGB (I’m gonna go try this now ) I’m ready to jettison this v3 garbage software into the sun and rid it from my OS forever.

Reply