Razer Kraken Kitty robotic voice from mic | Razer Insider

Razer Kraken Kitty robotic voice from mic

  • 10 May 2020
  • 5 replies
  • 168 views

When I start talking, my voice sounds robotic to other people for a second and then goes back to normal if I keep talking. The robot noise doesn't play over mic monitoring, and changing the settings fixes it for a little bit according to my friends. It's really frustrating, no other pair of headphones has done this.

This topic has been closed for comments

5 Replies

Userlevel 3
Hi! Do you use microphone noise supression function in synapse 3? If so - try to disable it, when i use it - i have a robovoice in all voice programms, looks like it is broken.
My friends have told me it still does it even with the noise suppression off, I have no way to hear it myself. It was like that with both pairs I've owned.
Userlevel 3
Well, i have kraken TE and disabling this function helped me, plus quite rarely something happens and i have a constant robovoice and replugging to other usb port or back helps to solve it. Have you tried to use in synapse self hearing feature, just to check if robovoice happens. I really think it is some kind of soft issue since it is a second headset. Maybe synapse 3 uninstall will help, but you ll lose the features of this headset. Thats all the problems and solutions i found when i had a robovoice.
Hi! I have the same problem and it's getting quite annoying. Have you found any solutions? I've tried everything 😞
Userlevel 7
Quinnara
Hi! I have the same problem and it's getting quite annoying. Have you found any solutions? I've tried everything :slightly_sad:


Thanks for posting your Razer Kraken Kitty's concern here. Have you tried disabling all mic enhancements on Razer Synapse 3.0 microphone settings? By the way, I'll be locking this thread due to hijacking. Please refer to our house rules. Feel free to send me a PM. Let's continue from there.