Razer leviathan v2 turns on but will not work | Razer Insider
Solved

Razer leviathan v2 turns on but will not work


Userlevel 1

My leviathan v2 speakers have been working great for a while now and all of the sudden, stopped working, they turn on and the source light is green, but my pc no longer detects the speakers whatsoever. i also cannot change them to bluetooth to connect my phone to them. i just cannot get anything out of them. i have tried updating the firmware but in order to do this, the device needs to be in bluetooth mode so i cannot update, i have tried reinstalling synapse and restarting my pc but still no luck. i left it a couple of days and suddenly the source light was solid red and pressing the buttons or holding them did nothing, i switched it off at the wall and then back on and im back to them being able to turn on and off but still cannot get them in bluetooth mode or cannot get my pc to recognise them.

icon

Best answer by EpikkVanilla 8 September 2023, 18:29

View original

53 Replies

Lost count of how many times this has happened to me. Here I am again, bricked bar after power outages due to storm. 

Tried the usual firmware updater process:

Firmware Updaters

Razer Leviathan V2 Firmware Updater | RZ05-03920

Above didn’t work for me this time. What worked was doing a hard reset.

Follow these steps:

  1. Pull out the power cable
  2. Hold down the Power button, Volume Up and Volume Down
  3. While holding down, plug back the power cable
  4. Release the buttons after 3 seconds
  5. Hold Power button, Volume Up and Volume Down again for 10 seconds

Hope it works for you

Cheers!

Lost count of how many times this has happened to me. Here I am again, bricked bar after power outages due to storm. 

Tried the usual firmware updater process:

Firmware Updaters

Razer Leviathan V2 Firmware Updater | RZ05-03920

Above didn’t work for me this time. What worked was doing a hard reset.

Follow these steps:

  1. Pull out the power cable
  2. Hold down the Power button, Volume Up and Volume Down
  3. While holding down, plug back the power cable
  4. Release the buttons after 3 seconds
  5. Hold Power button, Volume Up and Volume Down again for 10 seconds

Hope it works for you

Cheers!

My guy you are a legend, I’ve had this problem for over a year now and this is exactly the method to fix it.

Lost count of how many times this has happened to me. Here I am again, bricked bar after power outages due to storm. 

Tried the usual firmware updater process:

Firmware Updaters

Razer Leviathan V2 Firmware Updater | RZ05-03920

Above didn’t work for me this time. What worked was doing a hard reset.

Follow these steps:

  1. Pull out the power cable
  2. Hold down the Power button, Volume Up and Volume Down
  3. While holding down, plug back the power cable
  4. Release the buttons after 3 seconds
  5. Hold Power button, Volume Up and Volume Down again for 10 seconds

Hope it works for you

Cheers!

it didn't work the first time. Then I unplugged the usb and repeated all the steps. After connecting the usb, windows and synaps detected the device. Thanks!

Same after a power outage it stopped working

 

This is very disappointing, a speaker whose worth a merely 200 bucks is worthless, no solutions no luck! hey help us out here, your product sucks!

I have the same issue… speakers work but suddenly no sound. Source light blue for me though. Trying to update whatever I can now and see what happens later. 
 

Razer support team please answer us on why this is happening…..

Userlevel 1

UPDATE…. Slight fix i have found…

 

So when i posted this, i had fixed it before i saw any replies, managed to fix with changing the power wire that goes to the power brick… since then it was fine (once i got it back to PC mode) but then i took it in to the garden to use with my phone for bluetooth and then same again, would not go back to pc mode and would not play with bluetooth.

 

I tried for hours with switching cables and nothing worked, i then found a cable from a back massager that i have, that had the same size plug for the speaker end and it has the same specs as the power brick from the original one… Input: 100-240v - 50-60Hz so i removed the original power brick and plugged this into the speaker, turned it on, and it was able to switch to pc mode instantly, i then turned it off and plugged the original power wire back in and its working perfect on my pc… for me this is fine because i just wont change back to bluetooth again… i feel like this issue is initially down to the power brick from razer just being iffy / broken and probably requires a new one, but as long as its in pc mode and not switched, it works.

 

Thanks fort all your replies, hope this can help you all.

Man, that is not a real solution, you should be able to work connecting this speaker to your usb c port. The problem is the quality of this devices. If someone is reading this post, before to buy it. Please, don't buy this garbage. 

I am having same issue. Having power surge few days ago and still unable to get the speaker back alive.

Going to try to change the cable and hopefully it will revive the speaker…

 

helped solve the problem by disconnecting the speaker from the power supply at night + resetting the settings (hold down the power button and -/+ volume)

Hello, I too am experiencing the same issue. Attempted to switch cables and no fix. Any updates? 

 

bro me too this leviathan v2 is too sux broooo

A power outage bricked my Leviathan V2. It turns on, will even connect to a Bluetooth transmitter, but there’s no sound. Additionally, the device is not recognized when it’s USB-connected to a PC, so there’s no way to factory-reset it.

 

When the power outage occurred, the device was plugged into surge protector. It would appear that the soundbar’s electronics are just too fragile.

I have the same issue… speakers work but suddenly no sound. Source light blue for me though. Trying to update whatever I can now and see what happens later. 
 

Razer support team please answer us on why this is happening…..

Hi guys, I just had this same issue, tried different USB ports, no fix. Tried bluetooth connection which resulted in a solid red light. What did fix it was trying a different cable than the Razer one, as soon as I tried this my pc detected the device. Unplug the power if you get in the red light state, but try a new cable then connect to your pc. It seems to be an odd issue with the firmware update getting stuck and changing the cable corrects this. My device is now working again after I change cable and unplugged the power to exit the red light state. I then also tried the original Razer cable and this works too. I hope this helps you guys! P.S My issue was caused by a brown out power surge at my house for a minute, device didn’t lose power but my oven etc did, it seemed to be enough voltage disruption to prevent the firmware check from power cycling - or whatever the exact technical term may be. Good luck and hope this helps.

 i have the same issue since a year now , no veiled solution from Razer.

Same after a power outage it stopped working

 

Now another round of a power outage, another round of problem. And it can’t be fixed by switching the cables. Damn!

I have the same issue… speakers work but suddenly no sound. Source light blue for me though. Trying to update whatever I can now and see what happens later. 
 

Razer support team please answer us on why this is happening…..

 

I have the same issue after a power surge.

My Pc Windows or synapse doesnt detect the soundbar.

Bluetooth mode connects to my laptop but no sound.

Here is how i managed to start it again.

 

Remove all cables from the sound bar.

Remove the adapter from power socket. (This may not be necessary, just my experience)

Wait disconnected with no power about 15 minutes. (This may not be necessary, just my experience)

Press and hold power button for about 5 seconds. You should hear a low click inside the soundbar.

Connect every cable and power up.

 

I have the same problem and Razer does not offer a valid solution.

same problem… buy high end speaker for got problem only…. if u only replace the unit = useless.. 

I have the same problem and cannot seem to get it working. Other sound devices work.

I've tried all the methods but still can't detect it.

help me!

Sorry if I’m late to the thread. There is a solution for this and it works for me every time.

 

The sound bar needs to be electrically discharged after a sudden power surge or interruption. Just like some computer towers/cases. Do the following:

  1. Unplug all cables from the sound bar. This includes all three: the power cable, USB-C and sub-woofer.
  2. In the sound bar, press the power button quickly and repeatedly many times for 20-30 seconds. Don’t stop pressing the power button very quickly and repeatedly, and do it for at least 20-30 seconds.
  3. Reconnect only the power cable. Press the power button in the sound bar. The sound bar will in PC mode (green source button).
  4. Press the source button. If it switches to BLUE (bluetooth), then the issue is resolved. Connect the USB-C and sub-woofer cables and use the sound bar normally.
  5. If the source button does not change to blue, the issue is not yet resolved. Disconnect the power cable and repeatedly press the power button many times for 20-30 seconds again.

This has been tried and tested and it always works. I hope it helps someone.

I have the same issue after tuned off my PC. every time that i make my PC start up this issue happen every time  synapse cannot detect soundbar. i had to disconnect cable and reconnect it to solve this problem.
lasted Driver of synapse and soundbar firmware updated everything.
hey Razer your product is suck. ashamed on you Razer.

no more buy your product.

I suspect that disconnecting the device from the power supply for more than 15 minutes helped me. Now it is working, but the synapse still does not see it

I’m facing the same issue, sometimes this is working and sometimes no. I hate this product, I’m  not going to buy any Razer products in the future. I bought it, without extend warranty and  now after only 6 months this garbage is not working.

Reply