Peripherals (Mouse/Keyboard) disconnect many times | Razer Insider

Peripherals (Mouse/Keyboard) disconnect many times

Show first post
This topic has been closed for comments

179 Replies

I had a problem recently with my BlackWidow X Chroma just randomly disconnecting, the keys don't respond but the lights are still flashing. I of course googled fixes and the best option that looked solid was to disable Windows from turning USB device off.

I went onto control panel and got device manager. Went down to *Universal Serial Bus Controllers* and right clicked every USB connection clicked on properties clicked on the *Power Management* tab and made sure "Allow the computer to turn off this device to save power" was unchecked. A lot of the connections didn't have the option. Haven't had it happen since.
The last two Windows updates, huh?

This may be a bit of a drastic suggestion, but if you have tried literally everything, I would recommend rolling back those specific updates, then toggling off automatic Windows updates until they release a version that actually works. As a Windows 8.1 user (disgusting, I know,) I have used this technique several times over the years to fix some extremely annoying issues with troublesome, yet necessary, software.

I'm not the biggest computer expert, but I'm extremely unlucky - if you can think of a 1:1 search result issue with a programme, I've probably had it, and I hold onto this information in the hopes that someone will have the same issue and need a fix. That being said, this issue is new to me, and rolling back a few updates is the only way I've dealt with similar issues before, so good luck, and I hope you manage to fix this annoying bug.
Userlevel 4
Before I begin, I have a Lancerhead mouse (Latest one) and a Blackwidow Chroma Keyboard v1.
Things that I've tried:

  • Onboard USB 2.0 ports
  • USB 3.0 ad-on card
  • Another USB 3.0 ad-on card
  • Standard mouse and keyboard
  • Above Razer mouse and keyboard
  • Up-to-date software, drivers and Windows 10 Pro OS
  • PC re-formatted 2 times

The standard mouse and keyboard doesn't have any issues. If I uninstall the Synapse software then I have no issues with the above Razer mouse and keyboard. For the Razer Lancerhead mouse: This happens both when using Wireless and wired (Synapse 2.0 or 3.0 installed). This seems to happen with the last 2 Windows 10 feature updates (which includes the April Spring update). I had no issues before that.
Are you sure it isn't simply your USB ports that are causing the issues? Try testing another product so that we can rule possible causes out before providing a solution.