Peripherals (Mouse/Keyboard) disconnect many times | Razer Insider

Peripherals (Mouse/Keyboard) disconnect many times

Userlevel 4
I'm really getting tired of this. Throughout the day both my Razer mouse and Razer keyboard disconnect and reconnect. I can be typing or hovering over something when it happens. I made sure that all USB power settings are set correctly. This doesn't happen if the Synapse software isn't installed. When using Synapse 3.0 it happens 3 times more than Synapse 2.0.

This topic has been closed for comments

179 Replies

Userlevel 4
Before I begin, I have a Lancerhead mouse (Latest one) and a Blackwidow Chroma Keyboard v1.
Things that I've tried:

  • Onboard USB 2.0 ports
  • USB 3.0 ad-on card
  • Another USB 3.0 ad-on card
  • Standard mouse and keyboard
  • Above Razer mouse and keyboard
  • Up-to-date software, drivers and Windows 10 Pro OS
  • PC re-formatted 2 times

The standard mouse and keyboard doesn't have any issues. If I uninstall the Synapse software then I have no issues with the above Razer mouse and keyboard. For the Razer Lancerhead mouse: This happens both when using Wireless and wired (Synapse 2.0 or 3.0 installed). This seems to happen with the last 2 Windows 10 feature updates (which includes the April Spring update). I had no issues before that.
Are you sure it isn't simply your USB ports that are causing the issues? Try testing another product so that we can rule possible causes out before providing a solution.
The last two Windows updates, huh?

This may be a bit of a drastic suggestion, but if you have tried literally everything, I would recommend rolling back those specific updates, then toggling off automatic Windows updates until they release a version that actually works. As a Windows 8.1 user (disgusting, I know,) I have used this technique several times over the years to fix some extremely annoying issues with troublesome, yet necessary, software.

I'm not the biggest computer expert, but I'm extremely unlucky - if you can think of a 1:1 search result issue with a programme, I've probably had it, and I hold onto this information in the hopes that someone will have the same issue and need a fix. That being said, this issue is new to me, and rolling back a few updates is the only way I've dealt with similar issues before, so good luck, and I hope you manage to fix this annoying bug.
I had a problem recently with my BlackWidow X Chroma just randomly disconnecting, the keys don't respond but the lights are still flashing. I of course googled fixes and the best option that looked solid was to disable Windows from turning USB device off.

I went onto control panel and got device manager. Went down to *Universal Serial Bus Controllers* and right clicked every USB connection clicked on properties clicked on the *Power Management* tab and made sure "Allow the computer to turn off this device to save power" was unchecked. A lot of the connections didn't have the option. Haven't had it happen since.
There are no excuses for this #Razer. I am a professional who uses a black widow chroma keyboard and naga epic chroma mouse. Ive been using them for 3 years. Over the last 18 months my mouse has gotten worse and worse. It constantly stops working and I have to unplug and replug into the USB port to get it to start working again. If I uninstall Synapse they work great, no problems, except that of course, I lose everything but basic functionality. I feel like I have given this company a lot of my money over the years regardless, expecting that a large company that commands the prices they do, would have a system in place that can identify problems and correct them.

In the mean time, I have a $10 battery powered logitech mouse (my backup for this one) that works better than my $100+ Razer mouse.

In the time its taken to write this, my mouse has gone out twice.

Userlevel 2
So, I believe I just solved this issue.
I have been having the same issue since getting a new laptop. At first I thought my USB hub was bad. I replaced it. No go. Later I realized that after I rolled back to 2.0, the problem was much less frequent. But, it still occurred.
It's obviously a power issue. So, I was hoping that changing the power setting as suggested would fix it. No go.

Finally, I stated just going through EVERYTHING in device manager. And I found that there are OTHER PLACES where you need to uncheck "allow windows to turn this device off to save power".

First, I did everything already suggested in this thread. I went through all the USB devices and clicked the power management tab and unchecked the "allow the computer to turn off" boxes.
Then I went to the power management and usb settings and disabled the "usb selective suspend" for both on battery and plugged in.

FINALLY, I went back to device manager and went to Human Interface Devices. I clicked on every razer device there and unchecked "allow the computer to turn off" boxes on the power management tab.

So, you have to do it in the USB section, AND in the HID section where it shows your razer devices. I rebooted... and it hasn't done it as single time since. And I'm running synapse 3.0 again.

Hopefully this will help you. It fixed it for me. Kinda redic that I had to do this, and I am 100% positive that it has something to do with Razer's software because the issue DOES NOT OCCUR prior to installing synapse software.

So razer... get your ish together mang.... this is just stupid.
Userlevel 2
Scratch that. It's back to disconnecting constantly again today. I checked all the boxes, they are still unchecked (the power management boxes). Razer... Come on. You charge a small fortune for your crap, I really expect it to work better than this.

I have a question. How many in this thread that are having the issue are using laptops?
I just bought my first ever Razer products, a Cynosa Chroma keyboard and Naga Trinity mouse. I also have the same disconnect problems everyone else is having. Happens randomly, sometimes every 30-60 seconds... sometimes goes 5 minutes before doing it again. Mine just makes the Windows alert sound and the keyboard and mouse go black a few seconds then come back online. This problem has been happening long enough to show me Razer doesn't care about their customers once they have their money. This should have been fixed long ago! Back to Walmart to return non working junk I guess because I won't go through the proper hoops like others have done in reporting it to Razer, only to still not have a replay several months later. What a joke.
I have open ticket for 3 months now and nobody from Razer Dev team replied. Support told me to wait for dev team to check my ticket. I provided all logs and did everything on my side. There is no fix for this. Synapse 3 cause all of these problems.


Going to live chat agent support told me just wait we dont have any information. Its total bs and whats funny nobody from razer even check these forums or reply to threads related to synapse 3.0.

I wanted to switch for logitech but their ghub is even more buggy then synapse 3.0.
i just started having this issue, my motherboard only has 2 rear usb2 and 4 rear usb3.

Cynosa Chroma plugged into USB2 as well as Deathadder Elite, Goliathus is in USB3. Keyboard randomly goes black and does not respond, Devicemanager doesn't show any yellow exclamation points when its disconnected either so windows thinks its still there. This has to be a software issue like many of these posts say. Come on razer.
also anyone else get like random turbo mode on a single key when typing? like i'll be typing something and the next thing i know there is 25 of the last letter i typed.
Wanted to post an update of sorts here. Since my last post a few months ago, I have been solely using Synapse 2. Zero disconnects. This is clearly a Synapse 3.0 issue, so I would avoid using that for now. Only drawbacks are limited customization compared to 3.0, but hey, I’ll take working devices over that any day. I currently have my Ornata and Lancehead directly connected to my USB ports, with my Firefly connected to a USB hub. One Chroma device per port seems to work the best, and I have 4 other things connected to the hub with no issues (unless I try to use an external hard drive but that’s another story). The fix that works for me is Synapse 2. Not sure if it’s universal, but I thought I would share.
Userlevel 4
Razer Support sent me a feedback survey for the support call they haven't responded to. :confused_:

They didn't score very high...
Same issues. Tried different computers, reinstalled drivers, Synapse, etc. :slightly_sad:

my initial thoughts were that it was a software+hardware issue
but since I bought a new mouse and the issue persists.....I doubt it is a hardware issue.

so...synapse team.....get to work
Userlevel 7
When i have this i look into this issue and dont know if you having the same issue as me but you can cheack it. For me the problem was a usb power menagment issue on motherboard that give too low voltage to run it so when the voltage go low it cutoff power on usb ports. The fix was settings usb as pernament voltage delivery in windows usb driver. Guide and full description you find on gogle without any problem 😛
Had same issue in windows 10, turns out in an update there is a USB power management called "USB Selective Suspend Setting" that was killing power briefly and causing constant disconnects my Razer gear.
Edit Power Plan > Change Advanced Power Settings > USB Settings > USB Selective Suspend Setting > Change to Disabled > Hit Apply and do a reboot
Have a good gaming session!


Joined the forum just to say that as of now this -appears- to have solved my problem. It's been several minutes and I still have all my custom lighting and full key functions. I'll have to see if it lasts - but it's the best results I've had in three days of troubleshooting.
Got a Razer Cynosa Chroma keyboard last week. Installed Synapse 3.0 and it was great for a few days. Then I got a Deathadder Elite mouse (to replace my old Deathadder Chroma). Both were recognized by Synapse 3.0 and the random disconnect/reconnect started happening almost immediately.
Tried different USB ports, restarting, USB power settings (in Power plan and Device Manager), deleting devices in device manager and letting it reinstall drivers.
The ONLY thing that stopped the random disconnects was uninstalling Razer Synapse 3.0. Now everything is fine.

Weird that my Cynosa keyboard with Synapse 3 and Deathadder Chroma mouse with Synapse 2 (both running at same time) -- it worked fine. It wasn't a problem until I upgraded to a Deathadder Elite mouse and both devices were using Synapse 3.0 (I unistalled Synapse 2).

Not sure how Razer can let this go on for so long and just ignore this thread...
razer never again
There is no real solution other than pluging into your USB ports on your laptop, clearly I think this is a software problem that complete makes all Razer products unusable on any usb hub powered even with 230w unless it's a Razer Core or an overprice TB3 hub. If it's a power problem, Razer should have had a warning that X product needs more power or just plain disable the lights automatically. I guess Synapse 3 still has the "bug" just to make you spend more without a solution.
Hey all.
I am having the same issues as everyone else with a Blackwidow X Chroma Gunmetal Grey, Naga Trinity and Goliath Extended Chroma. Have Synapse (3.4.512.51410) , Cortex ( and Central ( installed

Random disconnects of all 3 products at any stage of using the PC; Gaming, office, unlocking to windows. I have also notice it disconnects when changing profiles (gaming to office based work)

Whilst the disconnect and reconnect are fairly instant, its fairly annoying as well. All 3 devices disconnect.

Whilst the software was installed i tried the fixes with Disabling USB Selective Suspend Setting In Power Options. In control panel -> device manager, disallowed any type of power management on all USB and Human Interface Devices.

Still disconnecting. Tried all combinations of USB ports both on PC and on USB Hub. Same thing happened.

Remove all stated Razer software and there are no more disconnects.

Oddly enough, i never saw as many disconnects as when i added the Razer Goliath Extreme. Prior top this when i only had the mouse and keyboard it was 1 or 2 a week. Once the mat was introduced, its probably 20 disconnects a day. I want to add some Razer headphones but have canned that idea as interrupted sound would be the ultimate annoyance.

I think i am more emotionally disappointed after researching and investing in Razer. It looks and behaves like a premium product. If only i had researched the underlyingsoftware issues, i would have thought twice about these products. COME ON RAZER. On my rig, its your software causing the issues.
And now it started again... As I wrote last time I added an external USB hub and the issues disappeared.
Suddenly yesterday the issues started again, just out of no were! I didn't update anything just playing my games as usual..
I'm thinking of just exchanging all my Razer products as this does not seams to be addressed/fixed!
I've tried every option listed here. USB selective suspend is disabled, Windows cannot turn off USB powers. Updated drivers, removed all un-needed software. deleted EVERY disconnected hardware piece in device driver. Uninstalled all RAZER Synapses programs (2 and 3).....and everything worked. As soon as I rebooted, Synapses re-installed....and all the issues came back.

I've currently got my Golaith and Mercury White Base stand unplugged, as soon as I plug them in, issues pop back up.
Been having this problem on a Blackwidow keyboard currently waiting for razer's dev team to get back to me ill update here if they come up with a fix
I also have the same issue on a Lenovo laptop with a Lenovo docking station. I have an Ornata Chroma, a Mamba Tournament Edition and a Firefly Hard Edition. I am not a gamer, just liked the keyboard click and bought the mouse and mat for the "coolness" factor.


However, the user experience is awful. I have the same issues reported in the thread, tried the work-arounds suggested here and in other fora, opened a ticket with the Razer user support but at the end of three weeks email exchange I did not get a solution, only generic suggestions (update the OS, reinstall Synapse etc) and finally an invite to replace my docking station (it is brand new) or to connect the peripherals directly to the laptop. .....


In my very personal opinion, this might be a known issue, possibly limited to a relatively small number of users, which they do not intend to fix especially if this possible "non-standard" use of the USB protocol is what actually enables the majority of systems to work as they do.


A short update: the docking station has been replaced. Due to another, independent issue the laptop mainboard has been replaced as well.

Same keyboard, the problem keeps occurring. Also the problem must be in the Razer hardware or in the drivers.

I am still convinced that the issue must lie in a "non-standard" use of the USB protocol which allows the magic and does not give any problem to 99% of the systems under typical conditions.

Such problem could also lie in the Razer hardware itself - could it be a USB controller embedded in a certain series of Razer peripherals which could be defective, or not working as expected under certain circumstances. Could also be a compatibility problem with the counterpart USB hardware on the PC side.

In any case, I guess we'll never know...
Currently, I have turned off Synapse, and I don't seem to be getting any more disconnects. It's just annoying to not be able to use the one feature these products boast, especially since the Firefly's lighting flickers any time the spectrum cycles to a shade of blue. Hopefully a fix is available soon. This is just plain obnoxious honestly.

I also confirm that killing all the Razer "management" :big_grin_: software decreases significantly the frequency this issue occurs.
Hé I just started my pc up.
And I have the same problem it’s going on and go off. I am so fucking scared that I can’t use my things anymore it was all my money. I tried to uninstall synapse but I can’t remove raser SDK.
Do I have to uninstall it? Or does it not matter at all. please help me out with this I am so sad right now.

If you have something to help me please mail me [email][/email]

sorry for my bad English I am from the Netherlands English is difficult .

Just uninstall Synapse 3 is enough. Your peripheral will work but you won't be able to use any customisation.