Razer Tartarus Pro Can't bind macros to keys. | Razer Insider
Question

Razer Tartarus Pro Can't bind macros to keys.

  • 28 September 2023
  • 4 replies
  • 359 views

I did a clean install of windows 11 so I can run the new 22H2 Moment 4 released on the Sept 27th. I was In the beta channel for this but I decided to leave it because of other issues I was having. Now I can't bind my macros to the keys on the Tartarus Pro. Funny thing is I can assign those same macros to my blackwidow v3 keyboard and my BASILISK V2 mouse. Even tried to create a new macro to see if I can assign that to the Tartarus Pro and that failed. I couldn't get it working so I decided to do another clean install and still cannot assign the macros. After reading some posts here it seems like the synapse software may be bugged.

 

I was hoping if there's an older version I could download? I'm currently running version 3.8.930.91517 which I download fresh, I did follow the instructions for a clean install of synapse and that did not resolve it. Thank you


4 Replies

I have a similar sounding issue for which I have raised a ticket - you should do so too if you haven’t already.

For me, if I create a new profile I can bind a macro no problem.  The problem is if I bind an alphanumeric character to a key and then later try to bind a macro (or any other function), while Synapse displays the new bind, it actually isn’t, the previously bound character is still active.

The workaround I found is to bind the key to Default, then I can bind another function to that key such as a macro.

Current Synapse version I have is 3.8.930.92719.

Having the same issue.

Steps to reproduce:

  1. Create a new macro that types “Hello”.
  2. Bind it to the 1 key
  3. Tap the 1 key and “1” still gets typed.
  4. The macro still says “0 Bind”
  5. The device key mapping does show the new macro is attached to the 1 key.

Windows 11 Pro, Version 10.0.22621 Build 22621

Synapse version 3.8.930.92719 (App version 20231013)

Tried:

  • Different USB ports
  • Uninstalling
  • Running repair tool
  • Reinstalling
  • Restarting

Rolling back to a previous version might fix this because this only started happening in like the last month.

  1. Create a new macro that types “Hello”.
  2. Bind it to the 1 key
  3. Tap the 1 key and “1” still gets typed.
  4. The macro still says “0 Bind”
  5. The device key mapping does show the new macro is attached to the 1 key.

Having done that, if you now set the 1 key to Default (and Save, of course), and then try to reassign the macro, will it work now?  I’m finding doing these extra steps acts as a workaround for me.

Yes, there are older versions of Razer Synapse available for download. You can find them on the Razer website.

To download an older version of Razer Synapse:

  1. Go to the Razer Synapse download page.
  2. Click the "Select Version" drop-down menu and select the version of Synapse that you want to download.
  3. Click the "Download" button.

Once you have downloaded the older version of Razer Synapse, install it on your computer. Once it is installed, try to bind your macros to the keys on your Razer Tartarus Pro.

If you are still having problems, you can try the following:

  • Make sure that your Razer Tartarus Pro is firmware is up to date.
  • Try running Razer Synapse as an administrator.
  • Try resetting Razer Synapse to its default settings.
  • Try uninstalling and reinstalling Razer Synapse.

If you are still having problems, you can contact Razer support for assistance.

Reply