Ryder Synapse 3 40 to 100% CPU usage WMI Provider Host | Razer Insider

Ryder Synapse 3 40 to 100% CPU usage WMI Provider Host

  • 22 December 2022
  • 95 replies
  • 4436 views


Show first post

95 Replies

Also experiencing this issue. Restarting WMI service does act as a workaround, but I ran into another issue while troubleshooting this.

I completely reinstalled Synapse, and now my "Razer Central Service" is stuck using 30%+ of my cpu, and not allowing the cpu to throttle. I've reinstalled and repaired multiple times, and just did a clean reinstall following the clean uninstall guide and the issue is still there.

Basically the software is unusable for me.

I moved away from logitech last year to get away from their frustrating software issues and I'm on the verge of tossing this mouse in the garbage and going back. Incredibly frustrating software and this isn't the first time I've had to do the repair/reinstall dance with Synapse.
Userlevel 2
AndreAzevedo
this topic cannot be ignored. because that would not make sense to exist the forum razer insider.
even more so far several people have committed to reporting the problem. do you find it useless or do you want direct answer from them?


I have re-requested Razer support to confirm that they are actually looking at this topic.
Userlevel 2
ivan.yu
Can Razer support please confirm this thread is monitored?

Can Razer support please respond whether you are looking at this topic at all?
Userlevel 3
ivan.yu
Maybe we need to raise a support ticket on this issue. This forum may not be monitored by Razer support team.

https://mysupport.razer.com/

this topic cannot be ignored. because that would not make sense to exist the forum razer insider.
even more so far several people have committed to reporting the problem. do you find it useless or do you want direct answer from them?
Userlevel 2
Maybe we need to raise a support ticket on this issue. This forum may not be monitored by Razer support team.

https://mysupport.razer.com/
Same problem since yesterday.
Userlevel 2
Can Razer support please confirm this thread is monitored?
Any alternative software for programing the razer keypads?
So after some digging arround, i found a log reporting tool for razer.
this created: Razer Synapse 3.log which contains 3786 entries of:
"StatusCode: 500, ReasonPhrase: 'Internal Server Error'"

so its fairly easy to pinpoint whats going on - obviously the synapse is requesting something that is not available.

https://virtuedk-my.sharepoint.com/:u:/g/personal/odc_virtue_dk/EdXy0QF5BUlNkFz1Uyw0aQYBH4EoGcQrtwkvYbDC-sCjSw?e=wkIp3I
pw: razer

im suspecting that the dev machine they run this on have IIS installed with ASP.net options that are not available to the general windows installation.
Posted on other live thread re: WMI issue

Massive issue for me as causes unacceptable battery drain on my laptop while I'm mobile.

(Unfortunately not the first time a Windows update and/or Synapse update has caused runaway Synapse CPU use!)

Temp fix is obviously to uninstall Synapse - kills lighting, sound etc. though!

If like me you need the lighting to see your keyboard caps there is a work around however:
Search for OpenRGB on gitlab (Author is Adam House) - will let you control your backlight to enough of a degree as to be useable. (May work for other peripherals, but I haven't tested).
Hi, I'm also having the same issue! @Razer support, can someone look further in to this issue? Had to go back to SignalRGB...
Userlevel 2
@Wendigo-ove

Once exit Razer apps. The Razer services are still running in background but WMI activity log stops logging further events. So it stops WMI requests at that point.

If Synapse open, it starts to look like below...



2nd screenshot. Razer services takes up so much system resources just to change lights/control fans. Hogs more resources than other apps. At this point I don't care about RGB if I can find third party way of fan control.


once you close synapse - wmi provider goes to 0% load basically.
Can anyone tell me if the hyper polling remains active when synapse is closed?
Im having exactly this problem. Restarting WMI does stop it, but I also use Alienware Thermal controls which I don't seem to get working again after the restart of WMI.

Rollback or update, but please get this fixed.
Userlevel 2
Event Log - WMI Activity Logs:

Razer Synapse 3.exe
GameManagerService.exe

Event ID 5858 and 0x80041032 critical error codes being generated

Id = {00000000-0000-0000-0000-000000000000}; ClientMachine = P2; User = NT AUTHORITY\\SYSTEM; ClientProcessId = 8592; Component = Unknown; Operation = Start IWbemServices::ExecQuery - root\\cimv2 : SELECT ProcessId, ExecutablePath, CommandLine, Name FROM Win32_Process WHERE ProcessId=1704; ResultCode = 0x80041032; PossibleCause = Unknown

Cause and possible solution for Razer below from Microsoft Article below:

https://learn.microsoft.com/en-us/troubleshoot/windows-client/system-management-components/wmi-activity-event-5858-logged-with-resultcode-0x80041032
Hi everyone,
it seems we are all on the same boat, from the latest synapse 3 update I see Razer Central Service constantly hogging 15/20% of my cpu constantly. Even if I kill the process it comes back on after few seconds.
I hope a solution or update is on its way
I have the same problem, please fix this or let us go to previous version
I've registered just for this. Ever since Saturday when Razer Synapse made an update, i get this issue as well.
Whenever i start the Razer Synapse my WMI goes to space. Either restarting "Windows Management Instrumentation" fixes it, until i try to start the program again.
Fix this or let us go to previous version.
Userlevel 2
Unfortunately, for me, WMI provider host is still hogging 10-15% CPU, even after disabling Game Manager service, I can still hear my fan. I would have to resort to restarting WMI in the meantime, very annoying indeed.

I guess I need to switch to liquid cooling if I want to install Synapse 🙂
Userlevel 2
Probably a bad idea but did it anyway. Seems Synapse service not really dependent on Game Manager service.

Explanation:
https://www.reddit.com/r/razer/comments/kpp3hu/ysk_how_to_disable_razer_game_manager_service_as/

Script to run as every Synapse update will re-enable Game Service:
https://github.com/Invertex/RemoveRazerGameManager

Tested I am still able to:

Change RGB colour keyboard and mouse
Macros
Mouse poll rate
Mouse DPI
Fan control
Switch Optimus

Everything thing still seems to work in Synapse. So I wonder what this Game Manager service was for.

Only seemed to minimise WMI CPU usage though.

Crazy how Synapse uses around same handles than my Brave web browser open for few hours with 20 website tabs open...
Userlevel 2
Maybe the fundamental logic used by Synapse Game Manager to detect process id for games need to change. Polling is seldom the best way.
Userlevel 2
Taking responsibility to re-introduce a bug so it can be re-fixed again 😉
bestYellowOrangelab412
Looks like this issue has been around for a very long time. Probably was not noticeable before but now as it takes more CPU cycles with each update it has become more visible to people. Sometimes low CPU usage, sometimes high between updates from different user experiences.

4 Years ago...
https://www.reddit.com/r/razer/comments/c9xwlj/solution_razer_synapse_causing_wmi_provider_host/
https://www.reddit.com/r/razer/comments/br4kht/gamemanagerservice_causing_issues_with_wmi/
https://www.reddit.com/r/razer/comments/c644j0/game_manager_wmi_provider_host_issue/

5 months ago..
https://www.reddit.com/r/razer/comments/xk8xas/razer_synapse_constantly_forcing_wmi_provider/

Just a bit annoying to now have a desktop .bat script to run as admin whenever I restart Synapse.

net stop Winmgmt
net start Winmgmt


Nice to see Razer taking responsibility and fixing their software accordingly...
Userlevel 2
Looks like this issue has been around for a very long time. Probably was not noticeable before but now as it takes more CPU cycles with each update it has become more visible to people. Sometimes low CPU usage, sometimes high between updates from different user experiences.

4 Years ago...
https://www.reddit.com/r/razer/comments/c9xwlj/solution_razer_synapse_causing_wmi_provider_host/
https://www.reddit.com/r/razer/comments/br4kht/gamemanagerservice_causing_issues_with_wmi/
https://www.reddit.com/r/razer/comments/c644j0/game_manager_wmi_provider_host_issue/

5 months ago..
https://www.reddit.com/r/razer/comments/xk8xas/razer_synapse_constantly_forcing_wmi_provider/

Just a bit annoying to now have a desktop .bat script to run as admin whenever I restart Synapse.

net stop Winmgmt
net start Winmgmt
Userlevel 2
Sounds like the latest Synapse will get a handle to WMI upon startup, then users WMI to busy poll some other process' info. That would explain why if we manually restart WMI, this polling stops since the WMI handle will be invalid. Upon restarting Synapse, it will again go get a handle to WMI, and the nightmare then repeats.

Reply