Streamer Companion app | Razer Insider

Streamer Companion app


Wep, as the thread @DylShock got closed and me not being able to answer to this thread, thanks for nothing huh?...
I´d simply reupload his question, because I think this is a BIG question and in my opinion fixable, if someone is paying attention... @dekades @mltan


DylShock New Member
I have a Huntsman Elite keyboard which has a specific profile that's controlled via the Chroma Studio app. I also have an Emote Display that can only be controlled via the Streamer Companion app. Activating either application overrides the other and removes it's control of ALL Razer devices.

I want the Chroma on my keyboard keys to react to my inputs in specific ways, which can only be done with Chroma Studio controlling it. As soon as I activate the Streamer Companion app, the keyboard Chroma stops responding and remains static. The Chroma Studio app is grayed out and states that the "Streamer Companion app is currently controlling your devices."

If I venture into the Streamer Companion app, I haven't selected my keyboard to be used with ANY of it's functions whatsoever and have no way of returning it's control over to Chroma Studio without forcing Chroma Studio to take control over all of my devices, rendering the Emote Display unusable.

Is this an issue anyone else is having and is it fixable?



For your question: Yes, I guess it´s a problem anyone else, who bought the Emote Display is having, at least I do have the same problem as you.
And fixable, to be honest idk. I´d say Razer for sure is able to, but neither seen a program nor mod nor proper settings for synapse to "expand" the Connect feature. Beside deactivating everything...


BUT... IS THERE ANY POSSIBILITY TO GET "SEPERATED" SUPPORT FOR THE EMOTE DISPLAY?
For being able to keep your pattern active while using the Stream Companion App.
Even if it would only be, that i can activate my pattern in the Companion app
I added a screenshot of the App. Its all there, but the feature to add your own Studio pattern is missing...


I saw you added support of the Kraken Kitty Edition in synapse 3, which was also Companion app only at the beginning? But being a streamer who wants to present his special made chroma pattern in combination with the Emote Display just ends in somehow "color" (I dont even want to call it RGB with the Companion app) for all other razer devices...
It´s really sad to have so much Chroma devices forced to a simple color. What is this? 1967? (year of color TV launch in my country)

I mean nobody wants to get rid of the Streamer Companion app, don´t get me wrong!
It´s just about integration and the possibility of using your OWN Chroma Studio Pattern WHILE streaming or better said while using the Emote Display together with the streamer companion app.


I know Synapse 3 is still beta but c´mon Razer you can do better than this.

Nontheless the Emote Display is LIT! (Would add a picture but sadly can´t as I cant show you my real chroma :rolleyes:)

Keep up the good work and why not try fixing this ...or release a toaster... who said this? ;P

Sincerely,
everyone who bought a Emote Display and does not only do the rainbow theme...

This topic has been closed for comments

24 Replies

I am having an issue where I cant even see anything on the razer emote display even when trying to do testing. Its like it doesn't recognize it as being a razer device. Have you had any fix/heard of this at all? Even with the companion app, its not working.
I did contact the razer support as I had exact the same issue... with doing a clean install of razer synapse I did get it to work...
So first of all do a backup of all your devices and chroma pattern (its all saved in the cloud, but wanted to be safe).
You can do so by exporting all of your profiles and afterwards importing them if it didn't work
And ill just add the "guide" i gut from razer supp ->

I'll add my PS already here, otherwise some could miss it:
I did a point 2.5
After deinstalling all drivers in step 2 I even unplugged all of my devices beside the mouse and restarted twice just to be safe the drivers are uninstalled.
Even the support told me I don't really need to deinstall all drivers, but a buggy synapse could cause a buggy driver, so you never know.
And of course DEINSTALL Stream Companion App before (SCA)


Kindly follow the steps below.

CLEAN UNINSTALL / REINSTALL SYNAPSE

1. Kindly uninstall Razer Synapse from your PC and delete all files in C:\\Program Files (x86)\\Razer and C:\\ProgramData\\Razer directories. These folders may be hidden by default, so please be sure to unhide them. We want to ensure that there are no residual files remaining that may corrupt your installation. This is important so please do so. Restart your computer afterward.

2. Go into device manager, go to Keyboards/Audio inputs and outputs/Mouse and other pointing devices, uninstall HID Keyboard/Mouse Drivers and all other Razer product drivers, and restart your PC. Be sure to select delete drivers as well when uninstalling. Restart your computer again.

3. Turn off all Firewall and Anti-virus software to prevent any conflicts. Download and install the latest version of Microsoft .NET Framework (4.5 or higher) (In some cases, you may need to uninstall the older version on your system). Restart your computer again.

4. Install the latest version of Razer Synapse that can be downloaded from the link below, and restart your computer again.




I did unlink the links because I'm sure that I'm not allowed to post them, but I guess you figure out where to get the latest .NET Framework and Synape 3 by googleing :stuck_out_tongue_winking_eye_:

After all of this I installed the SCA and was able to activate the SCA via the Connect tab in synapse
You have to enable Connect apps and SCA!

Last step would then be setting up the Emote Display in the SCA.
But as soon as you start the "connection" you will lose all of your setup chroma patterns...

BTW the guy of the support claimed that there would be a seperate tab in synapse for the Emote Display like for the Seiren Emote, he called it lighting tab, but not for me?
At least it worked "somehow" via SCA.

Hope you're able to fix it and you have to tell me if you'll get this so called Lighting tab as I don't have it after reinstalling twice.
If so, it's all about reinstalling razer synapse right?!?
But I sadly guess not...
guys i have a big problem and i want your help.I just buy seiren emote and when i try to run the streamer's companion app it shows a message "server connection error".I amfrom Greece so help me
webCatalinaBlueleet856
guys i have a big problem and i want your help.I just buy seiren emote and when i try to run the streamer's companion app it shows a message "server connection error".I amfrom Greece so help me

I have the same problem, do you solve it?
webCatalinaBlueleet856
guys i have a big problem and i want your help.I just buy seiren emote and when i try to run the streamer's companion app it shows a message "server connection error".I amfrom Greece so help me

ufff not sure about that but beside reinstalling hole synapse+companion app there wasn't even a real fix for my problem. Sooooooooo I´d say nope, you're f**ked.
Hopefully it doesn´t have to do with regional locking, but I wouldn´t say so.
But in the end except trying to reinstall everything "clean" or contacting the support somehow, there's no real help...
Where do you get the "no connection screen"? Can you maybe provide some screenies?
Could maybe someone that already have the software send us the installation files?

They should be on:
C:\\Windows\\Installer\\Razer\\StreamerCompanionApp\\

I can’t think of anything else at this point!
Yeah ive the same problem, i cant install the SCA cuse of connection error
J3rseyHack
I am having an issue where I cant even see anything on the razer emote display even when trying to do testing. Its like it doesn't recognize it as being a razer device. Have you had any fix/heard of this at all? Even with the companion app, its not working.

iam having same issue here, but everytime reinstall all razer software I can test the rezer emote display on companion app but after I restart or shutdown the computer I cant see anything on the razer emote display. please I need help to fix this.
davurizkia
iam having same issue here, but everytime reinstall all razer software I can test the rezer emote display on companion app but after I restart or shutdown the computer I cant see anything on the razer emote display. please I need help to fix this.

Same here after the initial setup it wont let me go back to edit, and i checked and it's not even loading.
Well I don't know about the restart/shutdown problem or the server connection problem,
but then there just kicks in the IT guy in me:
OlguiPR
Same here after the initial setup it wont let me go back to edit, and i checked and it's not even loading.

did you activate the SCA in Synapse3? in the Connection tab?

I can only speak for myself but the initial reinstall with the provided steps worked for me, but never had server problems..
And I'm able to restart/shutdown the computer and still am able to use the emote display.

Well, still a native Emote Support would be very neat... like with the sirene as what the support chat told me, don't own one.
So basically i have dowloaded the SCA but it doesnt show in the ''connect'' tab in synapse 3. I don't know what to do anymore because i have already reinstalled both of them like 4 times. I tryied downloading the synapse and the SCA in my HD and it worked, but when i use it in my SSD i have this problem
Userlevel 1
dXcheeze
Wep, as the thread @DylShock got closed and me not being able to answer to this thread, thanks for nothing huh?...
I´d simply reupload his question, because I think this is a BIG question and in my opinion fixable, if someone is paying attention... @dekades @mltan



For your question: Yes, I guess it´s a problem anyone else, who bought the Emote Display is having, at least I do have the same problem as you.
And fixable, to be honest idk. I´d say Razer for sure is able to, but neither seen a program nor mod nor proper settings for synapse to "expand" the Connect feature. Beside deactivating everything...


BUT... IS THERE ANY POSSIBILITY TO GET "SEPERATED" SUPPORT FOR THE EMOTE DISPLAY?
For being able to keep your pattern active while using the Stream Companion App.
Even if it would only be, that i can activate my pattern in the Companion app
I added a screenshot of the App. Its all there, but the feature to add your own Studio pattern is missing...


I saw you added support of the Kraken Kitty Edition in synapse 3, which was also Companion app only at the beginning? But being a streamer who wants to present his special made chroma pattern in combination with the Emote Display just ends in somehow "color" (I dont even want to call it RGB with the Companion app) for all other razer devices...
It´s really sad to have so much Chroma devices forced to a simple color. What is this? 1967? (year of color TV launch in my country)

I mean nobody wants to get rid of the Streamer Companion app, don´t get me wrong!
It´s just about integration and the possibility of using your OWN Chroma Studio Pattern WHILE streaming or better said while using the Emote Display together with the streamer companion app.


I know Synapse 3 is still beta but c´mon Razer you can do better than this.

Nontheless the Emote Display is LIT! (Would add a picture but sadly can´t as I cant show you my real chroma :rolleyes:)

Keep up the good work and why not try fixing this ...or release a toaster... who said this? ;P

Sincerely,
everyone who bought a Emote Display and does not only do the rainbow theme...

+1 please, is needed for our streams.
Man, STILL no answer here for that original issue I posted huh? Not great, Razer. You've treated me well with my Razer Phone, but this Emote Display-- not so much.

I use this thing on every stream, but the fact that it shuts down my Keyboard Chroma in order to do so is unacceptable.

Thanks for keeping this topic going and reposting it guys.
edudds
So basically i have dowloaded the SCA but it doesnt show in the ''connect'' tab in synapse 3. I don't know what to do anymore because i have already reinstalled both of them like 4 times. I tryied downloading the synapse and the SCA in my HD and it worked, but when i use it in my SSD i have this problem

did u fix it ? i have same problem 😞
Bianconero94
did u fix it ? i have same problem :slightly_sad:

Bro I just waited some days to reinstall everything again and it worked....
edudds
Bro I just waited some days to reinstall everything again and it worked....

doesnt work for me yet :(((
Hey everyone!

Just bought the Razer Seiren Emote mic and was googling to see if anyone had figured out how to better use the Emote display without the Streamer Companion app taking over your whole entire Synapse Studio lighting.

Seems like no or not yet.

Razer Support, are you there?
dXcheeze
Wep, as the thread @DylShock got closed and me not being able to answer to this thread, thanks for nothing huh?...
I´d simply reupload his question, because I think this is a BIG question and in my opinion fixable, if someone is paying attention... @dekades @mltan



For your question: Yes, I guess it´s a problem anyone else, who bought the Emote Display is having, at least I do have the same problem as you.
And fixable, to be honest idk. I´d say Razer for sure is able to, but neither seen a program nor mod nor proper settings for synapse to "expand" the Connect feature. Beside deactivating everything...


BUT... IS THERE ANY POSSIBILITY TO GET "SEPERATED" SUPPORT FOR THE EMOTE DISPLAY?
For being able to keep your pattern active while using the Stream Companion App.
Even if it would only be, that i can activate my pattern in the Companion app
I added a screenshot of the App. Its all there, but the feature to add your own Studio pattern is missing...


I saw you added support of the Kraken Kitty Edition in synapse 3, which was also Companion app only at the beginning? But being a streamer who wants to present his special made chroma pattern in combination with the Emote Display just ends in somehow "color" (I dont even want to call it RGB with the Companion app) for all other razer devices...
It´s really sad to have so much Chroma devices forced to a simple color. What is this? 1967? (year of color TV launch in my country)

I mean nobody wants to get rid of the Streamer Companion app, don´t get me wrong!
It´s just about integration and the possibility of using your OWN Chroma Studio Pattern WHILE streaming or better said while using the Emote Display together with the streamer companion app.


I know Synapse 3 is still beta but c´mon Razer you can do better than this.

Nontheless the Emote Display is LIT! (Would add a picture but sadly can´t as I cant show you my real chroma :rolleyes:)

Keep up the good work and why not try fixing this ...or release a toaster... who said this? ;P

Sincerely,
everyone who bought a Emote Display and does not only do the rainbow theme...

Cone911
Hey everyone!

Just bought the Razer Seiren Emote mic and was googling to see if anyone had figured out how to better use the Emote display without the Streamer Companion app taking over your whole entire Synapse Studio lighting.

Seems like no or not yet.

Razer Support, are you there?



I am having the issue where I have a Razer Keyboard, Mouse, headset and now the seiren. I have set up custom lighting for all of my devices and the seiren I received for xmas. I set everything up, but can't seem to have custom lighting through synapse 3 (keyboard, mouse, and headset) while using the custom emotes on the Mic.

Is this a known issue?

not being able to use chroma studio / custom lighting for the keyboard / mouse and the razer seiren?
wow still no fix or respond whatsoever eh? they should make the emote devices can be enabled on chroma studio. like seriously you cant even change the background effect on other chroma devices on the companion app to wave or somthing, only static available
J3rseyHack
I am having an issue where I cant even see anything on the razer emote display even when trying to do testing. Its like it doesn't recognize it as being a razer device. Have you had any fix/heard of this at all? Even with the companion app, its not working.


I have found a way fellow frustraters.
my devices this worked with Razer sieren, diamondback mouse, deathstalker Keyboard and hardfly mouse mat
1. make sure both streamer companion app and synapse are both running
2. turn off chroma apps in your chosen synapse
3. customise your lighting on your devices and apply them
4. turn the chroma apps back on
5. sit back enjoy your keyboard etc. should have saved the last known configuration and running it and with the chroma apps back running your emote/sieren should be running as it should

on a side note under the chroma apps list the streamer app should be at the very top (eg 1st priority)
if anyone is having trouble please get in contact with me @ https://www.facebook.com/loki.gaming.359
I will post a video on twitch with full step by step instructions doing this at 2pm gmt live 4th march 2012
here:-
lokigaming13 on twitch
OlguiPR
Same here after the initial setup it wont let me go back to edit, and i checked and it's not even loading.

I have posted a soloution
buzzUltramarinefever627
I have found a way fellow frustraters.
my devices this worked with Razer sieren, diamondback mouse, deathstalker Keyboard and hardfly mouse mat
1. make sure both streamer companion app and synapse are both running
2. turn off chroma apps in your chosen synapse
3. customise your lighting on your devices and apply them
4. turn the chroma apps back on
5. sit back enjoy your keyboard etc. should have saved the last known configuration and running it and with the chroma apps back running your emote/sieren should be running as it should

on a side note under the chroma apps list the streamer app should be at the very top (eg 1st priority)
if anyone is having trouble please get in contact with me @ https://www.facebook.com/loki.gaming.359



Hi there! New here and just found your solution via google. I tried it but as soon as I turn the chroma app back on, it overwrites my customized pattern again. Any update on this?