Tartarus Pro - Synapse 3 not saving key changes | Razer Insider

Tartarus Pro - Synapse 3 not saving key changes

  • 1 November 2019
  • 21 replies
  • 882 views

My Tartarus Pro just landed, and I'm trying to set up profiles, but several reboots later Synapse 3 is not saving any changes to the device. My V2 works fine, and I can edit it and chroma settings for the Pro, but no key mapping.

Anyone have any thoughts?

This topic has been closed for comments

21 Replies

Userlevel 7
Try to reset device from synapse settings window. From what i remember Pro version only have local and cloud profiles so if make change change to settings should sync with cloud. When you reset device make sure to delete old profiles and just leave default make change sync this profile and reboot and see if something change.
It may be different from your device problem, but in my case the key mapping is not applied after Windows wakes up from sleep mode and will be in the default key state. In Synapse 3, the device is displayed.
Therefore I need to restart Synapse 3 after sleep mode.

Other bugs I noticed
The secondary actuation point is not functioning properly.
Synapse 3 works just fine for my Tartarus V2. It just does nothing but change the color of the Pro.
Userlevel 7
could you send over some pictures? That would help.

after I click "save" the button stays dimmed, but it never does anything. using the V2, the key programmed turns green and I can move on to program the next key. On the Pro, if i click away I get this:
Userlevel 7
Try setting a keymap. On the pulldown bar below the profile name.
Nope. Still hangs. And still works fine with my V2.
Userlevel 7
talkthinkMalachite533
It may be different from your device problem, but in my case the key mapping is not applied after Windows wakes up from sleep mode and will be in the default key state. In Synapse 3, the device is displayed.
Therefore I need to restart Synapse 3 after sleep mode.

Other bugs I noticed
The secondary actuation point is not functioning properly.


The Tartarus is connected directly to the PC ports or via docking station ?
Userlevel 7
JR0nin
The Tartarus is connected directly to the PC ports or via docking station ?

I was about to say this, Sometimes when using a USB hub Things wont work.
PC directly, tried multiple USB ports, I'm thinking it's something with my profile on the server side, both my V2 and Pro can be edited for lighting and that works fine, but something with editing keys just doesn't work.
Thank you JR0nin and xARACHN1D.
The problem with sleep mode was caused by USB HUB.
This HUB has no problems with Tartarus V2, so I didn't think this was the cause.
It's gotta be my profile. Tried the Pro on a different machine, and my profile doesn't work, but if I make a new profile, it works just fine on either machine.
... and the support email is bouncing because their mailbox is full.
Userlevel 7
metis1
My Tartarus Pro just landed, and I'm trying to set up profiles, but several reboots later Synapse 3 is not saving any changes to the device. My V2 works fine, and I can edit it and chroma settings for the Pro, but no key mapping.

Anyone have any thoughts?


Hi everyone! Thanks for sharing your concerns and inputs on this thread.

Hey @metis1! Have you tried using a guest or dummy Razer Synapse account and see if the issue persists? If it does, please send me a PM. Let's continue from there.
@Razer.Speedcr0ss I did, and tried it on multiple machines. Apparently upgrading from Synapse 2 broke my account for new content in Synapse 3 and after over a week of the support email rejecting emails because the email box was full @Razer.RedPanda was able to get the support email team to migrate my settings from this account to a new dummy account I can actually use on the device. This account still doesn't work on the Pro, but I can at least use the device, and thus far I'm not sure if I'm more frustrated with device limitations or how long it took for support to half resolve the issue.
Userlevel 7
metis1
@Razer.Speedcr0ss I did, and tried it on multiple machines. Apparently upgrading from Synapse 2 broke my account for new content in Synapse 3 and after over a week of the support email rejecting emails because the email box was full @Razer.RedPanda was able to get the support email team to migrate my settings from this account to a new dummy account I can actually use on the device. This account still doesn't work on the Pro, but I can at least use the device, and thus far I'm not sure if I'm more frustrated with device limitations or how long it took for support to half resolve the issue.


I see. That's inconvenient. If the issue persists, ensure to delete all saved profiles in your PC and redo all your macros/profiles to omit it from saving in the cloud storage. Feel free to send me a PM should you need additional assistance.
@Razer.Speedcr0ss is your advice really to delete 50+ different macro's and rebuild them from scratch?

The macros are not the problem, the razer cloud version of my profile being unable to save specific to the Pro is the problem. It seems that the Pro will ONLY save via cloud storage, so your advice seems to be contradictory to Synapse 3 behavior.

I can export the macros, import them to a new profile and remap them all manually for my other devices, and other profiles seem to work just fine, so there's no reason to generate a third profile again.

I get that Synapse 3 is in beta, but maybe it'd be a good idea to have an operational driver for a product before you sell it, and support who have solutions other than burn it all down and rebuild it, and are able to receive email.
Userlevel 7
metis1
@Razer.Speedcr0ss is your advice really to delete 50+ different macro's and rebuild them from scratch?

The macros are not the problem, the razer cloud version of my profile being unable to save specific to the Pro is the problem. It seems that the Pro will ONLY save via cloud storage, so your advice seems to be contradictory to Synapse 3 behavior.

I can export the macros, import them to a new profile and remap them all manually for my other devices, and other profiles seem to work just fine, so there's no reason to generate a third profile again.

I get that Synapse 3 is in beta, but maybe it'd be a good idea to have an operational driver for a product before you sell it, and support who have solutions other than burn it all down and rebuild it, and are able to receive email.


Your point is well taken. I've asked that as part of the isolation. Do you have a case ID from the Support team that I can review? If you have, please send it via PM.
@Razer.Speedcr0ss PM sent with info.
Userlevel 7
metis1
@Razer.Speedcr0ss PM sent with info.


Thank you for the mention! I've replied to your PM.
I was running into same issue as I just received my Razer Tartarus Pro. I would try to change the F keybind to C instead and when clicking save it would just sit there and never actually save. I uninstalled reinstalled Synapse 3 rebooted several times still ran into same issue. I deleted the profile completely and created a new one still same issues. I plugged in my Tartarus V2 booted up synapse exported my profile. Plugged in Tartarus Pro imported my old profile and kept trying to modify the F key to be C instead and finally it saved. Should not require this much work as when using the Tartarus v2 every thing saved on the fly with no issues ever!