When will Synapse 3 ever support "Legacy" Devices? | Razer Insider

When will Synapse 3 ever support "Legacy" Devices?

  • 8 September 2020
  • 8 replies
  • 182 views

I am again signal amplifying this issue that I have seen many Razer customers bring up repeatedly.

Will Razer ever fulfill their promise to add "legacy" hardware support to Synapse 3?

I have a Razer Orbweaver, and functionally the Orbweaver is not all that different from the current Tartarus and was still purchasable up until as recently as December 2019. The product in my opinion is on par quality wise with the Tartarus because it features mechanical keys, better adjust-ability (especially for larger hands) and one more main key where the Tartarus has the scroll wheel. The main issues I have with it is the Synapse 2 software is super buggy and looses sync with the device periodically and the only solution is to reboot the PC when that happens or the Chroma stops working. I feel like migrating it to Synapse 3 would solve A LOT of the issues I have with it. Not to mention there is more and more app support for Chroma, but only the Synapse 3 version. I would love to have my Orbweaver Choma work with more modern apps. Orbweaver users have been making this request of Razer for YEARS!

This topic has been closed for comments

8 Replies

Userlevel 7
Badge
Still waiting for ManOwars to be compatible with Synapse 3 😞
To be clear, I don't agree with many Razer devices being considered "legacy" either. There's potential for a brand new Orbweaver being less than a year old at this point.
I hope they do add more of the devices to 3. For example, I have the Blackwidow X Chroma TE which is only supported in 2, even though its full-sized brethren are supported in 3. I was disappointed when a Razer guy over in reddit said there were no plans to add any more legacy devices to Synapse 3, I hope they rethink this.
I second this. I have an Orbweaver which is completely useless without software to change the button layouts, but I'm left installing this ancient Synapse 2.0 software PLUS the 3.0 software for my Mamba Elite...
I have a Blackwidow Chroma, and a Firefly that work with Synapse 3.0. But it doesn't support my Deathadder Chroma, so I cant sync my lighting across all 3 devices. Its ridiculous, considering I bought them all at the SAME TIME. There are articles on reddit from 2 years ago saying this would be fixed and it still isnt. Razer is going to lose me as a customer if this isn't fixed soon. I'll start switching to Corsair or another brand, because this just sucks!
Right. so what you're telling me is that I am returning the Orbweaver that arrived today from Amazon. Did a lot of research before I bought a replacement for my Logitech G13 but I guess I missed the reports that the Orbweaver was a dead product line.

Back to the drawing the board. Wish I'd thought to come to the forums sooner. It just never occurred to me that they would be selling a product they no longer care to support.
They can't even get Synapse 3 to properly support what it already "supports". As soon as I load it my Blackwidow Elite will randomly stop typing for a few seconds, every few seconds the RGB will blank for a split second and restart (easy to notice during spectrum cycling compared to spectrum cylcing with synapse 3 not loaded), and once it started constant typing a single letter I hit until I actually logged out of Windows. All that and I have barely had it a week. Razer makes great hardware that they turn around and ruin with horrible software issues.
Personally I'd rather have it the other direction make my synapse 3 compatible devices work on synapse 2 which has a lot less unnecessary features.