Razer devices having connection issues after past update | Razer Insider

Razer devices having connection issues after past update

  • 2 May 2024
  • 1 reply
  • 21 views

My viper v2 pro has been having non stop connection issues over the past 2 months. I have tried all methods of getting it to reconnect, including completely resetting my pc and all settings. 

Last night (May 1st 2024)  it completely stopped connecting after the last synapse update. All my drivers are up to date. The mouse is charged. And still my pc will not pick up the dongle, the only way i can use the mouse is via the USB-C. 

I looked and noticed hundreds of people are having the same issue as me as of the last synapse update. Please fix the issue. 


This topic has been closed for comments

1 Reply

Userlevel 2

Hello, @Hiyzomi!

 

Have you tried it on a different PC? When successfully connected, you can try updating its firmware. If that didn’t work, then you can send me a PM along with your mouse’s serial number so I can check for other workarounds.

 

*Thread locked to curb conversation to PM.