synapse failed | Razer Insider

synapse failed

  • 21 January 2021
  • 4 replies

Hi, I have and razer mamba and firefly and the synced perfectly with synapse but in the last couple of weeks, they didn't sync very well until 2 days ago that my mamba dpi buttons stop working and the battery indicator on syngas shown 0 % and none of my personalized buttons worked and the same happened with firefly too I change the profile on synapse and nothing happened so I uninstall synapse and reinstall it and everything start to work perfectly and I shut down my laptop and when I start my laptop this morning nothing worked again the same problem and I should mention that my mamba works perfectly when I connect it with wire and the problem with mamba is when it connected wirelessly with its dock. and I don't know what to do about it.

This topic has been closed for comments

4 Replies

Userlevel 7
I suspect a software issue like a virus, but let us try few things
Let us try some hardware and software troubleshooting


  • Try connect your devices to a different USB port
  • RAZER devices do not work well when connected to a multi USB hub, so connect to an individual USB port


  • Update your Synapse 3.0
  • If it still causing issues, uninstall and reinstall the Synapse 3.0 and update

If it is still causing issues, I suspect it is a fault on your PC / OS (virus)

  • Grab a temporary Windows 10
  • Update the Windows
  • Install Synapse 3
  • Connect your RAZER peripherals and see if it works better?
hi thank u for responding I usually use a USB hub under my desk to connect my mouse and my pad but since this happened I try a direct connection with the original wire and another micro USB but the same thing happened (if the mouse is directly connected to wire everything is fine but is soon as I connect it to the duck same problem I said before nothing works) and about synapse 3 as far as I know the mamba that I have does not get any support with synapse 3 but I just start to install it maybe it would help synapse 2 to work better and about viruses, I just ran 2 scans on my laptop and everything seems to be fine.
Userlevel 7
Ah! so that means you have a Mamba 2012
Yeah, if that is true, that is only compatible with Synapse 2.0.

Following thread shows RAZER products that are compatible with Synapse 2.0

These devices and it's features cannot be interacted with Synapse 3.0
Userlevel 7
Two things. First what exact mamba you have becose there are few models of this mouse 🙂. Second try first to logout from synapse wait few minutes and log back if you use synapse 3 if not or dont help try to remove synapse and all other razer softwere then remove the AppData razer folder and programfiles reboot pc and download new fresh copy of synapse. When you write your mouse model we can cheack if the firmware is avalible to download for this mouse.