Blade 17 - external monitor via USB-C/Thunderbolt 4 not working

Discussion in 'Systems' started by Ribsletics, Jul 6, 2022.

  1. FlyingFoxFei

    FlyingFoxFei New Member

    I finally figured out... The driver was fine. no issue. The only issue is that my new razer require thunderbolt 4 cable to connect to external monitor. i swapped the thunderbolt 3 to 4 and all problems solved. Thanks!!
     
    Razer.Speedcr0ss likes this.
  2. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Thanks for confirming. Should you need additional assistance, you can submit a ticket to our Support Team as the laptop's port performance needs an investigation. Otherwise, send me a PM so I can help initiate a support ticket on your behalf.
     
  3. Is this maybe the solution for everyone with this issue?
     
  4. Hi ! Similar problem on Razer Bade 15 Advanced 2021 (RZ09-0409)
    I use two monitors connected via USB-C on the razer dock thunderbolt 4. I also updated my bios to v2.02.
    With nvidia driver <516.xx everything is working fine.
    With nvidia driver >516.xx my monitors are listed in the nvidia control panel but cannot be used. I tried to connect the tb4 dock on both USB-C ports, same problem. When I connect the monitors without the dock, directly on the USB-C ports it's working properly.
    I hope this will help devs finding the problem.
    I must say that I am also disappointed that this could happen with hardware that is that expensive.
    Have a great day
     
  5. BlackFireDragon

    BlackFireDragon Well-Known Member

    I’m happy that help you. For the tb4 is hard to tell becose i’m using direct connection and on my tb4 all ports are in use. How are the ivestigation is going ? Becose people/cudtmers are waiting.
     
  6. Well the thread is marked as FIXED
    I don't think the issue is fixed at all
    @Razer.Speedcr0ss
     
    Alchimista_Acciaio and FiszPL like this.
  7. THIS IS A DRIVER ISSUE! Roll back your graphics driver and the connectivity will be there. This is an NVIDIA issue. No idea why Razer haven't made this clear.
     
  8. Bubblessmarttech156

    Bubblessmarttech156 New Member

    Has this been solved?
     
  9. Bubblessmarttech156

    Bubblessmarttech156 New Member


    Has this been solved?
     
  10. Xeno2991

    Xeno2991 New Member

    Hello, my computer is the same model as yours, the same, I can't find any bios update,I don't want Razer to just drop this model,They don't even open XMP and undervoltage to us.
     
  11. BlackFireDragon

    BlackFireDragon Well-Known Member

    I dont agree with you the same issues was on every other laptops from the review of msi ge56 or 76 if dont mistake reviewer rise up this problem on Video and tell he send message to msi about this and after a week they give bios update. So yeah we stuck waiting on Razer enginering to solve this. I can only Think base on the info from other brands and they actions this can be conflict or communication issue from gpu to motherboard.
     
  12. Ender1618

    Ender1618 New Member

    I own a Razer Blade 17 2022 (RZ09-0423x), Intel i9-12900H, NVidia RTX 3080ti. I read on this thread that on some older versions of the laptop that a bios update helped fix this issue. I am on version 1.07 of the BIOS, and there does not seem to be an update past that (not that I could find).

    Is there an driver update past 1.07 for RZ09-0423x that exists?

    I use this laptop mainly for game development, and I can confirm that the Unreal 5.03 Editor crashes using the Nvidia driver 512.15, but the application runs fine with 516.25 or higher (but then my USB-C display ports stop working). The editor gives a warning on start-up if your driver is not 516.25 or above. BTW trying to drop down to version 5.02 of Unreal is not an option (you would have to build it from source, and its just not supported).

    I have also been looking at the forums of other retailer's that sell laptops with similar specs (12th gen intel, and NVidia 30xx RTX), some had a similar issue with their USB-C -> Display ports not working after the 512.15, but some were able to fix this with a laptop BIOS/firmware update.

    I am hoping that Razer will continue to work with NVidia on trying to solve this problem, ether in the form of NVidia releasing a new driver or Razer or maybe both, that fix this.

    Has anyone been able to get the display ports working on a NVidia driver 516.25 or higher?

    I heard something about making sure your USB-C ->Displayport cables are rated for Thunderbolt 4.
     
    Last edited: Sep 11, 2022
    Bubblessmarttech156 likes this.
  13. Ender1618

    Ender1618 New Member



    Which cable did you use? What model Razer did this work for?
     
  14. BlackFireDragon

    BlackFireDragon Well-Known Member

    Nope read my previous post here. On second question this dont give anyting. Without bios update that fix the issue you do anyting. You stuck on old driver where external monitor works or new where it dosent. The posts that you write was where old or other brands have bios update.
     
  15. Bubblessmarttech156

    Bubblessmarttech156 New Member

    So are you saying it's a Razer update fix required here?
    Keen to not fork off onto some weird BIOS branch only to be saddled with a choice to loose the setup (as advertised mind you and therefore grounds for compensation / redress at the expense of the supplier).

    This is probably why they're being cagey. Since they have offered a device that can't provide the advertised feature. The Sqeaky wheel gets the oil - amazed how many people are having the same issue and no addressed solution.

    The Support email I got doesn't help either.
     
    Ender1618 likes this.
  16. BlackFireDragon

    BlackFireDragon Well-Known Member

    I can be wrong but from what see here and on the web the issue is for regular 30xx and ti cards. Every brand that shipp device with one of this cards have the same problem. Some brands like write above fix the issue with bios update also here someone write that have bios for he”s device and this fix the issue. Base on everyting we stuck with premium laptop that is very expensive with enginering team from Razer that cant do their job find and fix the problem. MSI fix the same problem with one week we waiting almost two month.
     
  17. Bubblessmarttech156

    Bubblessmarttech156 New Member

    Yeah - feels like they're making it a "you problem" - rather than an issue with their bios. Not great ITAR either since they've largely ignored this thread. Suggest tweeting them might make its way via a different channel to someone who can actually diagnose / triage the problem - or make that happen!
     
    Ender1618 likes this.
  18. BlackFireDragon

    BlackFireDragon Well-Known Member

    You can find in this thred messages from Razer support employe but he can only adress the issue is prezent and it for the team that will investigate the problem. The Real problem is team that should eliminate the problem lin Max week or two. Lack of knowlage is why there is no fix for this dat.
     
  19. aalhail

    aalhail New Member

    I own a Razer Blade 17 2022 , NVidia RTX 3070ti

    And manage to fix the problem with downgrade Nvidia to 512.95

    All good now
     
  20. BlackFireDragon

    BlackFireDragon Well-Known Member

    This is not a fix but temporary solution or workaround/ Fixed will be when you can update driver to up to date driver and everything will be working as should be. For now this is not possible.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >