Blade 17 - external monitor via USB-C/Thunderbolt 4 not working

Discussion in 'Systems' started by Ribsletics, Jul 6, 2022.

  1. BlackFireDragon

    BlackFireDragon Well-Known Member

    Now i'm having wird issues. When laptop start get info on black screen user login data cannot be lfound. User cannot be log-in or something like that. After reboot i I can login using windows hello but it remove everything like theme, settings list iof apps in windows start and back to factory. apps on tray are removed and on windows settings as user it say please log in into your ms account. After next reboot everything back to normal but windows store dont load after next reboot windows store open. What the ekk.. is going on after the update on 22H2 update or nvidia 517.48 this appear.
     
  2. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member


    I recommend creating a thread for this topic/concern or contact our Support Team through this link.
     
  3. joekong_hk

    joekong_hk New Member

    My Blade 15 2022 (RZ09-0421x) is now working with the latest drive 517.48. Hurrah!
     
  4. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    That's great to hear! I hope the other users here can confirm too. Otherwise, they can send me a PM or submit a case here.
     
  5. bl00na

    bl00na New Member

    I can confirm that with GeForce Game Ready Driver WHQL 517.48 my external monitor connected via USB-C on Razer Thunderbolt 4 Dock Chroma is now working again @Razer Blade 15, QHD 240Hz, GeForce RTX 3080 Ti.
     
    Last edited: Sep 30, 2022
    Razer.Speedcr0ss likes this.
  6. BlackFireDragon

    BlackFireDragon Well-Known Member

    Most Most of my issues during years resolve my self becose support send me basic staff to try fix issues most of them is so basic thets the first thing when something come up to try. Back to my post this is not message where i want help but question is other people have the same thing becose from my understanding there a three ways that can happend: 1)windows files get corrupted during the startup make error and this comeup, 2)TPM module is demaged and this is real problem. TPM is part of cpu diy and becose razer sotter cpu to motherboard everything will need to be replaced.
     
  7. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    I understand your standpoint. Also, your feedback is duly noted. However, you brought up a topic irrelevant to the original post. You may post a separate topic /discussion so our community can share ideas on our systems board. I am just reminding everyone of our house rules and posting guidelines. Thanks for understanding and your cooperation.
     
  8. Taylor254

    Taylor254 New Member

    Same issue on a different PC. I have an Alienware M15 R6 with an NVidia RTX 3070 Laptop GPU. I'm still unable to update my Nvidia driver past 512.15. My external monitor will not work through the Thunderbolt 4 on any later versions, any idea why this would solve the problem for some and not others?
     
  9. MA250

    MA250 New Member

    I confirmed the latest game ready driver 517.48 release date 9/27/2022 fixed the issue on my Blade 17 3080 TI 2022 version.
     
  10. Bubblessmarttech156

    Bubblessmarttech156 New Member

    Can confirm USB 3 - / C port now supports 2nd monitor. Thanks Nvidia!
     
  11. MA250

    MA250 New Member

    With game ready driver 517.48 release date 9/27/2022 I am running two external monitors at 3840x2160 off a Razer thunderbolt 4 dock. This configuration was not working unless I used the original driver that cam with the laptop (2022 model of the Razer 17 3080 TI 4K @144HZ.
     
  12. I´ve the same setup, just with razer blade 15. Same driver installed, but it just detects one of my monitors.
     
    GipsySnake likes this.
  13. MA250

    MA250 New Member

    Do you have each monitored plugged into the dock versus daisy chaining them. Do both monitors show up in windows display settings?
     
  14. I've plugged them both into the dock. And if i plug one out of the dock, the other one turns on. Just one is getting detected..
     
    GipsySnake likes this.
  15. BlackFireDragon

    BlackFireDragon Well-Known Member

    So for me 522.17 is Stable. Windows dont crash apps ar boot and nvidia control panel losd without any issues at Windows start.
     
  16. SRAY95006

    SRAY95006 New Member

    I have a Razer 17" (RZ09-0406). I updated the BIOS from version 1.03 to, the latest posted, version 1.06. Since then, I cannot get eternal monitors to work via the Razer Thunderbolt 4 Docking Station Chroma.

    The cable is the Razer provided Thunderbolt 4 rated. I connect from the Docking station using USB-C/Thunderbolt to DisplayPort on both monitors and the cables are rated for upto 8k 60Hz and support DP 1.4.

    I am running the latest NVidia drivers and have tried both Game Ready and Studio Versions (522.25 and 522.30 respectively) and these are the most current, publicly available, via NVidia.

    It worked fine prior to the BIOS update and since the update I have been unable to get the display outputs to work via the Docking station. Everything works if I direct connect to the Razer 17 thunderbolt ports.

    I've checked to make sure I have all the latest updates on Window 11 (10.0.22000 Build 22000)

    I do see the Razer Thunderbolt 4 Dock in the Thunderbolt Control Center:
    upload_2022-10-20_10-17-0.png

    Other devices attached to the Dock work fine (External SSD Storage, Keyboard/Mouse, ect...)

    Any suggestions on how to further diagnosis and fix this issue? Can I get a version of the BIOS 1.03 updater to try to revert to a known working version? Or is there a fix coming out that Razer is aware of?
     
  17. Joikansai

    Joikansai Well-Known Member VANGUARD

    Did you try also same driver that’s being used by @MA250 above? Latest driver doesn’t mean it’s the most suitable version of the device, actually it’ll be nice if Razer always makes update on the most suitable version for one model eventually.
     
  18. SRAY95006

    SRAY95006 New Member

    I have not tried to downgrade the NVidia driver. I want to make sure the point that this only happens with the Docking station and that it worked fine prior to the BIOS update to the latest Razer released version (1.06) for my model. It seems to be an issue between the Laptop and the Dock station and want to make sure that Razer Dev/Support get what they need before I start fiddling between different driver versions.

    I actually believe this is probably and issue on the firmware version running on the Dock station, but there is no way to troubleshoot that, or to find out what is running on the dock station.
     
    Last edited: Oct 20, 2022
  19. BlackFireDragon

    BlackFireDragon Well-Known Member

    @SRAY95006 In terms to downgrade the bios there is no way to do that. Bios updater will lock if detect on laptop older or the same version of bios. The only way to downgrade is by bios prohrammator but this will avoid the warranty. To the issue people on this thread report issue but only when they try to connect two external monitors via the dock with one there was no report that sameone have issue. You try to disconnect everything from the dock expect the monitor and reboot laptop go to bios and factory reset it to remove any issue that was made by any change and try to connect then only one device.
     
  20. SRAY95006

    SRAY95006 New Member

    It impacts either 2 or 1 external monitors connected to the Thunderbolt 4 Razer Dock. I tried with 1 or 2 connected, neither work.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >