Nanoleaf Aurora Integration

Discussion in 'Razer Chroma' started by Hyland92, Jul 31, 2018.

  1. Hyland92

    Hyland92 New Member

    Hi purchased some nanoleaf panels with the impression they would work with razer as nanoleaf have videos showing support and razer have a pairing tool. Once paired with my pc my chroma devices freeze and dont change colour and the panels dont react at all! Anyone had any luck getting this working thanks.
     
    ahlin941, qbapll, pancholr and 3 others like this.
  2. Kyron176

    Kyron176 Active Member

    Have the rhythm+15 but don't have it paired cause of decor. (Maybe one day)

    I wish you good luck.
    #RGB4Lyfe
     
    pancholr likes this.
  3. I also got a Nanoleaf and the integration with Razer is NOT WORKING in any way. There is also no evidence anywhere that it even ever did, as the only thing you find when searching for it are promo websites, obviously paid for articles and outdated guides from earlier this year. I love my Nanoleaf and my Razer gear, so I don't want to say that they are trying something scamy here, but it really rubs me the wrong way that they are still very much promoting this as "Gamer Integration" on Nanoleaf and on the Razer Chroma Workshop.
     
    pancholr likes this.
  4. s3rial4k1ll

    s3rial4k1ll New Member

    i have Nanoleaf, not working, why?
     
    pancholr likes this.
  5. Welcome to the club :) Its not working in general.
     
    pancholr, ahlin941 and s3rial4k1ll like this.
  6. s3rial4k1ll

    s3rial4k1ll New Member

    really? oh man
     
  7. Yes, unfortunately that feature is supposed to draw in the player crowd... Pretty fishy if you ask me. Let me repost here what what I have written elsewhere to fill you in:

    Nanoleaf promotes an integration with Razer Chroma that is NOT WORKING in any way. In fact, there isn't even any convincing evidence (user videos, images, etc.) that it even ever did, as the only thing you find when searching for it are promo websites, obviously paid for articles and canned shots from earlier this year. The guides also only describe how to use the PC connector tool - which works for most users trying to figure this out - but then just ends with "now your Nanoleaf syncs with other Chroma devices" which nobody can confirm. There is also this other thread about this issue from earlier this year that was silently archived without resolution and another one where the author after complaining about the issue was told by a Razer mod that he will be contacted via mail and receive instructions. I mean, how mysterious does this need to be? :)

    I love my Nanoleaf and my Razer gear, so I don't want to say that they are trying something scamy here, but it really rubs me the wrong way that both companies are still very much promoting this as "Gamer Integration" on Nanoleaf and on the Razer Chroma Workshop.
     
    s3rial4k1ll and imReqi like this.
  8. VizardXY

    VizardXY New Member

    I had nanoleafs working with Razer chroma for a day or two. I was playing around with my cousins panels. I decided to buy my own because I enjoyed it and now nothing is working. Synapse 3 completely doesn't work. Chroma SDK service crashes every time I open a Chroma App.

    Another person posted here who thinks the pairing tool seems to break chroma without a way to resolve it without reformatting your PC (as of now). I added my story to his post.

    I'm determined to get to the bottom of this. I've been elevated pst Tier 2 support directly to the Dev team.
     
    imReqi and DRIFT_IT like this.
  9. SeanIan81

    SeanIan81 New Member

    Ugh, finally got around to getting a piece of razer gear just so I could have my nanoleafs sync with gaming. This isn't exactly inspiring me to keep it at this rate. I'll contact them as well, maybe they will get to the bottom of this eventually...
     
  10. VizardXY

    VizardXY New Member

    Are you having the same problem? Did you try pairing your nanoleafs with the pairing tool? What result did you get?
     
  11. SeanIan81

    SeanIan81 New Member

    Shows as paired and active in the pairing tool, but it doesn't seem to have any impact with games or with the chroma effects I have set up. I've tried it with the rhythm module on and off.

    Honestly they should just build it into synapse like the hue lights, but considering all the complaints I see about synapse 3 in general who knows if that works either...
     
  12. VizardXY

    VizardXY New Member

    So your Chroma effects are working normally? You are using Synapse 2?

    When you click apply in the pairing tool and then open say music visualizer, nothing happens with your nanoleaf but your keyboard/mouse correctly does the effect?

    Hey you guys! I made some awesome progress!

    I was able to fix my Synapse 3 issue.

    I had corrupt windows files. In my troubleshooting, I had already tried running sfc /scannow. This did not find any issues.

    BUT, what a support agent failed to mention in their steps was the need to run Deployment Image Servicing and Management (DISM) in order to update my local files for windows to verify against.

    Learned about this here: https://support.microsoft.com/en-us...er-tool-to-repair-missing-or-corrupted-system

    The command to run is this: DISM.exe /Online /Cleanup-image /Restorehealth

    Once I did that and re-ran sfc /scannow, windows found corrupt files. It automatically repaired them. I rebooted, installed Synapse 3 and the program started working normally!

    I was able to pair my Philips Hue lights and I am able to use them with Chroma Apps!

    But that brings me to my bad news.

    I discovered a second problem. It's the same exact problem that the OP posted about. The moment I run the Nanoleaf Pairing Tool, the Chroma SDK breaks.

    I was able to reproduce this, and also fix it.

    Here are the steps I took to both replicate the issue, and fix it once again:

    1. Make sure Synapse 3 is working and Chroma Apps are working (Keyboard Visualizer used as a test) then close Keyboard Visualizer.
    2. Open the Nanoleaf pairing Tool.
    3. Hold the power button on the Nanoleaf until it starts pairing.
    4. Click discover in the Nanoleaf Pairing Tool.
    5. Once you see your Nanoleaf appear, pair it.
    6. Click the Devices tab, then click Apply for your Nanoleaf.
    7. Now, go back and open the Keyboard Visualizer app.
    8. Chroma Apps no longer work at this point for me. If I open Services.msc, I can see that the "Razer Chroma SDK Service" is no longer running (it crashed).
    9. Go ahead and restart the service. Nothing seems to be working still.
    10. Go into "Add or remove programs" and uninstall the Chroma SDK only.
    11. Then open regedit.
    12. Browser to HKEY_LOCAL_MACHINE > SOFTWARE > WOW6432NODE
    13. Delete the Nanoleaf folder (key)
    14. Go back into "Add or remove programs", click Razer Synapse 3, then click uninstall.
    15. When the Window opens, click Repair.
    16. Once the Repair completes, restart your computer.
    17. Go ahead and open Synapse 3 and make sure it is working and you are logged into your account.
    18. Open Keyboard Visualizer, and Chroma Apps should now be working again.

    Basically what I've concluded is that the Nanoleaf Pairing Tool is breaking the Chroma SDK when it is paired with a Nanoleaf and the only way to fix it is by reinstalling the Chroma SDK (by uninstalling it and repairing Synapse 3)

    Can the OP try my steps?

    Can the Razer support folks update my case with these findings? I would love to actually talk to one of the Devs to show them this. I still haven't been contacted by the Dev team yet.
     
    Last edited by a moderator: Dec 1, 2018
  13. SeanIan81

    SeanIan81 New Member

    So just an update for everyone, I just got off of a support chat.
    I was first told via email to use Synapse 2 via email, which still will not recognize the keypad.
    Support chat was unable to help me get the keypad recognized by Synapse 2 and said to leave it running and try Synapse 3.

    Synapse 3 is working and chroma effects are working fine so far, but the lights still won't sync so they took some logs. I started digging into the logs as well and in the RzSDKService.log file I was able to find this:

    [2018-11-28 19:45][Info]Load Nanoleaf (Triggered by param Enabled = 1) (Configured by Nanoleaf pairing tool)
    [2018-11-28 19:45][Info]Load Nanoleaf (Triggered by param Enabled = 1) (Configured by Nanoleaf pairing tool)
    [2018-11-28 19:46][Info]Load Nanoleaf (Triggered by param Enabled = 1) (Configured by Nanoleaf pairing tool)
    [2018-11-28 19:51][Info]Load Nanoleaf (Triggered by param Enabled = 1) (Configured by Nanoleaf pairing tool)
    [2018-11-28 20:07][Error]ParsePanelLayout returns exception (Invalid IP / Network Error / Device not found)
    [2018-11-28 20:08][Error]ParsePanelLayout returns exception (Invalid IP / Network Error / Device not found)
    [2018-11-28 20:08][Error]ParsePanelLayout returns exception (Invalid IP / Network Error / Device not found)
    [2018-11-28 20:09][Error]ParsePanelLayout returns exception (Invalid IP / Network Error / Device not found)
    [2018-11-28 20:09][Error]ParsePanelLayout returns exception (Invalid IP / Network Error / Device not found)
    [2018-11-28 20:09][Error]ParsePanelLayout returns exception (Invalid IP / Network Error / Device not found)
    [2018-11-28 20:10][Error]ParsePanelLayout returns exception (Invalid IP / Network Error / Device not found)
    [2018-11-28 20:10][Error]ParsePanelLayout returns exception (Invalid IP / Network Error / Device not found)
    [2018-11-28 20:36][Error]ParsePanelLayout returns exception (Invalid IP / Network Error / Device not found)
    [2018-11-28 20:37][Error]ParsePanelLayout returns exception (Invalid IP / Network Error / Device not found)

    This is despite the pairing tool stating the lights are paired and enabled.
     
  14. VizardXY

    VizardXY New Member

    Can you tell me where this log file lives once it is created? I searched my C drive and couldn't find it. Maybe I never had one generated?
     
  15. SeanIan81

    SeanIan81 New Member

    This is the link I was provided by support to collect the logs from Synapse.

    http://dl.razerzone.com/drivers/Synapse3/win/LogCollector/Razer_Log_Collector_V1.6.0.zip

    I'm starting to wonder if it would be easier to make some IFTTT applet that could simply pair the chroma profile to a premade scene in Nanloeaf. Not sure how simple or seamless that would be but I'm kind of concerned about where the communication is between these two companies.

    Nanoleaf has told me Razer built the integration, and Razer has stated that Nanoleaf is the one that made the tool. While both are technically true there is some kind of disconnect here and it really shouldn't be this difficult. To be fair Razer just reached out to me and informed they that they have created a feature request for Nanoleaf integration with Synapse 3. I have no idea what that entails, and what a timeline for such a feature would be, but its a start I guess.
     
  16. VizardXY

    VizardXY New Member

    So it is actually really easy to manually pair the Nanoleaf in the tool. You can edit the Reg key in here:

    HKEY_LOCAL_MACHINE > SOFTWARE > WOW6432NODE > Nanoleaf > AuroraDevices

    Here are the instructions I received from Nanoleaf support a while back:


    Can you please follow the steps below in order to successfully sync with Razor and let me know where in the setup process you get stuck?

    1) Begin by determining the IP address and the ID of the Controller on your local network. You can do this by checking on your router (it will show up as IEEE Registration Authority with the MAC Address beginning with 00:55:DA) or using a tool like SSDP or Bonjour browser on your phone should assist with this (Android: https://play.google.com/store/apps/details?id=com.melloware.zeroconf&hl=en_CA or iOS: https://itunes.apple.com/us/app/discovery-dns-sd-browser/id305441017?mt=8 - see attached image)

    2) From there you will need to obtain an http service like postman: https://www.getpostman.com/ in order to obtain the Light Panels authentication key.
    a) In Postman: enter the following (but don't press send yet)
    <IP_address_of_Light_panels>:16021/api/v1/new
    b) Hold the power button of the controller for 5-7 seconds until the LED starts flashing in a pattern
    c) Then select Send and the authentication token will be generated appearing like this:
    {"auth_token" : "xxxxxxxxxxxxxxxxxxxxx ... xxx"}


    3) Now you'll need to register the device in your Window's registry.



    a) Run the command 'regedit' which will open up the Windows registry.

    b) Navigate through the following folders: HKEY_LOCAL_MACHINE > SOFTWARE > WOW6432Node

    c) In the WOW6432Node folder create a new folder (called a key in this view) called Nanoleaf

    d) In that key create a new key called AuroraDevices

    e) Create key within AuroraDevices named the ID of the Light Panels (as found in the discovery browser - see attached screenshot)

    f) Within this folder you will need to create 4 string files:

    1) authToken - which has the value of the Token you obtained in step 2

    2) enabled - which has the value of True

    3) ip - which has the value of the IP address of the Light Panels (ex: http://192.168.1.23:16021 - be sure to have the port 16021 specified and the http:// in front!)

    4) name - which is the value of the name - in the screenshot this is Light Panels 50:22:8c



    Then when you open the tool, you should see your panels.
     
  17. SeanIan81

    SeanIan81 New Member

    My panels have shown up in the tool, After numerous support chats and issues the issue now seems to be that my hardware doesn't work with Synapse 3 and as more hardware comes out support will be dead in the water until they implement support for Synapse 3.
     
  18. VizardXY

    VizardXY New Member

    I've begun suspecting that the Nanoleaf Pairing Tool doesn't support Synapse 3. I really hope they address this soon.
     
  19. Mednar

    Mednar New Member

    I spent a lot of money on 24 Nanoleaf panels and was so excited to use them. I thought they weren't working because I didn't have a Chroma device for them to sync with so I got a Tartarus V2 as I love my original one. It was trash and the bindings froze every single game, returned it. Then I got a HDK to pimp out my tower a bit. Seemed to show up fine as a chroma device but it still wasn't working so I also got a keyboard despite having a perfectly fine working Logitech one. Keyboard plus HDK and still the panels weren't working. Worse yet the chroma devices weren't reacting in game as advertised.

    Searched the internet high and low, hours of chat support, still nothing. Finally sent in logs today and had them escalate. At about 14 hours this week alone trying to get it to work. On my own I've found the issue with the SDK service constantly crashing, restart it only for it to crash again. It was only about 30 min before I found this thread that I narrowed it down to the Nanoleaf utility as well. I'm not sure but believe these two things have to be related. I also am baffled as to why I have to unplug my HDK every time I reboot to get my PC to boot correctly, otherwise it simply boots in a loop.

    Has anyone figured anything out here since discussion halted a little over a month ago? Any ideas on the separate HDK boot issue? Did I get bamboozled into buying over $300 in Nanoleaf products and over $100 in razer products only for none of it to work as advertised? I'm so frustrated by the whole thing.

    P.S. It appears regular Chroma functionality works as long as the nanoleaf panels are unchecked (disabled) under the "Devices" tab in the pairing tool.
     
  20. VizardXY

    VizardXY New Member

    I have been in constant contact with Nanoleaf and Razer. The only problem is my contact at Razer who I was working with stopped responding to me in November. I've sent him 2 emails since then, and I've contacted General chat support with my case number.

    Nanoleaf support:

    "
    Hi Jon,

    Sorry for the delayed response. I do apologize for any frustration this may have caused. While I do understand your position, unfortunately, Razer is who built the integration. We are continuing to work with Razer to further investigate this issue, and are pushing to attempt to resolve this as best as we can. However, at the moment there have been no concrete advancements made. Once we are advised of a solution, rest assured that we will be implementing the best course of action for the customers that have been inconvenienced. That said, I would suggest that you continue to force the issue with Razer. This will ensure that you are kept in the loop as far as any new developments may go. I do apologize for any inconvenience you may encounter while we are attempting to resolve this. I can say with the utmost confidence that we are as eager to resolve this, as you are to have this resolved.

    Regards,


    Jeremy Grant"
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >