Razer Basilisk lighting is stuttering

Discussion in 'Razer Support' started by eclipsefalcon7, Jul 3, 2020.

Thread Status:
Not open for further replies.
  1. eclipsefalcon7

    eclipsefalcon7 New Member

    ok so i got a basilisk mercury white edition for Christmas last year and i have experienced any problems except an issue witch the thumb button not working so i cleaned it and it worked but now the lighting on my mouse is flashing super quickly not like the spectrum effect however on the synapse software it shows the mouse using the lighting i set for it (reactive for the mouse wheel and audio meter for the logo) and a few days ago i could hear rattling in the mouse so i think there is something broken on the inside of the mouse i also change the effect to see if that was it but to no avail i also switch the USB it was plugged into and unplugged it for some time and have tried using the mouse without light for a while but turning it on instantly returns it to the flashing colors one more thing to note is that the color i set is correct just the lighting effect is wrong
     
  2. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hey there! Please gather your Razer Synapse 3.0 logs by following the steps here. Once done, please clean install the Razer Synapse 3.0 and see if it helps. Should the issue persists, send me a PM together with a Google Drive or other online drive account link that contains the Synapse logs. I'll pick it up from there.
     
  3. eclipsefalcon7

    eclipsefalcon7 New Member

    hi sorry for not updating the thread but i fixed it after giving the mouse a firm shake
     
  4. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    That's good to hear! Let me know should you have other concerns. I'll be locking this thread now.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >