Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Razer Blade Pro 17 2020 Ram Issue

Discussion in 'Razer Support' started by Ljcastellano, Jul 3, 2020.

  1. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    Thanks for sharing your observation. I call that the RAM dance (swapping/testing the modules to both slots). Please send me your email address or case number via PM so I can update your case.
     
  2. Lawalong

    Lawalong New Member

    It is very hard to post a message in here actually, got lots of permission denied intermittently. Can you also fix the Forums ...
     
    chusiupan likes this.
  3. I'm having exactly the same issue with my HyperX 64GB ram. Is there a solution to that?
     
  4. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    Have you tried sending me a PM? Should you still have an issue, please let me know so I can send you a PM instead.

    Hey @JADEfrontYellowGreen520! I've replied to your PM. I'll wait for your follow-up.
     
  5. chusiupan

    chusiupan New Member

    I have the same problem when running 32GBx2 RAMs together with my 2020 Razer Blade Pro 17 4K120Hz RTX2080. My 64GB RAM kit is Kingston 32GB HyperX Impact HX432S20IB/32 DDR-4 3200MHz CL20 SODIMM. There seems to be no issue when the 32GB RAM runs in single channel.

    After verifying the RAMS are not faulty. Razer Tech Support guided me to upgrade BIOS to 1.04 but it does not solve the problem and they have asked me to return the laptop to repair center. Hopefully this problem can be solve with another new BIO update instead of risking the laptop being damaged with shipping back and forth.

    Since this issue has been brought up for months, has anyone manage to solve this without needing to buy another set of RAMS for trial and error?
     
  6. Lawalong

    Lawalong New Member

    I mentioned
    upload_2020-8-28_13-35-24.png

    Here is the answer I got from one of "Senior Techicians"
    upload_2020-8-28_13-36-3.png

    Hey Razer, you better re-evaluate your employee. or I might change my faith to other brands.

    I don't think this guy even a qualified entry-level

    Really really disappoint
     
    dreambeats likes this.
  7. I feel the same, I'm waiting for a senior technician that was supposed to reply within 24h for 72 hours now. I'm just gonna return my RAM.
    I wish I could do the same with my Razer Blade to be honest. At this point I'm not sure if I even CAN have 64 gb of ram in it.
    Pretty disappointing.
     
  8. Lawalong

    Lawalong New Member

    Hi mate, 64gb 3200 CL21 Samsung works fine for me (for 2 weeks now), but this one without XMP so it working at 2933 eventually
     
  9. Thanks man!
    I'll try to find it in Europe; )
     
  10. This is the answer I get after a week of talking to support?
    I'm not gonna even bother to respond. Your support guys is a "LITTLE" below of what I expetcted.
     

    Attached Files:

  11. chusiupan

    chusiupan New Member

    Agree with the Razer Support part. After weeks of conversation exchange, some of their replies left me absolutely speechless and lost faith. It seems like some of the support technicians just cannot be bother to investigate and address the issues properly. It feels like they just throw in some "official model answers" to you and hope the next technician in line will solve it. Every support reply is with a different technician. I feel pity for the competent technician and repair center that have to share these kind of stack up workloads from the incompetent ones.
     
  12. chusiupan

    chusiupan New Member

    For my case, I described my issues to Support in great details and my troubleshoot pretty neatly. They asked me to rewrite my case according to their question format. When I told them my laptop cannot even boot up due to Bios update failure and could not access Desktop/Recovery Mode/Reinstall Windows OS. They asked me to back up my files and go into Desktop Settings to do a system recovery. o_O

    Eventually, they just told me to ship the laptop back to repair center but they will not be responsible for shipping lost or damage.
     
  13. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    Hey Lawalong and JADEfrontYellowGreen520. I've tapped our Support Team regarding your feedback. I've updated your case numbers.

    Hi chusiupan! Your feedback is important too. Please send me a PM together with your case number so I can check and update the escalated ticket.
     
  14. Akht79

    Akht79 New Member

    Hello,


    I wrote in this forum back on August 4th on line 14. Since that time I have RMA'd Four different 2020 17inch razers laptops for a refund (because the RMA replace option is very slow. I waited for a month then asked for a refund instead and order a new one each time). All four laptops had the same thing in common. They would not work with the HyperX impact 2666Mhz or the HyperX Impact 2933Mhz in a 2x 32Gb RAM stick configuration and would BSOD immediately on Windows boot or shortly thereafter and would hard lock with memory exception message on Linux boot. I have received my fifth 2020 Razer Blade 17 laptop. This laptop is still an early 2020 model. I have installed the RAM (HyperX Impact 2933Mhz in a 2x 32Gb RAM configuration) without any issue thus far. A few things I notice in this laptop that differ from the last four laptops are the BIOS and EC FW versions. The last four laptops had version 1.0. This laptop has come with version BIOS 1.03 and EC FW 1.01. Also, I notice XMP profile is in the BIOS where it was not in the last four laptops. I have attached photos for reference. I hope this will help everyone.

    (*Removed the screenshots that are showing the laptop's BIOS info.)

    *Update*
    Still working, no BSOD. I used the laptop for several hours. I powered the laptop off and on a few times to try to make it BSOD. I have not gotten any BSOD. I did try updating previous laptops BIOS to 1.03 and this did nothing to fix the issue. I never tried updating the EC FW in previous laptops. I think that it's possibly the EC FW version that is the issue and the fix. I would try updating the EC FW version.
    http://drivers.razersupport.com//in...wnload&downloaditemid=3877&nav=0,350,996,1005

    Razer Support has removed the photos of the BIOS that I posted but eveything stated above is what was shown in the photos.
     
    Last edited: Sep 4, 2020
  15. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member


    Hey there! I appreciate the gesture. However, posting sensitive details such as your laptop's BIOS information on threads is against our house rules. Feel free to send me a PM or visit our self-help options should you have other questions or concerns.
     
  16. Akht79

    Akht79 New Member

    Still no issues.
     
  17. pongwon

    pongwon New Member

    I've got the HyperX impacts 2933Mhz in 2x 32Gb RAM as well. With bios 1.04 and EC FW 1.01 I've been able to get past the blue screens I was having. Unfortunately games still crash when running on the 2933 profile. If I use the 2666mhz profile things are stable. I'd like to run it at 2933 but not sure what else to try.
     
    Razer.SpeedCr0ss likes this.
  18. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    Thanks for sharing. Should the issue persists, please submit a case to our Support Team or send me a PM.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >