Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Razer Central Not Allowing Login

Discussion in 'Razer Support' started by MoonshadowXV, Apr 3, 2019.

Thread Status:
Not open for further replies.
  1. MoonshadowXV

    MoonshadowXV New Member

    Every time I try to login to the Razer Central application it says there was an unexpected error and to reload the page and try again. It did not do this with my laptop. I can login to the website but the app still shows this message, only on my new PC. I've reinstalled the application. This is to access the RGB Panel to light up my keyboard.
     
  2. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hi there! Let me help you out. Can you share a screenshot of the issue so we can take a closer look?
     
  3. MoonshadowXV

    MoonshadowXV New Member

    Sorry, I work from when Razer support opens until after it closes, which is also something that's making this situation really frustrating. As of when I got home, the application will no longer open, so I can't take a screenshot at this time. I'll see about reinstalling the application again.
     
  4. MoonshadowXV

    MoonshadowXV New Member

    [​IMG]
    I reinstalled the application. It has been on both my SSD and Harddrive so it has nothing to do with where it was actually downloaded to.
     
  5. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Thanks for the screenshot. Please PM me the build version of Synapse as well as the link to this thread. I'll pick it up from there.
     
  6. TOPAZradio196

    TOPAZradio196 New Member

    Hi,
    Same here.Can share the solution? I keep having this pop up.
     
  7. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hi there! Have you tried doing a reinstall to see if it helps? Let me know through PM.
     
  8. Chan602

    Chan602 New Member

    yeah, i have the same problem on my razer blade 15 2018 pls help
     
  9. Nazareim

    Nazareim New Member

    Same problem here too, re-installed all Razer applications

    Edit: doesn't help
     
  10. Chan602

    Chan602 New Member

    did that work?
     
  11. SenZjo

    SenZjo New Member

    same here.. Razer synapse (3.4.630.62510) and razer central (7.3.19.118) stopped working after the last update.. same error as OP... reinstalled 2 times already.. no go.. (windows 10, 1903)
     
  12. Topshottax11

    Topshottax11 New Member

    Same issue for me
     
  13. Valorus9000

    Valorus9000 New Member

    same here. can't get it to login after the last update
    upload_2019-7-15_19-12-51.png
     
  14. Spiff2000

    Spiff2000 New Member

  15. Rodorn

    Rodorn New Member

    Same here. It's god damn raid night in 18 min and i cant play :/
     
  16. Gamerratic

    Gamerratic New Member

    I'm having the same problem as OP as well with Razer Synapse. Restart and reinstall did not work.
     
  17. antonis179

    antonis179 New Member

    same.

    Anyone wanna buy a blackwidow elite before I throw it out the window?
     
  18. Spiff2000

    Spiff2000 New Member

    Now I know what they mean by: Maximize your unfair advantage with Razer Synapse 3! :D hehehe!
     
    antonis179 likes this.
  19. antonis179

    antonis179 New Member

    Why do we need to be logged in to even manage the lighting on a keyboard?? And why do you advertise on-device profiles without specifying they do not work without the software? Seems like information I'd like to have before paying 150 eu
     
  20. sebix80

    sebix80 New Member

    I think it's problem from razer's site.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >