Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Razer Central Not Allowing Login

Discussion in 'Razer Support' started by MoonshadowXV, Apr 3, 2019.

Thread Status:
Not open for further replies.
  1. Subhuti

    Subhuti New Member

    all my own settings on my razer tartarus v2 has now been reset, and cant even go in and change them, wtf
     
  2. Rodorn

    Rodorn New Member

    It's ludicrous that their software doesn't have offline mode. It should be basic feature
     
    ryiinn, Subhuti and sebix80 like this.
  3. Jigs74

    Jigs74 New Member

    A little confused why I would have to "log in" to an app to change local device settings like lighting. Regardless, experiencing same issues with logging in.
     
    antonis179 likes this.
  4. ryiinn

    ryiinn New Member

    Same problem here. It's incredibly frustrating that basic settings aren't stored locally. I also have a raid coming up and can't play if my mouse buttons don't work. :mad_:
     
  5. CapsuleGraph

    CapsuleGraph New Member

    Same problem here. Probably a problem on Razers end if we are all having this issue within this short time frame.
     
  6. Fr3kOnALeash

    Fr3kOnALeash New Member

    Found a "potential" workaround:

    - Close Racer Central / Synapse in your Tray (bottom right)
    - Pull your Ethernet Cable from your PC / Disable your Network adapter (aka no internet)
    - Restart Razer Central / Synapse
    - Input your old Account & PW
    - Wait for succesful login
    - Reconect Ethernet / Reactivate Network adapter

    Just worked for me.
     
  7. Fr3kOnALeash

    Fr3kOnALeash New Member

    Shit, scratch that. After the internet connection came back razer logged out again.
    Wow, one of the worst programs i have ever used in a long time...
     
  8. MaxPlaceo

    MaxPlaceo New Member

    It's working for me now. After about 20 attempts of logging in...
     
  9. Gamerratic

    Gamerratic New Member

    Same. I was able to log in again.
     
  10. CapsuleGraph

    CapsuleGraph New Member

    Yep, its back up
     
  11. Spiff2000

    Spiff2000 New Member

    It worked for me now.. So look like they got the services running again! :D

    Good work Razer team!
     
  12. b00tl00p

    b00tl00p New Member

    I'm able to log-in too but my profiles are gone!
     
  13. Jigs74

    Jigs74 New Member

    Back up and working again, can we fix the app so we don't need to login for these things?
     
  14. SenZjo

    SenZjo New Member

    seems to be fixed now...
     
  15. Is there a solution already? I'm also having the same problem here
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >