Razer Synapse 2 not opening

Discussion in 'Razer Synapse' started by blackyboy2017, Jul 25, 2019.

  1. BOOONKGANG

    BOOONKGANG New Member

    Yup still hasnt been god damn fixed
     
  2. Hitpoint2

    Hitpoint2 New Member

    I mean come on, Synapse is not working for more than 3 months.. WTF RAZER?
     
  3. natana3l

    natana3l New Member

    not working on any version of windows as it seems.
    tried on: w10 1903,1803,1703, and w7 sp1 all beeing x64
     
    DRIFT_IT likes this.
  4. blackyboy2017

    blackyboy2017 New Member

    yeah, it's still not working for me since august. So nice Razer.. new update came, nothing new. Installed, log in.. nothing. Still doesn't open. Didn't work on 1809, 1903, 1909 version Windows. So I gave up.
     
  5. So frustrating. :mad_: I may need to buy a Logitech, they doesn't seem to care about customers. :confused_:
     
  6. Shinolina

    Shinolina New Member

  7. Same issue. I have an old Taipan and ready to upgrade. No razer response, no workaround, for months!??!?! Why should I consider razer for my next mouse?
     
  8. koshtan

    koshtan New Member

    Why not just switch to version 3? It looks stable right now, at least for me.
     
  9. Mawzen

    Mawzen New Member

    As of last Windows update I have this problem as well. I no longer can use the Macro keys from my BlackWidow Ultimate and launching the program won't do anything in any means. I've used Revo Unistaller for fresh installs and also nothing. I've also noticed that by changing ports it fails to update itself.
    Anyone with a fix yet?

    Because some of us have "older" products that aren't compatible with v3?
     
    blackyboy2017 likes this.
  10. Shinolina

    Shinolina New Member

  11. Taipan is not supported in v3.
    This thread made me give up on Razer, I allready ordered a new Corsair Glaive.
     
  12. blackyboy2017

    blackyboy2017 New Member

    yeah it's working for you. That doesn't mean it's working for me or for us. I've tried everything and the razer synapse 2 is still not working on 5 computers I've checked. The version 3 is working, but my razer kraken is not supported by version 3.
     
    RegarD_ likes this.
  13. tailzborne

    tailzborne New Member

    Having this same issue as of today. Just got the quartz Huntsman and Basilisk and no-go. Came here to hopefully find a solution. Ughh
     
  14. nopalpite

    nopalpite New Member

    Multiple thread had been opened about this issue and Razer do nothing ... it's a shame.
     
  15. M-S-G

    M-S-G Active Member

    Have the same problem with Synapse since November. How long does Razer take to fix it?

    And no, Synapse 3 is unfortunately not compatible with the Ornata without Chrome.
     
  16. I have the same problem. Unreal they haven't released a fix yet?!
     
  17. santiserna6

    santiserna6 New Member

    To all the people in this thread problem with SYNAPSE 2 and 3... this is gonna be dificult because im spanish so sorry for my english.
    I've made a super reaserch on this issue and i end up talking with a Razer support guy on the Chat page. The main issue coud be WINDOWS UPDATE. If it's not Updated with the last microsoft update version on the Microsoft page of Windows, it could be not Syncronizing because synapse 2 and 3 is a CLOUD base configuration.
    My windows update got stucked in version 1607 four years ago at 0%.... the actual version is around 1900... Acording to RAZER the synapse 2 is working for a lot of users and will be going to be updated for a long time!
     
  18. santiserna6

    santiserna6 New Member

    For the end MAC USERS with problems with synapse 2 are having trouble because CATALINA supports only apple Apps

    For the people with problems with Razer Kraken 7.1 v2 chroma or Usb headsets theres 2 Screenshots

    THE MOST IMPORTANT WITH RAZER SUPPORT PERSON WORDS FOR ALL THE PEOPLE COMPLAINING IN THIS FORUMS: "We just can't help them since Razer Insider is not under our scope." ..... (so don't waste your time).

    So in the end i attach the conversation to you for all to see if this works or not.

    https://ibb.co/ydj4jvS
    https://ibb.co/s6Q5D7k
    https://ibb.co/VwjR3bQ
    https://ibb.co/y5rwnJX
    https://ibb.co/3y8RgyP
    https://ibb.co/x5nVT3v
    https://ibb.co/TtRWTCc

    If it worked for you and if you want leave me a follow on any of my pages.
    follow twitch.tv/sntj
    twitter : mishi_im
    instagram: im.mishi
    Facebook: Im Mishi
     
  19. RegarD_

    RegarD_ New Member

    did yall already fix the problem? if yes pls tell me
     
  20. Just installed again and it seems to work, my windows version is 1903 (Os Build 1836.592)
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >