Razer Synapse 3 THX Spatial Sound Mixer/EQ Problem

Discussion in 'Razer Synapse' started by KeyShr3kt, Dec 26, 2020.

?

Did this method solve your issue?

  1. Yes.

    26.7%
  2. No.

    73.3%
Thread Status:
Not open for further replies.
  1. KeyShr3kt

    KeyShr3kt New Member

    That's the thing that is driving me nuts, when it works, it really works. The sound imo is really good, the spatiation is great, improved my capacity of localising enemies in CS by a lot. But the software is really really buggy and I am really sad because I always was a Razer fanboy. First product to be that buggy tho, the mouse and the keyboard are working amazing and I have no complaints. So, the conclusion, don't ever buy Razer headsets again.
     
    msevket likes this.
  2. miomir09

    miomir09 New Member

    THE RAZER BLACKSHARK V2
    Same problem here.What should I do.
    Тo throw them out the window.Shit software.
     

    Attached Files:

  3. specwolf82

    specwolf82 New Member

    Have you gone to the profiles tab at the top and tried to manually search in the folder and find the game you are looking for?
     
  4. miomir09

    miomir09 New Member

    Attached Files:

  5. Southey

    Southey New Member

    Having the same problem, uninstall , reinstall works for a few hours, shutdown pc , reopen pc , problem starts again.
     

    Attached Files:

  6. leadene

    leadene New Member

    getting this issue been having it since day one of buying my razer kraken ult, this software needs a fix stop blaming your customers. razer synapse 2.0 was way better then your razer synapse 3. fix the software already.
     
  7. Rikitikitavi

    Rikitikitavi New Member

    Mechanical button not working if conect headphones to Razer Laptop, working only software switcher from Synapse. As I see it is a mass problem. Many, many install and reinstall Synapse 3 =\

    1) https://insider.razer.com/index.php?threads/kraken-ultimate-thx-button-not-working.66403/
    2) https://insider.razer.com/index.php?threads/thx-toggle-button-not-working.61754/#post-611053
    3) https://insider.razer.com/index.php...-thx-feature-of-my-headset.63766/#post-674799
    4) https://insider.razer.com/index.php...ate-thx-button-not-working.60602/#post-595947

    If plug on another laptop all work normal.

    Has anyone solved it?
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >