Razer Tartarus V2 controller D-pad sticking / glitch

Discussion in 'Razer Support' started by cpoChiD, Dec 10, 2020.

  1. NoahArk620

    NoahArk620 New Member

    Please keep us updated. :3 Razer Support has stopped their conversation with me already, so I had not been keeping things up to date.

    I had been hearing Naga Trinity been having the same issue since a few months back though.
     
  2. waaaghmachine

    waaaghmachine New Member

    This issue extends to the Razer Huntsman V2 Analog. I’ve been giving the same instructions on using different ports, using a clean version of Synapse, and then Razer suggested I return it to the retailer for another one. Maybe I had a defective keyboard? Well… I’m trying again, this is my third keyboard, and to nobodies surprise, it has the same “sticky” keys. If I log out of Synapse, the issues go away completely.

    The only thing I get from Razer anymore is an RMA offer, zero solutions to their flagship new keyboard, which isn’t getting “reviewed” by many prominent youtubers who typically cover Razer products (Badseed, RandomFrankP, HardwareCanucks).
     
  3. Daisame

    Daisame New Member

    I have not heard from Razer support in about a month. So guess they stopped sending the automated "we have not heard from you in a while and want to see if you ware still having issues" email. I guess they got wise to my automated response saying I was still having the issue.

    In any case, I don't know what (if anything) is being done to actually identify and correct the issue.
     
  4. NoahArk620

    NoahArk620 New Member

    With reports affecting not only Tartarus v2 and Pro, but also including their other newer product lines like Huntsman V2 Analog, and Naga Trinity, this could be a sign for things to come. Perhaps this warrants a new thread to have everyone chime in to get noticed. What do you guys think?
     
  5. Daisame

    Daisame New Member

    New threads generally only clutter the issue. I don't know if it would be worth it. I just asked for an update on my case, I think everyone who has not already, needs to open support cases and keep on top of them for updates.
     
  6. Neco2510

    Neco2510 Member

    I have the same issue with my huntsman analog.
    Seems razer are completely ignoring the issue.
     
  7. Katyblossym

    Katyblossym New Member

    Hey all, thought I may share something I experienced with the rest of you, maybe something to pick our brains on.

    TLDR: After having to update my bios/chipset/virtual memory paging file settings due to a blue screen that has literally plagued me for years if I tried to update from my factory BIOS (but was forced to in order to make my new CPU work), I had no sticky dpad issues with my Tartarus v2 during 2 hours of play time. I am not sure what the particular "fix" was (if it remains working correctly), but I have an idea that it may have been the way my motherboard USB ports were communicating with my Razer devices, possibly with Synapse/drivers as a middleman but I am not sure. Synapse DID run an update after I did all my BIOS updates/fixes that I describe below in detail, but I also had a bunch of devices update drivers including my built in Realtek Audio on my motherboard.

    Full Story (stick with me here): I have a Gygabyte Aorus AX370 Gaming K-5 (rev.1) motherboard that previously had a 1st gen Ryzen 1600x installed. Any time I would try to update my BIOS, I would pretty quickly get a PAGE_FAULT_IN_NONPAGED_AREA blue screen, which is one of the most unhelpful blue screens one can get. Any time I attempted to update the BIOS whenever I got brave, I would end up having to revert back to factory BIOS.

    Because of WIN 11 (which I am running the DEV build of now), I had to upgrade my CPU, so I ordered a 3rd gen Ryzen 7 3700x. Although my motherboard supports 3rd gen AMD CPUs, it wasn't until it wouldn't post after the CPU install that I realized dreadfully that my BIOS had to be updated to a much later version to support 3000 series Ryzen CPUs.

    After reinstalling my old CPU and installing specific BIOS updates, then required chipset drivers/etc for those specific BIOS versions in a specific order (quickly I must add to beat the dreaded blue screen), I continued to get the same blue screen. Eventually I went into my System Properties/Advanced/Performance Options/Virtual Memory and changed my paging file size from Custom Size to System Managed for both of my hard drives (the checkbox for automatically managed paging file size for all drives had previously been unchecked from things I had done in the past).

    Once I did all this, I received no further blue screens. I decided to stress test my system instead of letting it just sit on the desktop by playing Destiny 2, and of course I used my Tartarus V2. Typically before when I would play, I would get the occasional sticky dpad that we have all been experiencing. Surprisingly, in my 2 hour playthrough last night, I had no issues with my Tartarus v2 at all, it worked perfectly (I did notice some slight popping noises in my Kraken Tournament headset, but I think that has more to do with the Win 11 Dev build I am on and not Synapse itself).

    Note: All of my Razer devices remained in the same USB ports as they were before I did all the upgrades to my CPU/BIOS.

    I ordered a Tartarus Pro and I am expecting it to come in tomorrow. I still have some USB ports available, so I am going to test it when it comes in, creating a "duplicate" profile that matches how I have my Tartarus v2 set up. Since the Tartarus Pro has the analog features that others in this forum have had the same issues with, I am curious to see if I see any of those issues as my Huntsman Elite is the non-analog version.

    I will update after further testing and playing, hopefully SOMETHING that occurred during all my motherboard troubleshooting and fixing last night regarding my BIOS/CPU upgrades inadvertently fixed the issues I had with my Tartarus v2.

    @Razer.Speedcr0ss I hope you see this.
     
    Last edited: Jun 30, 2021
  8. waaaghmachine

    waaaghmachine New Member

    while this may lead to a solution, I don’t know if I subscribe to it being bios related since I can close Synapse and NEVER have a “sticky” key. I would get these issues maybe 4-6 an hour with Synapse running, and I went days without a single issue so long as Synapse wasn’t running.
     
  9. Katyblossym

    Katyblossym New Member

    I didn't necessarily mean BIOS related, but motherboard related; how Synapse is talking to the hardware (motherboard). I only mentioned BIOS because its how I discovered my Tartarus was working last night. HOWEVER, I think I jinked myself because playing tonight I had more issues than I have in two weeks.

    What I don't understand (at least on my machine) is how it can work perfectly one night and then be buggy as hell the next. Either way, I think we all agree that SOMETHING in Synapse needs to be fixed, but it probably won't happen until Synapse 4... or 5.. or 6...
     
  10. Daisame

    Daisame New Member

    Thanks for posting all your info. If there is some issue with the way Tarturus interfaces with the motherboard, then it ONLY seems to happen when Synapse is running. The easiest work around to the issue is to uninstall Synapse, and the problem goes away. So if there is some mismatch between the hardware and software, it is aggrivated by Synapse. People can use thrid party software to remap keys, make macros, and the problem also does not present. It is ONLY with Synapse that people seem to have the issue (at least from reading threads here).

    I tried to get an update after a month from Razer on this issue. They acted like they never talked to me before, startinig their tech support script from scratch again. It is extremely frustrating but leads me to believe that they are not taking this issue seriously. Frankly, I don't think they are even working on trying to fix the issue any longer. Until this hurts their business, they probably won't fix it.
     
    Neco2510 likes this.
  11. Neco2510

    Neco2510 Member

    I tend to agree with you on this.
    After several conversations of copy/paste messages they all end in the same way, RMA or go away (paraphrasing of course)
     
  12. Katyblossym

    Katyblossym New Member

    Hey all I promised I would post back with my results with the Tartarus Pro and in two days I haven't had any issues at all. I plugged it into the same port as the v2 was, and I copied my v2 profiles into the Pro.

    However, before I began using it, I was aware that the Pro will sometimes show up as a phantom xbox controller. I looked up some instructions on how to fix that before I even began using it, and I am wondering if it had anything to do with why my Pro is working without issue so far. I was hoping some of you all may try testing this and seeing what results you all get:

    Go into device manager, and under View, change it to Devices by container. Scroll to Razer Tartarus V2, and expand it. Look for HID-compliant game controller, right click and Disable device. See if you have any issues after that.

    I will post an image here. I have no idea if this will help any of you all now that I am on the Pro, but I still am curious to see if this has any benefit. If not, oh well, but as we seem to be our own tech support, it wouldn't hurt to give it a try. Please don't kill the messenger if you still have issues, I just want to try and help.
     

    Attached Files:

    Tachyana1 likes this.
  13. Katyblossym

    Katyblossym New Member

    Follow up: I know I am posting a lot here, but MAYBE I am doing some good. Not trying to be annoying or anything.

    My Tartarus Pro has continued to operate without issue, EXCEPT for one singular moment.

    I was playing Destiny, and I use a Naga as my mouse. I decided to plug in my Basilisk v2 while playing (leaving the Naga plugged in as well) just to see if it felt more comfortable playing.

    Windows did its whole "installing device" sound (Destiny was in the foreground so I couldn't see anything happening on my desktop, and a few moments later, I got stuck moving to the left on my Tartarus Pro Dpad. I then unplugged the Basilisk, and continued to play. After the mission I was in, I restarted my computer and I have had no further issues.

    Something happening simultaneously between the Windows driver install Synapse caused the Tartarus to bug out. Probably been said a million times before but I have a very strong feeling that this has something to do with drivers Windows is using for our devices and how Synapse reacts to them. Maybe when the driver activates or has to perform a function?

    Just ideas from what I am seeing.
     
  14. d1kk3

    d1kk3 New Member

    Not annoying at all. I'm following this thread closely with great interest. I wish Razer would too :)

    I've had the sticky button issue forever. I've tried a lot of things and by now i'm so used to it in games that i automatically cancel the stuck button by pressing it again pure by muscle memory :stuck_out_tongue_winking_eye: .
    I would love to see this fixed tho because it still gets u in awkward situations in games.
    I will try disabling the HID controller like u said and report back if i feel its fixed for at least a while.
    gl with testing.
     
  15. Aliceon

    Aliceon New Member

    This doesn't seem to fix the issue for me :slightly_sad: Still getting those sticking keys
     
  16. skylaar

    skylaar New Member

    I picked up a Tartarus V2 recently (before seeing this post) and have the same problems experienced here with different keys sticking at random. I remap most of my keys because I play with ESDF. Once you close Synapse 3.0, then no issue at all but I lose my key map. I have used an Orbweaver for years with no problems at all but it runs on Synapse 2.0 and I wanted to avoid having both installed along with the Orbweaver showing some wear. To say the least, this is disappointing. I am looking into alternative software to remap my Tartarus keys and control the lights.
     
  17. Seegeth

    Seegeth Member

    After 1h sticks again for me.

    reWASD works fine. (but only controls, no rgb, no scroll)
     
  18. Tachyana1

    Tachyana1 New Member

    I've been disabling the "Hid Compliant Game Controller" that razer installs since the original synapse software came out. It has always caused problems with windows. I've been using the Tartarus since the very first one came out.

    I never had the "D-Pad Glitch" AKA Stuck auto moving in one direction until you hit that key again, until I finally replaced my Tartarus with the newer version 2.

    The new Synapse 3 is far superior in gathering data and sending it home but much worse at actually doing what we need it for, gaming :slightly_sad:

    Razers psuedo joystick idea has never worked right. If you want sticks that work get an xbox controller. I recently got an MSI brand controller for my kid and not only does it work really good, it's well built and it works with xbox, pc, playstation, and android.

    Thanks Katyblossym for reminding me to look in the device manager for that crap driver Razer has never been able to get to work right. Since disabling it I've had no more problems. I had hoped that since it has caused problems ever since Razer first released synapse, that they had actually done something to fix it. Silly me, they put all their effort into gathering our personal information instead. If they would just be content with profiting off the products they sell instead of making us their product, maybe they could get the sfotware to work right.

    Disabling it means you can no longer use the D-Pad on the Tartarus as fake joystick. But I don't see a problem with that because inside, there are just 4 switches, not 8 switches, and definitely not 2 axis.

    Software to make windows think the Tartarus is what it is not just doesn't work.
     
    Katyblossym likes this.
  19. Katyblossym

    Katyblossym New Member

    Hey guys, just another quick check in - after hours and hours of gaming on my Tartarus Pro this week, with the driver that I had previously mentioned disabled, I have had maybe... 3 instances of a key sticking once or twice in a gaming session. I was on vacation this week, so I put in probably about 60 hours of game time while my partner was at work. That means that the probability for failure on this device is extremely low, and I am not sure exactly why that is.

    During the times that I have had an issue, it cleared up pretty much instantly. Just to be sure, I would do a reboot of my machine when I hit a quiet moment in the game I was playing. I have a really strong hunch that this is not just Synapse itself... during the times I have had the issue, I am pretty sure that when I experienced the issue, some other device I use that had to communicate with Windows did it's thing with its driver and cause Synapse to flip out (probably another Razer device, because I have a crap ton of them - my bet is my Blackshark v2 Pro because I had it communicating wirelessly via the dongle *secretly hates that word). Further credence to this theory is that the very first time I had an issue with this new Tartarus Pro is when I plugged in a Basilisk v2 while playing a game).

    With my previous Tartarus v2, I would often open Notepad and just play with the dpad with WSAD mapping and just type with it. No matter how much I moved the dpad around and typed, I could never replicate the issue, yet when I went into a game, I would instantly start having issues. More food for thought - Synapse recognizes the games we play, obviously... we see images for the latest games we are playing when we click the Synapse icon in our System Tray. Synapse doesn't notice Notepad as a game, so maybe that ties into all of this too. I can see the dots on the map, I just can't figure out how to string them together (starting to feel like Charlie on Sunny in Philadelphia).

    My professional life deals in the IT world, previously as a system/network admin and now an IT Operations Manager (I tell you this because my crazy theories and hunches have led me to some great successes with tech issues and that I am not just pulling stuff randomly out of the air). What I don't know is how to ping anybody in Razer to get them to notice my testing I have done.
     
  20. Katyblossym

    Katyblossym New Member

    Thanks for the shoutout! I'm always trying to help where I can, even if it doesnt always lead to a fix!
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >