Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Recent update to Synapse 3?

Discussion in 'Razer Support' started by RedAsKetchum, Apr 8, 2020.

Thread Status:
Not open for further replies.
  1. RedAsKetchum

    RedAsKetchum New Member

    Today after turning on my monitor I noticed a synapse update being installed. After this my nommo chromas wont sync with Wallpaper engine anymore. They seem to be frozen or very very laggy. Was there an update released???
     
    Dr_Axton and Hermanator like this.
  2. Cyraxus

    Cyraxus Active Member

    Having big time issues with the new update as well. All my lighting is going crazy. When I open the synapse app it keeps trying to reload the devices over and over again.
     
    Dr_Axton likes this.
  3. Jenjar

    Jenjar Well-Known Member VANGUARD

    I had issues with having no audio and videos, games etc.. were very laggy, and it turns out that the Synapse update changed my default audio playback device to from "Razer Kraken TE - Game" to "THX Spatial - Synapse". Everything went to normal when I changed it back. Yes, very odd haha.

    If you are using Razer audio devices at all, just check and make sure your audio playback device did not change, and if it did change it back to what it was previously, and maybe that will help.

    I am moving this thread to Support in order to get an official support agent on it as well.
     
  4. r3sp3ct-HsM-

    r3sp3ct-HsM- New Member

    I got the update notification but when I tried installing it, it just straight up broke and couldn't install. Snyapse does not show up in the task bar and it also does not open. Re-installing it just keeps giving me an "insufficient disk space" error but I still have 30+GB on my C drive.
     
    Yuzhe0111 likes this.
  5. I can't get the link program to work for new profiles, it worked yesterday but just really really slowly, took forever for an explorer window to come up. Now trying to link a program just locks the app and nothing happens.
     
  6. Dr_Axton

    Dr_Axton Member

    My wallpaper engine also stopped working with chroma connect (as well as all other apps) and I think my nari is now dead beyond repair. Did they really mess up something in the update?
     
  7. TotorroDG

    TotorroDG New Member

    I am having the same issue, Synapse 3 is not running anymore due to the latest update..... I have tried to re-install the software but I got a funny message saying that I don't have enough space on my hard drive (a 1TB SSD with 80% free space). Come on... !!!!.

    cheers
     
    Yuzhe0111 likes this.
  8. Dr_Axton

    Dr_Axton Member

    I was speaking with suppport today and after deleting synapse then these folders from registry: HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432NODE\Razer and Razer SDK and after that reinstalling synapse it started to work. Maybe that will help you as well
     
  9. Yuzhe0111

    Yuzhe0111 New Member

    Me too ,
    I tried many times but still not work
     
    TotorroDG likes this.
  10. RaMian924

    RaMian924 New Member

    why I can't download synapse 3 on my MacBook. Where can download?
     
  11. Canaryfirstdome453

    Canaryfirstdome453 New Member

    my razer nommo speakers wont work help
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >