Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

So many issues -Synapse 2.0 - Doesn't, but might start, or is running in background but not visible

Discussion in 'Razer Synapse' started by kNewBcaveman, Apr 30, 2020.

Thread Status:
Not open for further replies.
  1. kNewBcaveman

    kNewBcaveman New Member

    I just purchased the ORBWEAVER Chroma Keypad. Pretty cool.
    I installed all indicated software, Razer Synapse 2.0 to allow for keypad customization.

    System is Windows 10 (64bit) 32Gig memory AMD3900X MSI RTX 2080 Super. It is not a system resource issue.
    USB 3.2 port.

    1. After install requires Reboot. No problem. Fairly standard with a lot of software.
    Went into Synapse 2. and saw my keypad and created a new Profile and change the coloration of the keys and applied. Went well and as expected. Let's play some more with the functions.

    Tried to change the colors to see what would happen and NOTHING! No change. Nothing happened. It remained as the first color settings.

    2. Created a new profile and tried to edit the colors in that one.
    NOTHING! No change. Colors remained the same from my first edit.

    3. Closed software and tried to restart.
    ----- NOTHING!!!!
    It flashed a sync dialog and what appeared to be a login dialog and then disappeared and then nothing for 5 minutes. I actually waited.
    *****I had to locate the hidden processes for 'Razer Central' and Razer Central Service'. I killed both these and restarted the software.
    This brought back the processes and the software opened immediately.

    4. Tried to change the colors on Profile #1 - No change.
    5. Tried to change the colors on Profile #2 - No change.

    REBOOTED my system.

    6. Started software again and tried to change colors of Profile #1 - No change.
    7. Closed and tried to reopen software and again it went into hidden mode.
    8. Killed processes again and was able to restart but could not change anything.

    9. CHANGED THE USB PORT and restarted the software.
    I was then able to create a new profile and assign color as well as change the previous profile and change its color.

    10. Then it stopped. No color change. No keymap action changes. Nothing,...again.

    11. Did NOT reboot. Did NOT kill the software. Change the USB PORT again and it reconnected and allowed a color change.

    There are some serious issues with this software and its configuration capabilities that need to be investigated. This software is extremely inconsistent at best.

    How can I collect log files from this software to provide for further investigation?
    There appears to be an issue between the Profile selected, the Customize Keymap # selection and the Lighting effect customization.

    I should not have to change the USB port to allow for editing capabilities in the software.
    The software is inconsistent and non-functional at times without user interaction changing its USB connection.
     
    NotTM likes this.
  2. kNewBcaveman

    kNewBcaveman New Member

    Removed all profiles except (1).
    Tried the port change again to the same port. Nothing.
    Tried the port change again to another port - Synapse - Software seemed to hang but eventually came back. No changes accepted.
    Change ports again, software hung but came back. Changes not accepted.

    Seems like this software is not polished and any change can ONLY be done to (1) profile at a time and a REBOOT is required in between changes.

    Unless more precise information can be provided for actual operation steps to manipulate multiple profiles at once in a single software session..............
    THIS IS HORRIBLE SOFTWARE!!!!!!!!!!!
     
    NotTM likes this.
  3. kNewBcaveman

    kNewBcaveman New Member

    Additional testing ------------ sent to Support as well.
    ==========================
    I had to REBOOT and then I was able to apply changes from my last edit!!! SERIOUSLY!?!?!?!?!!

    Then, I created a NEW profile and attempted to assign to Keymap 2. Attempted to custom the color and [Apply] = NOTHING!

    Went back to Profile 1 to see if I could change anything and = NOTHING!!!

    There is some serious issue with this software functionality when it does not recognize any changes due to a keymap or color customization change change, at least from what I can tell.

    I'll REBOOT again to see what happens.

    ----

    YUP!!! Last changes were accepted!!!

    Seriously!!!!!!

    Horrible software!!!! ,....but at least now I know I need to REBOOT every time I want to change something!!!!
    ===========================
     
    DRIFT_IT likes this.
  4. wellsy99

    wellsy99 New Member

    At least you have some form of access. I can not even get into Synapse 2.0. Just sits there active in the background. lost all my binds and Macros. Did you have this issue at all?
     
    baconfusion and Wade2626 like this.
  5. Wade2626

    Wade2626 New Member

    I am also having the same issue.
     
  6. wellsy99

    wellsy99 New Member

    Wow. it is crazy how bad Synapse 2 is.
     
  7. Wade2626

    Wade2626 New Member

    Yeah, I just went and bought a Corsair mouse, gonna see if it's any better.
     
  8. kNewBcaveman

    kNewBcaveman New Member

    @wellsy99
    I hadn't gotten into building it that far. I got fed up with dealing with it and went on to building profiles in my Stream Deck. SSSOOO much easier, but yeah, everything is local, not cloud saved as far as I can tell. I will probably get motivated and see if I can get Synapse 2 to function more properly.
    I'm surprised the software is not better.
    Also, still have not received any response from my support ticket directly to Razor since Apr 30.
     
  9. kNewBcaveman

    kNewBcaveman New Member

    @wellsy99
    I've had the stalled disconnect result a few times also.
    I "fixed" it by opening the Task Manager and locating __ALL__ Razor processes, there are 5 or 6 running in the background, and killing them all.
    Then restart the Razor Synapse 2 app and this will force a reconnect to the cloud server. That might help in that regard. Your config might still be there.
     
  10. baconfusion

    baconfusion New Member

    Having the same issue here. I've just resorted to buying better compatible devices. The money they get and they can't even get an app to work to make their products perform better. I doubt they even care judging by the fact this has been an ongoing issue for over a year.
     
  11. kNewBcaveman

    kNewBcaveman New Member

    Yeah. Sad for sure. The product touts a lot but the software screws it up.
    BTW - Razor made my system unusable this morning. Couldn't do anything once it performed its background login procedure. Had to completely uninstall all Razor software and reboot to gain access to my system again.
     
  12. baconfusion

    baconfusion New Member

    Same here. The app is literally a virus lol
     
  13. kNewBcaveman

    kNewBcaveman New Member

    No doubt.
    Well, I reported this issue also. Let's see if they respond to that request.
     
  14. dailyBluetruck889

    dailyBluetruck889 New Member

    They not reply this class of questions about synapse 2 =( you can try download razer surround old version
     
  15. kNewBcaveman

    kNewBcaveman New Member

    Thanks for the response dailybt.
    Not sure what a 7.1 Surround software has to do with a keypad/gamepad device or how this would be associated to this issue. Not sure it would be worth the effort based on product.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >