Synapse not reconizing devices

Discussion in 'Razer Synapse' started by KageRyu, Feb 2, 2019.

  1. Neozgred

    Neozgred New Member

  2. radioLAPISLAZULI753

    radioLAPISLAZULI753 New Member

    да тока у меня проблема с razer kraken pro 7.1 программа synapse 2.0 перестала видеть ее переустанавливал пару раз все четно
     
  3. off3nc3

    off3nc3 New Member

    I am absolutely disgusted by what's happening , been a razer fan since the diamondback series and this was my week back into the game with some new gear, Blackwidow Chroma Tournament V2 and Naga Trinity ..

    Imagine my surprise the keyboard can be seen and only works on synapse 2.0 while the Naga Trinity ( which i replaced today coming from the Naga 2014 which still works awesome under synapse 2.0 ) cannot be seen at all in synapse 3 or synapse 2 alongside the keyboard. After 20 OS resets and reinstalls and CC cleanups I just gave up.

    Is this what razer has become ? I literally wanted to go tomorrow and refund all my gear but after reading this forum idk what do anymore wait it out or just be done with this company...

    P.S running on Windows 7 , x64 , Ultimate SP1. which truly seems to be culprit.
     
    Last edited: Feb 15, 2019
  4. Toland84

    Toland84 New Member

    is anyone having problems login in to synapse I've created 3 accounts already and no luck, I also uninstalled and reinstalled.
     
  5. FortyOneNY

    FortyOneNY New Member

    I can't log in either. I can log in and change info/password just fine on the RazerID site, but when I try to log into the Synapse software so that I can re-sync my peripherals, it just gives me the stupid 'Oh Snap' error message. :|
     
  6. malichite453

    malichite453 New Member

    Is the DeathAdder Expert able to changed colors, if not does any one have a close date to when it will be added to synapse 3
     
  7. BlackFireDragon

    BlackFireDragon Well-Known Member

    Try to uninstall all razer razer softwere wipe all files that stay and download new installer mayby you have just corrupted file somewhere that prevent you to connect also if this dont help turn off antivirus and firewall and the windows defender too.
    No one knows becose there is no list what devices will be supported by synapse 3 and the only one that knows is synapse developer team.
     
  8. Senthynel

    Senthynel New Member

    WIN10 as well
     
  9. toooldforthis1982

    toooldforthis1982 New Member

    Came here looking for an answer and all I see is the same complaints.
    Razer Blade Stealth 2019
    Core V2
    Nommo Chroma
    DeathAdder
    Kraken Tournament
    BlackWiddow

    All are recognised except for the V2.

    I paid a lot of money for this stuff and I want to be able to use it properly. There are cheaper and better eGPU enclosures out there Razer - fix this please!
     
    phoshizzlettv likes this.
  10. off3nc3

    off3nc3 New Member

    Do what I did , buy and plan ahead according to what people report on the software front , Razer Naga 2014 still rocking it , razer firefly cloth edition and a BlackWidow Chroma TE Yellow Switches V2 they work flawlessly in Synapse 2.0 so im set !

    I ain't upgrading to 3.0 until that abysmal pile of p00p is out of the BETA. GL dudes
     
  11. toooldforthis1982

    toooldforthis1982 New Member

    Where can I find a 2.0 download and is it likely to work with newer devices?
     
    RubyRedleetcast194 likes this.
  12. Senthynel

    Senthynel New Member

     
  13. Kenserky

    Kenserky Well-Known Member

    You can download Synapse 2 here.
    And no, newer devices will only work with Synapse 3.
     
  14. phoshizzlettv

    phoshizzlettv New Member

    Also having troubles here. Support tech suggested I return my Core v2 for a direct replacement, or consider the Core X. I returned for a direct replacement. No dice. Very unfortunate that a $500 piece of hardware doesn't work. This is clearly a software issue as I went through a very lengthy troubleshooting call with RAZER support. I also went through the trouble of 1) rolling windows back to 1803, 2) uninstalling Synapse 3, 3) using the ME firmware updater, 4) updating Wndows back to 1809, 5) jiggering Synapse 3, 6) surviving BSOD crashes at boot, and 7) contemplating bringing the new device out back to shoot it...

    Very displeased with the amount of time/effort I've put into trying to make this relationship work. It's not me, it's you, RAZER...sad sad sad.
     
    Mch122 likes this.
  15. I'm sure that this will work :

    Do all steps bellow without conect the razer device.

    1 - download this file: cdn.razersynapse.com/1533035498f3QE4AcsRazerCynosaV2Setup_v3.3.0802.073117.exe,
    2 - unistall razer synapse, clean all razer files remain,
    3- very important step : download synapse3 installer, run it >>>but first install razer cortex only<<<, don't install synapses yet.
    4- execute file downloaded before,
    5- re-run synapses installer, install synapses,
    6- Once synapses instaled and runing, connect the razer device. thats all.

    For sure this will solve all problems of razer devices detecet
     
    Kenserky likes this.
  16. HzLow

    HzLow New Member

    I am trying to play using my Razer Naga Trinity on my laptop. I use the mouse daily on my desktop and it works perfectly so I know it is not broken hardware. My laptop also recognizes it as a Razer Naga in devices but razer synapse 2.0 does not recognize the device at all.
    I have tried reinstalling and updating the driver.
    I have tried plugging it in in the 3 different USB ports that I have.
    I have tried uninstalling and removing all files related to the driver (including the font files, folders and the registry entries for them along with other shit which I don't know why your installer doesn't handle).
    I have tried making all old devices visible in the device manager and delete all of them before reinstalling the software again.
    I have tried deactivating my anti-virus while installing and plugging in the mouse.
    I re-downloaded the install file and restarted the computer in between each of these tries.

    I am on windows 10. There may be a couple more things that I have tried but the bottom line is that I have done way more than is reasonable to have to do and it is not working. I love your hardware but I wish your software wasn't such a hot steaming mess from the way it looks to leaving files allover the place on uninstall. I hope you have an idea for how to solve this issue that I haven't thought of yet because right now my $100 mouse is basically a Microsoft pointer with fancy colors.
     
  17. BlackFireDragon

    BlackFireDragon Well-Known Member

    If you want to use synapse 2 with naga trinity it will not work becose synapse 2 dont support this mouse at all. All new devices with few exepction on headset support synapse 3 only.
     
    Kenserky likes this.
  18. LaughingJr07

    LaughingJr07 New Member

    Anyone tried these steps already?
     
  19. icymight

    icymight New Member

    i didn’t find out how to get back all my devices into synapse 2 but now at least i got back synapse 3

    I tried to uninstall it with CCleaner, than i chose the top button in uninstallation manager, something like “fix all problems”
    and now it works after few loadings ;)


    i hope all your devices are working now and all i can say i won’t download any new razed drivers (fck it)
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >