Synapse not reconizing devices

Discussion in 'Razer Synapse' started by KageRyu, Feb 2, 2019.

  1. Baconalick

    Baconalick New Member

    go into your install/uninstall setting. Delete razer synapse both 3.0 and 2.0 if you have both installed. Then scroll down and there should be something called a razer driver package. Uninstall that as well. Then restart your pc and download the latest razer synapse version.
     
  2. Blue_Razor_

    Blue_Razor_ New Member

    I did, it works on my laptop, but not on my desktop
     
  3. Blue_Razor_

    Blue_Razor_ New Member

    It never will install the "Control Device" driver, it always installs the keyboard/mouse drivers but that driver never works, I have absolutely no idea why. Should i try and delete my temp under appdata?
     
  4. Blue_Razor_

    Blue_Razor_ New Member

    I tried that, but there was no driver package.
     
  5. Dr_Axton

    Dr_Axton Member

    had the same issue, turned out to be synapse hating anything plugged into a usb hub. Maybe that's an issue
     
  6. Blue_Razor_

    Blue_Razor_ New Member

    What do you mean a USB hub? I have moved the cables to the front of my computer to no avail, i just pretty much uninstalled everything for good, I'm so sick of everything Razer constantly breaking after every update.
     
  7. BlackFireDragon

    BlackFireDragon Well-Known Member

    he say external usb extension device :stuck_out_tongue_winking_eye: In this case try to remove everything uninstall all razer softwere then delete razer folders in the appdata and programfiles next go to windows device menager and remove your devices after removing unplug them from usb when you finish reboot pc. When windows boot go to razer website download new installler and install it. This give you clean softwere install without saving files you have previous.
     
  8. Blue_Razor_

    Blue_Razor_ New Member

    i give up, im not doing any razer bs again, i already tried doing that without taking them out but no way that would really help because it would just use placeholder drivers until you restarted
     
  9. war3069mission

    war3069mission New Member

    i just spent all day and i got TartarusV2 to work, finally.

    i run win7 64.
    i had exact same issue. Razer Control Device Driver failed install. you have to be looking at hidden devices in device manager to even see that this didnt install correctly.

    first go to windows update and make sure you have any with Razor in the heading. I didnt have this one.
    -Razer Inc - HIDClass - 1/1/2017 12:00:00 AM - 6.2.9200.16448-

    this one got things to show up in my device manager.

    second go to windows update again and get this specific update.
    https://www.microsoft.com/en-us/download/confirmation.aspx?id=46148

    The windows error (code 52) is what lead me to this. its some bullshit about SHA1 and SHA2 certificate crap for windows whlq certified driver crap. win7 wont take sha2 or a mix of the two or something like that.

    hope this helps.
     
  10. war3069mission

    war3069mission New Member

    i just spent all day and i got TartarusV2 to work, finally.

    i run win7 64.
    i had exact same issue. Razer Control Device Driver failed install. you have to be looking at hidden devices in device manager to even see that this didnt install correctly.

    first go to windows update and make sure you have any with Razor in the heading. I didnt have this one.
    -Razer Inc - HIDClass - 1/1/2017 12:00:00 AM - 6.2.9200.16448-

    this one got things to show up in my device manager.

    second go to windows update again and get this specific update.
    https://www.microsoft.com/en-us/download/confirmation.aspx?id=46148

    The windows error (code 52) is what lead me to this. its some bullshit about SHA1 and SHA2 certificate crap for windows whlq certified driver crap. win7 wont take sha2 or a mix of the two or something like that.

    hope this helps.
     
    vbenkovskyy likes this.
  11. MossBf1942

    MossBf1942 New Member

    Happened to me..
    i was contacted by support and told to check PC for updates.
    check additional updates and you might find a razer driver update or something.
    worked for me anyway
     
    war3069mission likes this.
  12. vbenkovskyy

    vbenkovskyy New Member

    THANK YOU!!! It WORKS! Win7, Trinity and Tartarus V2
     
    war3069mission likes this.
  13. sharpconnect287

    sharpconnect287 New Member

    A bit late to the party here...I just bought a Razer Tartarus today and Synapse listed it as being disconnected. So I did exactly the same thing; disconnected it from my USB HUB and connected it to it's own USB 2.0 port. It was immediately recognized as being connected by Synapse and can now be customized flawlessly. Win7 64 also recognized it properly after reconnecting too, because while it was showing up as a working device under Devices & Printers initially, it wasn't being recognized as a game controller.

    Something I've learned in the past year, is that there's a problem with the some of the early gen Etron USB chipsets with supporting USB 2.0 devices connected via a USB 3.0 HUB. Razer devices aren't alone with that - a lot of TrackIR users have reported not being able to connect that device to such a HUB configuration either. I know if I try connecting my Logitech mouse or keyboard to my HUB, my PC has fits.
     
    war3069mission likes this.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >