Synapse won't open

Discussion in 'Razer Synapse' started by saboo.tage, Jul 28, 2018.

Tags:
  1. saboo.tage

    saboo.tage New Member

    Hi everyone, I recently got a new computer and a Blackwidow Chroma v2, but whenever I want to open synapse to configure lighting, I click the application and nothing happens. The only thing that seems to fix it is an uninstall and reinstall, and the problem returns every time i turn my PC on. The Razer Central application is running, mind you, but when I try to open Synapse therefrom, it doesn't work either. Any experience shared would be appreciated. Thanks in advance.
     
  2. ansmann

    ansmann New Member

    I have the same issue after like 30 reinstalls even Reinstalling stoped working. This Reinstalation just Corrupted My Windows Profile Too many times to Even Bother with Synapse 3 ... and Razer is Doing NOTHING with fixing.
     
  3. Razer.FirePenguin

    Razer.FirePenguin Keeper of the Flames, Bane of Sardines Staff Member

    Hi! I sent both of you a PM. Hit me with a reply if you are still having issues.
     
    pancholr and freakydoctor like this.
  4. ansmann

    ansmann New Member

    I Sent you my respond.
     
    pancholr likes this.
  5. why do you even handle it with PM's !??!?!?!?! post it openly, what kind of support is that?
    If there is a solution make it than everyone can see it, because MANY people have that issue and while searching for a solution I found out that this issue has been bothering people FOR MONTHS without any fixes, how incompetent can you be? if it doesn't get fixed right away I will bring my new mouse back to the store and NEVER buy ANY razer product again and I'm a longtime customer spending about 1k€ and also recommending products to others who also bought them, if it's not fixed I will do the opposite and warn them instead
     
    ahhaolee, pancholr, csills89 and 2 others like this.
  6. ansmann

    ansmann New Member

    Same Here ... They Didnt have a solution For me ... He Just wanted my Log Files so they can chceck it ... He (and Mostly ME) Don´t want my LogFiles all over internet. Have You tried Uninstall Synapse and Then Download it From Website and run the newest version ? because Updates from app Have always trolled me
     
  7. Yeah, I have tried everything, deinstalled and installed Synapse 3 about 7 times, also reinstalled Synapse 2.
    I even tried the method where you have to delete some stuff in the device manager, open up framework while installing and stuff....nothing works.
    Synapse 2 doesn't detect the Naga Trinity and Synapse 3 stops working after every restart.
     
    ahhaolee likes this.
  8. Norreca

    Norreca New Member

    we write on forum here for weeks same problems and as I see they do nothing.
    this is a bit embarrassing.
     
  9. Jaycee03

    Jaycee03 New Member

    hi sir i have the same issues in my blackwidow tournament edition. when i run RzSynapse application "Razer Synapse has stop working". help me please
     
  10. I had the same problem, and I think I have a solution.

    To start, my problem seems to be that when I close Synapse 3.0 and then try to re-open it using Razer Central, it will not open.

    To resolve this, I go through the Windows Task Manager and remove any process that has "razer" in the name. After stopping all of these processes Razer Synapse will finally open.

    To Razer: It looks like Synapse 3.0 may not be handling child processes correctly. When Synapse 3.0 closes, these child processes are not closing correctly. This is blocking the Synapse 3.0 process from being created, or blocking Synapse 3.0 GUI from displaying when the process is started.
     
  11. I think you hit the nail on the head there, Going through the processes and ending the razer ones solved to problem. at least on this start-up day. Oddly when I started shutting it down manually it kept restarting for a while. I had tried to start it several times.


     
  12. dustin16443

    dustin16443 New Member

    i have same poroblem
     
  13. ansmann

    ansmann New Member

    Have you tried Updating Synapse to the newest version?
     
  14. PookyChun

    PookyChun New Member

    My problem happened 'AFTER' i updated the other day. Now no devices show up in Synapse[​IMG]
     
  15. csills89

    csills89 New Member

    I have the similar issue but my razer synapse 2 won't open at all or if it does I get a error message like this;

    https://imgur.com/a/PEVrbDa[​IMG]
     
  16. MikeBloem

    MikeBloem New Member

    Also had an issue... Went to Device Manager... Human interface Devices...Right click on Razer...Elite _ Update Driver .. Had to Update 2 of my drivers .. Restarted PC ... Working for now.
     
  17. ahhaolee

    ahhaolee New Member

    i have the issue too

    synapse cant open
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >