Windows driver foundation 100% cpu usage when using razer synapse 2.0

Discussion in 'Razer Synapse' started by rozemrowkiwibratordodupk, Dec 22, 2018.

  1. Arcite520

    Arcite520 Member

    New update. Not the best either :\ ... Without the "drivers" the sound cuts off from time to time.. forcing me to plug/unplug my headset, 2-3 times per day.. Swell.... Not to mention the fact that i have literally no control on the headset's settings .. Right.

    It's 29 of January Razer. I get that most of you guys work on the new Synapse 3.0... And that your marketing department says "No no no" when ye'r trying to add older Razer products into 3.0 [Electra V2 ain't old, just cheap] But at least give us an ETA on this... Or is there any?

    Clearly, as you can see above, there's a BIG problem with Win10 1809 and Razer Electra V2 (dunno about other Razer USB headsets but i fear the worst).

    Is it so mind-boggling for you guys to fix a simple driver bug? Or you just literally don't give a :heart: .... :)

    Really... we even pay for this crap... Real dolla $$$ ..
     
    xInSaNeKiLLs likes this.
  2. xInSaNeKiLLs

    xInSaNeKiLLs New Member

    Hi man,

    I have the exact same headset and the exact same problems. It has something to do with the windows update and the electra v2 atleast. Probably also other headsets. I think razer just doesn't give a shit. I actually got one response on reddit. Even though I said I'm not a retard and I have reinstalled the drivers multiple times(clean). They just said. Try uninstalling the driver and than clean installing it again. So they probably don't even read the messages or anything.

    Funny thing is I have only used the headset for like 1-2 weeks normally. Then it got fked. Seems I'm never gonna buy razer again and also my little brother. We have had multiple razer kraken headsets and mouses. And my brother also has a really good keyboard now from razer. But with this support we are done. Not fixing it directly isn't a problem but not telling us anything is a problem. Bye-Bye razer!
     
    Arcite520 likes this.
  3. npapanik

    npapanik New Member

    I have an open(?) case since the 13th of December. Ten days ago I have sent them a (polite) update reminder, still waiting for an answer. I can't believe that Razer cannot fix this... I have a Razer keyboard, mouse and of course the Electra V2. Really disappointing.
     
    Rikardo13 and Arcite520 like this.
  4. EmperYalist

    EmperYalist New Member

    Synapse 2.0 update please.
     
    Rikardo13 and Arcite520 like this.
  5. Shadowdragon352

    Shadowdragon352 New Member

    I have had the same problem for ages and still isn't fixed it is getting really annoying!
    This should have been fixed ages ago!
    Razer PLEASE FIX THIS!
     
    Rikardo13 likes this.
  6. eiad999

    eiad999 New Member

    Same problem here.
     
  7. oO_AndreA_Oo

    oO_AndreA_Oo New Member

    Hello guys! Same for me...any idea on what to do?
     
  8. oO_AndreA_Oo

    oO_AndreA_Oo New Member

    TEMPONARY FIX:

    Take the administrator of "WUDFHost.exe" and rename it WUDFHost.exe.old
     
    Arcite520 likes this.
  9. Arcite520

    Arcite520 Member

    Right - and thus we screwed up ALL of our system drivers updates.... just to make this puny headset to work'ish ..... Not that i do not appreciate the feedback from the community .. and the "bad ass" fixes we find to fix YOUR crap problems Razer .... But going this far.. Literally screwing up our OS's just for a cheap headset... This is just plain stupid... and a CLEAR statement from your company... Making fun of us all and our money.

    This is 06.02.2019 Razer. No response.. no fix yet. Thank you for the last Synapse 3.0 update that nobody asked for tho...

    Meanwhile i found some delightful reviews on some Logitech headsets... THAT WORK properly also.

    Just take a hint. Really ...
     
    Last edited: Feb 5, 2019
  10. eiad999

    eiad999 New Member

    I have contacted Razer support and they have confirmed that a driver compatibility update is being worked on. It should take some more time before the update is released.
     
  11. Arcite520

    Arcite520 Member

    Thank you eiad999 for your post here. Hope it will get fixed soon... this year at least.. So tired of unplugging and plugging my headset every 2 hours or so. Would be lovely ....

    You are working on it .. right Razer? :S
     
  12. Urqon

    Urqon New Member

    bump, seems like theres a prob with electra v2, since i have the same prob with them
     
  13. Daexxter89

    Daexxter89 New Member

    Hi guys. I have had the exact same issue and it was driving me crazy! Here is a workaround for the problem until Razer finally fixes it:

    1) Plug in your Razer Electra v2 USB. It will show up correctly in Razer Synapse 2.
    2) Go to Device Manager
    2) Go to Human Interface Devices
    3) There are going to be several USB Input Devices. Find out which one is the Electra v2 Headset. I unplugged and replugged the headset and checked the serial under "Properties"
    4) Rightclick and disable the Electra V2 USB Input Device.
    5) Reboot

    Important: Don't disable the Razer Headset under any other category in Device Manager.

    After this the headset will still be functional and shows up correctly under Sound Devices. However, it will not be displayed in the Synapse 2 software.

    I hope this helps you!
     
  14. Arcite520

    Arcite520 Member

    Hi again Razer! how's it hangin?? .... Good, good, glad to hear. How about our fix !? >.<
     
  15. Csizi

    Csizi New Member

    Without the Razer Synapse this headset is a piece of ... the mic is terrible if I can't reach the synapse settings :/ and also we lose the virtual 7.1 and this was the main reason why I selected this headset
     
  16. thedrunkmachine

    thedrunkmachine New Member

    Razer, Fix this!
     
  17. thedrunkmachine

    thedrunkmachine New Member

    Unplug your Electra V2 USB;
    Install IOBit Unlocker;
    Rename "WUDFHost.exe" to "WUDFHost.exe.OLD"
    Restart the PC;
    Reconect our Electra V2 USB
    Done.
    Works for me.
     
  18. Arcite520

    Arcite520 Member

    Sooo.. anyone can confirm this is fixed? I admit... not gonna destroy my RIG again, just for this. Did razer fixed it? Please tell.. kind people :)
     
  19. npapanik

    npapanik New Member

    My case has been escalated... Logs, screenshots etc. sent. Will post when I get some feedback.
     
    vzbrst and Kenserky like this.
  20. OzCavalier

    OzCavalier New Member

    Add me to the list.... Wondered why I was getting abnormally high CPU load via Synapse and also Windows Driver Foundation after the last Razer update... Removed my Electra v2 as per Daexxter89's post above and, voila!! No more CPU issues!!

    Hopefully there's a decent fix from Razer shortly, so the community doesn't have to continue to rely on bodgy 'quickfix' solutions...
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >