Battery Lasts few days with Basilisk X Hyperspeed Mouse | Razer Insider

Battery Lasts few days with Basilisk X Hyperspeed Mouse

  • 14 February 2023
  • 28 replies
  • 3182 views

Userlevel 2
I've had a Basilisk X Hyperspeed for 15 months now. In the last 2 weeks or so, it feels like it is draining the battery super fast or at least the hardware thinks it is. I just put in a new Duracell AA a week ago, as the low battery message was appearing and 5 days later I got the same message. I put in another fresh battery yesterday and today the low battery message appeared again. I've tried the Razer support guidance about checking the firmware is up to date and that Windows (11 in my case) is up to date and they were already up to date. I usually connect using 2.4ghz wireless rather than bluetooth but when following the support procedure for checking firmware it said to connect via BT. When I did I noticed the PC telling me battery was at 13% despite only being put in the previous day.

Anyone else experienced similar recently and have a resolution. Previously the battery had lasted months.

28 Replies

Userlevel 7
Hi RoseRedbitAPATITE642,


Thanks for sharing your concern here. Can you PM me the case number so I can check its progress and raise and coordinate with the relevant team to know our options?
Userlevel 7

Hope an answer is out there

Userlevel 2

@Razer.Zionzedd  Sorry for the slow reply, couldn’t post due to the forum maintenance. The link to PM you didn’t work, but wanted to let you know that there wasn’t a case number and I was instructed to post on the forums. Since I made the original post the mouse has completed drained the new battery I put it. 

This is exactly the same problem I have with mine, glad I’m not the only one.

It's been working okay for years, and since last month or two I need constantly change batteries, also sometimes it doesn't wake up from stand-by and the only way to make it working is to remove the battery for a couple of seconds and then insert again.

I’m not so sure, but it looks like it happened after a major windows update, maybe after w10 22h2. I tried everything, also on w11 but with no success.

BTW I'm on the latest firmware v1.02.00_r2

I’ve had the mouse for about 4 months and have been experiencing the exact same issue. I have changed the batteries 4-5 times for that period which is insane.

I think it lasts a bit longer on Bluetooth but still, changed it a week ago and battery is now at 60%. I only use the mouse for work so about 8 hours a day - must have used it 50 hours tops after the last battery change.

Does anyone on here have a fix - should we perhaps try to rollback to an older firmware version? If this can’t be resolved I will be forced to try and return it as deffective - never had a mouse which needed so many battery changes 

same problem. I have this mouse for about 15/mo., the first 6 months I changed the battery 2 times and after that it got where I am in the present, changing the battery every week, I've tried every brand of batteries and with all is the same, I would not recommend anyone to buy this mouse just because of this really anoying problem.

Alright, so, today I am putting in a fancy expensive spanking new battery in and I will be posting updates weekly on the battery percentage and the hours used. I have set up the Power saving slider at 5 minutes and the DPI is set to 1800

 

Hello i got same problem. i using rechargable batteries. i know  batteries full but some times mouse light blink when i change battery then it faint slowly like short circuit. after several time try when i plug battery oh its okay working and battery shown full! How we solve this?

I would really recommend getting the batteries I mentioned above - Duracell Optimum. If you can find them, they are a bit more expensive but I have used the mouse for around 50 hours actively and it is still at 100%. Before with cheaper batteries it would have been at 30-40%. I wonder if they maybe did a quiet firmware update which also contributed to the result 

I’ve got this exact problem, my mouse has been working perfectly for months. I got the red flashing light so replaced the battery like normal, that battery “drained” in less than 5mins. Thought it must be a faulty battery so swapped it out for a new one and same thing happened. I’m currently having to cycle through the same batteries to use my mouse.  
No warning before his happened, perfect connectivity to the pc, no lagging or problems coming out of dormant mode just stopped allowing the battery to power it? 

Same issue here. The mouse worked flawless for months and for the last month or two I’ve had to put a new battery in once or twice a week. I thought maybe I got a bad pack of Duracell’s from Costco. Now I’m guessing it’s the mouse.

Yet again I have the exact same problem as everyone else. I hope this is was not intentional as I am a razer die hard because I cannot deal with this kind of malfunction. 😡

Same problem!!! I use Energizer Ultimate Lithium batteries and they last less than a month!!

 

WTH Razer!?

I just ended up selling mine... The lack of feedback related to the issue regardless of the price and the profile of the company was pretty annoying. Good thing that I bought mine on a black Friday deal and managed to sell it for the same price I bought it for.

Given the fact that I was using it as a productivity mouse, I find that the Logitech MX master 3 is centuries ahead in terms of features, comfort and battery life (even though rechargable)

@techlinkVividCerise535 Yeah it’s super frustrating, I bought mine for work also for the selectable definitions while using CAD and Fusion. Nothing like your mouse going dead mid-design…

I go through so many batteries that accounting made me write an explanation letter to our grant auditors. 

Has anyone had any luck solving this?  I’m having the same difficulty. I bought this mouse before heading overseas to a relatively remote place. The first year was fine, changed the battery once, since then I’m lucky to get a week, sometimes less than a day. I don’t have access to the highest quality batteries, but even when I get my hands on them, the problem remains…

Is Razer doing anything about this? 

I changed the batteries like 3 times in the first 8 or so months I had this mouse. For well over a year though, it has been completely sporadic, sometimes lasting a week, sometimes a new battery won’t fix the problem, but nearly every time I can get more use out of the mouse by quickly popping the battery out and back in. It’s extremely annoying though, and I probably (definitely) should’ve gotten a new mouse at this point.

I have the same issue as well. I have it for 2 years and as soon as the warranty went off, this issue happened. I pop off the battery just to “reset” it, turning the mouse on and off, but the only solution, which is not a solution at all, is to put another new battery, that will help for a day or two. I always turn off my mouse when I don’t use it. 
I believe that Razor must withdraw this product from the market, since it is generating a tremendous amount of hazardous waste from all those batteries, and is making the users buy more and more batteries just to keep their mouse running. They should refund all users of this product!

I highly suggest Razer do something about this because I will never buy another product from them again if it persists 

Was this solved, and if so, how? Having the exact same problem. I make do by re-inserting the battery a couple of tjmes. Every now and then, it picks up again and I can work with it the entire session (as long as I don’t let the laptop   go to sleep).

I have had basilisk hyperspeed x for several months now. I had so many issues with bluetooth connectivity and to add to it now, the batter is getting drained fast. 3 batter in the last month. What do I do?

This is like the worst mouse I’ve ever had, from now on I’ll stay away from Razer products. The lack of interest and support from razer are unacceptable:/

I've had a Basilisk X Hyperspeed for 15 months now. In the last 2 weeks or so, it feels like it is draining the battery super fast or at least the hardware thinks it is. I just put in a new Duracell AA a week ago, as the low battery message was appearing and 5 days later I got the same message. I put in another fresh battery yesterday and today the low battery message appeared again. I've tried the Razer support guidance about checking the firmware is up to date and that Windows (11 in my case) is up to date and they were already up to date. I usually connect using 2.4ghz wireless rather than bluetooth but when following the support procedure for checking firmware it said to connect via BT. When I did I noticed the PC telling me battery was at 13% despite only being put in the previous day.

Anyone else experienced similar recently and have a resolution. Previously the battery had lasted months.

Same issue with my mouse. I keep on cycling the rechargeable cells and it almost always show less than 10-20% even if it is fully charged. I bought four different brands of rechargeable batteries but exactly same results. I use it for work so I have to keep a spare cell in my bag all the time. First time I spent that much money on a “branded” mouse and got this, lolz. I guess its better to buy a 20$ mouse, since just the price is premium not the product. By the way, now I am having the scroll wheel jumping issue with this mouse. Time to look for another one (definitely not a Razer one).

Same with mine! What a piece of garbage! I noticed the problem is that when my laptop is in idle state, the mouse still keeps blinking. Leading me to believe that it’s still draining the battery from the mouse!

 

We want a RECALL AND A REPLACEMENT RAZER!

exact same problem. Anyone found a solution?

Reply