Huntsman Mini Slowing down system start after firmware update | Razer Insider

Huntsman Mini Slowing down system start after firmware update

  • 21 December 2020
  • 68 replies
  • 311 views

I was very happy with my Razer Huntsman mini up untill the moment I noticed that it had sticky keys problem. Tried updating the firmware through Razer's own special tool (they do recommend using the latest firmware)... aaand the whole SYSTEM now starts WAY slower than it should. The problem is a 100% firmware update, as it's never occured before and the system starts perfectly IF I disconnect the KB.
It is impossible to go back to the previous firmware (what?...) and the sticky keys issue persists on top of that. The KB was sent to me as a gift from a friend, who lives in a different country. RMA won't work. I'm stuck with a pretty much broken product.

This topic has been closed for comments

68 Replies

I have similar problem.
My Huntsman mini stuck (no RGB) after Synapse 3 update.
And I updated firmware to v1.01.00_r1.
I realize after update that RGB brightness was automatically set to 0 % after Synapse 3 update.
It was little silly not to diagnose first problem immediately. (Always try all keyboard controls)
And keyboard work perfectly, but on Windows 10 Pro startup logon process takes up ten times longer.
When I finally get Windows to desktop, taskbar freezes and after two clicks to taskbar exploler.exe restarts and system works fine.
First, I trayed re-install Windows two times and problem appears every time, after first restart/shutdown.
When I try connect another keyboard everything works fine.
It’s no problem with Synapse 3 because I first try without it.
Firmware_v1.01.00_r1 sucks.
Razer should give us old firmware or make fix.
StormStrykerX
I have similar problem.
My Huntsman mini stuck (no RGB) after Synapse 3 update.
And I updated firmware to v1.01.00_r1.
I realize after update that RGB brightness was automatically set to 0 % after Synapse 3 update.
It was little silly not to diagnose first problem immediately. (Always try all keyboard controls)
And keyboard work perfectly, but on Windows 10 Pro startup logon process takes up ten times longer.
When I finally get Windows to desktop, taskbar freezes and after two clicks to taskbar exploler.exe restarts and system works fine.
First, I trayed re-install Windows two times and problem appears every time, after first restart/shutdown.
When I try connect another keyboard everything works fine.
It’s no problem with Synapse 3 because I first try without it.
Firmware_v1.01.00_r1 sucks.
Razer should give us old firmware or make fix.


Very sorry to hear you have the same problem 😞
And you did a much better job at explaining the issue - this is EXACTLY the way my system behaves now.
I really hope this catches Razer guys’ attention and we can have a fix
I only have power consuming fix. (Standby is not power efficient)

Put Windows to sleep mode and when wakes up everything works perfectly.

(Logoff and Logon also works with no problem.)


Diagnosing problem:

I’ve tried keyboard on my VMware Player on virtual version of my Windows 10 (2H20) clean install and with randomly software with and without Synapse 3.

Everything works fine.


If plug in keyboard when Windows is running taskbar freezes.

If you want to shutdown in this situation press Windows key+ X and in options chose shutdown or restart.

Apparently, the issue with keyboard appears only when gets first power up (booting and plug in).
I have a huntsman mini with exactly the same problem. I've been using a blackwidow and deathadder together with no problems, apart from the sketchy synapse3 software. With the huntsman mini connected it takes my win10 gaming PC 10-15 mins to progress past the start menu. I chose this keyboard over the ducky one 2 mini because i've bought into the eco system quite heavily. It's starting to wear very thin with me now, the hardware is OK, but the firmware/software is the least robust i've ever used. Come on, get it sorted, it isn't good enough for expensive kit.
same issues exactly after the firmware update
MrKittyCat101
same issues exactly after the firmware update

Sorry to hear that =(
I really hope Razer will fix it, or let us go back to the previous firmware, AT LEAST
I'm having the same exact issue after doing the update yesterday. On the phone with their support center now to see if they can help roll the firmware back. I only had the keyboard for 2 days, this is terrible if they have known about this issue since last month.
heavenradioOrchid229
I'm having the same exact issue after doing the update yesterday. On the phone with their support center now to see if they can help roll the firmware back. I only had the keyboard for 2 days, this is terrible if they have known about this issue since last month.


Wow, quite a few people are dealing with this :frown_:
Keep us posted about your progress with support, if you have time :wink_:
No worries I will definitley update this thread. I've officially contacted support and now have a ticket number. I have also recorded a video expressing my dis-satisfaction with this keyboard since the update and will uploading it to Youtube later today. So hopefully they address this, the one thing I will say is that the support rep I spoke to didn't know about the issue, but when he esclated his senior engineers seemed to be aware of it. I asked him then why do they keep pushing the software, no answer. Anyway, gotta get some sleep.
heavenradioOrchid229
No worries I will definitley update this thread. I've officially contacted support and now have a ticket number. I have also recorded a video expressing my dis-satisfaction with this keyboard since the update and will uploading it to Youtube later today. So hopefully they address this, the one thing I will say is that the support rep I spoke to didn't know about the issue, but when he esclated his senior engineers seemed to be aware of it. I asked him then why do they keep pushing the software, no answer. Anyway, gotta get some sleep.


I too contacted support before posting here and on Reddit. They should be aware of the issue by now and it's good to hear that the senior engineers seem to know about it
OK just a quick update, I did receive an email from Razer support yesterday. Unfortunaley the agent who logged the initial ticket made some error and this added some delay. Somehow he reported that I was using the keboard on my Macbook and not my windows 10 PC and they 2nd level came back stating there was not firmware update for Mac's. This was of course correct, so I corrected the information and provided all my troubleshooting steps in email and they have replied back to me today.
They stated they agree that this does look like a firmware issue and they are working with the developers to look into it. Additionally they have provided me a firmware to try and see if it resolves my issue. I won't share that here becasue if it's a beta piece of code and cases more issues, publicly posting would be irresponsible of me. if it does work I will come back and state that and suggest anyone having the problem contact support and request it from them. this way it stays controlled and not cause more issues potentially. Fingers crossed this works, I am really liking this keyboard.
Ok that was pointless, all their application did was tell me I already had the latest firmware. Extremely disappointed with the support so far!!
heavenradioOrchid229
Ok that was pointless, all their application did was tell me I already had the latest firmware. Extremely disappointed with the support so far!!


Ah, that is very unfortunate! Thanks for keeping us posted
So I received another email from them today asking me to download and try another software. Unfortunalely when I click the link they sent me, it was the instructions to download and use the software they instructed me to download the use 2 days ago.

This has to be the most pointless set of troubleshooting and resolution steps I have ever been asked to follow. What makes it worse is both emails came from the same person on the support team.

email 1


Download link from PDF today -
I don't think anyone at Razer is gonna do anything about this any time soon unless there is mass complaints. They had me run through a ton of troubleshooting steps but I told them to escalate it over an email. If they don't or won't sort this out sometime soon, im gonna be on my way to another keyboard, and will be switching out the rest of my peripherals too.
Same issue here, I reinstalled my windows three times until I found whats wrong. I sent a ticket to them too. From what I can see this issue is around for a long time now, look: /huntsman-mini-broke-my-windows.65606/
First post nov 11, Im just shocked there is no solution yet.
oh my... https://forums.tomshardware.com/threads/mouse-dysfunctional-unresponsive-icons-windows-and-task-bar.14375/
Same issue, thread from 2012!!! I think until some big youtuber make a video about this, we are not getting a fix 🙂
well I'm not big, but im on Youtube, at least my gaming channel isn't big, but i'm posting a vid now about this lackluster support that we pay good money for. Glad my Anne Pro 2 is on it's way. Probably my first and last Razer product
Yeah I think Im gonna get anne too, post a link to your vid when its up Please 🙂
Here you go forward anywhere you feel it might get some traction
Video Part 1 I posted 3 days ago -


Part 2 - posted today with my problems with the support team -
It's unbelieveable that Razer is just flat out ignoring this!..
Hello. I have this same issue out of the box. Do you guys think I should contact them or just straight up ask for a refund. Do you think they're actually doing something on this fix or new firmware cause I dont wanna get rid of it knowing that it might get fixed anytime soon. Thank you...
Contact them first, if more people will report this issue maybe it will be fixed soon.
I just spoke to razer support on the phone and they were very unhelpful. Their advice was that I needed to contact AMD and make it their problem... So I need to contact AMD and tell them that they need to fix their architecture so that defective razer firmware will work on the system.

Returning the keyboard and mouse.
MkyAs
I just spoke to razer support on the phone and they were very unhelpful. Their advice was that I needed to contact AMD and make it their problem... So I need to contact AMD and tell them that they need to fix their architecture so that defective razer firmware will work on the system.

Returning the keyboard and mouse.


Wow... very "professional" of them