Huntsman Mini Slowing down system start after firmware update | Razer Insider

Huntsman Mini Slowing down system start after firmware update

  • 21 December 2020
  • 68 replies
  • 29 views

I was very happy with my Razer Huntsman mini up untill the moment I noticed that it had sticky keys problem. Tried updating the firmware through Razer's own special tool (they do recommend using the latest firmware)... aaand the whole SYSTEM now starts WAY slower than it should. The problem is a 100% firmware update, as it's never occured before and the system starts perfectly IF I disconnect the KB.
It is impossible to go back to the previous firmware (what?...) and the sticky keys issue persists on top of that. The KB was sent to me as a gift from a friend, who lives in a different country. RMA won't work. I'm stuck with a pretty much broken product.

This topic has been closed for comments

68 Replies

So i've just received and update from support that they have "Prioritized" this issue for replication and that I need to keep checking Synapse for an update but there is no ETA

I have similar problem.
My Huntsman mini stuck (no RGB) after Synapse 3 update.
And I updated firmware to v1.01.00_r1.
I realize after update that RGB brightness was automatically set to 0 % after Synapse 3 update.
It was little silly not to diagnose first problem immediately. (Always try all keyboard controls)
And keyboard work perfectly, but on Windows 10 Pro startup logon process takes up ten times longer.
When I finally get Windows to desktop, taskbar freezes and after two clicks to taskbar exploler.exe restarts and system works fine.
First, I trayed re-install Windows two times and problem appears every time, after first restart/shutdown.
When I try connect another keyboard everything works fine.
It’s no problem with Synapse 3 because I first try without it.
Firmware_v1.01.00_r1 sucks.
Razer should give us old firmware or make fix.
StormStrykerX
I have similar problem.
My Huntsman mini stuck (no RGB) after Synapse 3 update.
And I updated firmware to v1.01.00_r1.
I realize after update that RGB brightness was automatically set to 0 % after Synapse 3 update.
It was little silly not to diagnose first problem immediately. (Always try all keyboard controls)
And keyboard work perfectly, but on Windows 10 Pro startup logon process takes up ten times longer.
When I finally get Windows to desktop, taskbar freezes and after two clicks to taskbar exploler.exe restarts and system works fine.
First, I trayed re-install Windows two times and problem appears every time, after first restart/shutdown.
When I try connect another keyboard everything works fine.
It’s no problem with Synapse 3 because I first try without it.
Firmware_v1.01.00_r1 sucks.
Razer should give us old firmware or make fix.


Very sorry to hear you have the same problem 😞
And you did a much better job at explaining the issue - this is EXACTLY the way my system behaves now.
I really hope this catches Razer guys’ attention and we can have a fix
I would like to add I have the exact same issue, very slow boot and unresponsive on start. I love this keyboard, and will be very sad to switch but it seems I will have to if this isn’t fixed. Glad to see I’m not crazy and my 2 month old PC isn’t broken already. I did try my keyboard on an intel PC and did not have the issue. Please razer fix this so I can keep using this keyboard!
hi i was talking to razer support about this issue and i send all i had in mi hand for the issue to be resolve cause in my country there is many people with the issue. i heard from them that fix will come with update so we need to be patient with this one and keep looking every day for the update. i know issue will be fix soon.
they are working on it!
I only have power consuming fix. (Standby is not power efficient)

Put Windows to sleep mode and when wakes up everything works perfectly.

(Logoff and Logon also works with no problem.)


Diagnosing problem:

I’ve tried keyboard on my VMware Player on virtual version of my Windows 10 (2H20) clean install and with randomly software with and without Synapse 3.

Everything works fine.


If plug in keyboard when Windows is running taskbar freezes.

If you want to shutdown in this situation press Windows key+ X and in options chose shutdown or restart.

Apparently, the issue with keyboard appears only when gets first power up (booting and plug in).
MrKittyCat101
same issues exactly after the firmware update

Sorry to hear that =(
I really hope Razer will fix it, or let us go back to the previous firmware, AT LEAST
No worries I will definitley update this thread. I've officially contacted support and now have a ticket number. I have also recorded a video expressing my dis-satisfaction with this keyboard since the update and will uploading it to Youtube later today. So hopefully they address this, the one thing I will say is that the support rep I spoke to didn't know about the issue, but when he esclated his senior engineers seemed to be aware of it. I asked him then why do they keep pushing the software, no answer. Anyway, gotta get some sleep.
Ok that was pointless, all their application did was tell me I already had the latest firmware. Extremely disappointed with the support so far!!
Here you go forward anywhere you feel it might get some traction
Video Part 1 I posted 3 days ago -


Part 2 - posted today with my problems with the support team -
Contact them first, if more people will report this issue maybe it will be fixed soon.
Thats what they replayed me, so they are aware of this issue, guess we just wait now, hope this not gonna take them too long.
Asthman
Thats what they replayed me, so they are aware of this issue, guess we just wait now, hope this not gonna take them too long.

Ok, so that means that they are at least working on it. A replacement for this is going to suck because I have keycaps on mine already. Hopefully they can get a fix for this quickly. It would be a shame if they just let this issue persist for as long as they have
Hi, official razer support answered in another thread:
/huntsman-mini-broke-my-windows.65606/page-3
Please send him this logs hes asking for, maybe this will speed up the process of solving this issue.
Userlevel 7
Hey everyone! Thanks for sharing your keyboard's ongoing concern here. Our Support Team is currently investigating the issue and will ensure to post an official fix once it is available. For now, please send me your Razer Synapse 3.0 logs by following the steps on this link. Save the file via Google Drive or to any online drive account, then paste in your PM.
In the mean time while this is being fixed..hopefully.. anyone have other recommendations for a 60% keyboard that has switches like the purple opticals?
Razer.SpeedCr0ss
Hey everyone! IF you are still experiencing the issue, please send me your computer's Razer Synapse 3.0 by following the steps here. Save the compressed files via Google Drive or any online drive account, then paste the link in your PM. Let's continue from there.

Hello! Do we select the "Include THX Logs" and "Include Runtime Logs" options when collecting the logs?
heavenradioOrchid229
So i've just received and update from support that they have "Prioritized" this issue for replication and that I need to keep checking Synapse for an update but there is no ETA



Thanks a lot for sharing this!
Razer huntsman mini causes windows taskbar to crash - YouTube
enghn83
Just sharing, so new user won't have to waste their time to go through all what I did for last 3 days... I am very sure.. Huntsman Mini cause taskbar freeze & system tray freeze upon Windows Startup, or when, right after plug in huntsman mini to USB port. The starter bar will freeze..

I am unlucky one, never read this thread until last night, or else I would able to figure out this problem much earlier.. I tried to re-format Windows twice, fresh installed both Home & Pro version, unplug and re-plug every single piece of my hardware, including swaping my motherboard, cpu, gpu, ram, ssd, remove and reinstall every single hardware's driver... but, no improvement.. after 3 days of keep trying and trying, I finally found that Huntsman Mini is the one causing all these freezing..

My system info:
Mb: MSI B550 Edge Wifi
Cpu: Ryzen 5600x
Ram: 4x8gb xpg rgb 3200mhz
Ssd: Samsung 980 Pro
Gpu: Zotac 3070 OC


Razer is seriously incompetent on solving this problem 3 months now. I suggest you dump every Razer brand down the drain and move to another brand. That is where it belongs since no one seems to be able to take this whole matter seriously and issue a firmware update.

Trust me, you will be a happier man.
I have a huntsman mini with exactly the same problem. I've been using a blackwidow and deathadder together with no problems, apart from the sketchy synapse3 software. With the huntsman mini connected it takes my win10 gaming PC 10-15 mins to progress past the start menu. I chose this keyboard over the ducky one 2 mini because i've bought into the eco system quite heavily. It's starting to wear very thin with me now, the hardware is OK, but the firmware/software is the least robust i've ever used. Come on, get it sorted, it isn't good enough for expensive kit.
same issues exactly after the firmware update
I'm having the same exact issue after doing the update yesterday. On the phone with their support center now to see if they can help roll the firmware back. I only had the keyboard for 2 days, this is terrible if they have known about this issue since last month.
heavenradioOrchid229
I'm having the same exact issue after doing the update yesterday. On the phone with their support center now to see if they can help roll the firmware back. I only had the keyboard for 2 days, this is terrible if they have known about this issue since last month.


Wow, quite a few people are dealing with this :frown_:
Keep us posted about your progress with support, if you have time :wink_:
heavenradioOrchid229
No worries I will definitley update this thread. I've officially contacted support and now have a ticket number. I have also recorded a video expressing my dis-satisfaction with this keyboard since the update and will uploading it to Youtube later today. So hopefully they address this, the one thing I will say is that the support rep I spoke to didn't know about the issue, but when he esclated his senior engineers seemed to be aware of it. I asked him then why do they keep pushing the software, no answer. Anyway, gotta get some sleep.


I too contacted support before posting here and on Reddit. They should be aware of the issue by now and it's good to hear that the senior engineers seem to know about it