Razer Basilisk X Hyperspeed 2.4GHz dongle does not working | Razer Insider

Razer Basilisk X Hyperspeed 2.4GHz dongle does not working


Hello, I have problems with 2.4GHz dongle, it does not see the mouse and the pair is not making. The mouse is NOT visible also in Razer Synapse 3 when is set to 2.4GHz, only when is set on Bluetooth.

The mouse is working on Bluetooth mode (but is a bit slowly).

I mention that I updated the drivers, restarted the laptop, updated Windows, reinstalled Razer Synapse 3 and the problem persists, the mouse is working only on Bluetooth mode, with 2.4GHz the mouse is not visible and is not connecting to the dongle.


35 Replies

I was having the same problem and when I launched synapse then plugged the dongle back in everything started to work again after it loaded the mouse as a device. 

Hi, for me pairing with utility under this link helped

https://mysupport.razer.com/app/answers/detail/a_id/6376/kw/basilisk%20x%20hyperspeed

(Second download)

 

I was really struggling to get this fixed and this worked.  Thank you!

You can do clean Synapse reinstall, so it’ll remove any Razer drivers, and they’ll be downloaded again.

  1. Uninstall Synapse
  2. Download & run this tool: https://rzr.to/Tf53xj to remove any razer drivers/leftovers
  3. Then restart your PC
  4. After reboot install Synapse again (as administrator).

thx its helped but after install synapse I also needed to reinstall the mouse driver (because after restarting the computer, it gave an error) then Synapse offered me to update and then mouse started working

SOLUÇÃO

Estava enfrentando o mesmo problema mencionado anteriormente. O primeiro sintoma foi ao conectar o USB, ele ficava constantemente conectando e desconectando, emitindo sons como se estivesse plugando e desplugando o dispositivo repetidamente. Após algumas tentativas, o USB parou completamente de ser reconhecido.

Aqui está o que fazer em último caso:

  1. Desmonte o USB e limpe cuidadosamente com uma escova utilizando álcool isopropílico (para eletrônicos). Se não tiver, pode-se utilizar um pouco de WD-40 para eliminar possíveis oxidações. Se isso não resolver, passe para o passo 2.

  2. CUIDADO COM ESTE PASSO, PODE SER ARRISCADO. Utilizando um soprador térmico, ajuste a temperatura para 380 °C e a potência mínima do soprador, para evitar danos aos componentes. Aqueça com cautela ambos os lados da placa de circuito impresso (PCB) do USB. Se você tiver uma lupa e uma boa pinça e observar algum componente solto, tente consertá-lo.

Eu realizei esse procedimento e o USB voltou a funcionar normalmente depois.

SOLUTION

I was facing the same issue described above. The initial symptom occurred when plugging in the USB – it would continuously connect and disconnect, producing sounds as if the USB was being inserted and removed repeatedly. After several attempts, the USB ceased to be recognized altogether.

Here's what to do as a last resort:

  1. Disassemble the USB and gently clean it with a brush using isopropyl alcohol (for electronics). If unavailable, use a small amount of WD-40 to eliminate possible oxidations. If this doesn't work, proceed to step 2.

  2. BE CAUTIOUS WITH THIS STEP, IT CAN BE RISKY. Using a heat gun, set the temperature to 380 °C and the blower's power to the minimum to avoid damaging components. Carefully heat both sides of the USB's printed circuit board (PCB). If you have a magnifying glass and a good pair of tweezers and notice any loose components, attempt to fix them.

I performed this procedure, and the USB started working normally again.

I've chucked in a draw and switched to Logitech at the moment 

meu dongle está com erro no driver, quando conectado fica conectando e desconectando , alguém sabe como resolver ? tem algum driver específico para esse problema?

 

ja mudei de porta USB, desliguei PC, atualizei drives pc, mas na Razer não encontrei informações de atualização driver de mouse

I have the same problem. I've tried several solutions posted here on the forum but to no avail. I've updated the firmware, uninstalled/installed drivers, reset in synapse, formatted windows, and nothing. Every time I put the dongle windows goes crazy and can't recognize the drivers, worse that it affects the other usb as well. It wasn't like that before, it started a while ago. Now only using it on bluetooth with inconsistency and delay :(

Same issue, 6/7 8nteractions with support team, sending videos etc and in the end said can't help as bought from an Amazon marketplace seller (still new) as opposed to Amazon direct so no warranty beyond 30 days

TRAGIC RAZER !!!!

I bought RAZER VIPER V2 PRO, before one year on my company. I get same problem after 6 months. Eshop K24.cz give me new mouse. I have same problem in next 6 months and have varanty 12months only. I am 3 days after warranty 12 months. So been destroyed 2 dongles in 12 months and haven’t chance to complaint. I wrote on RAZER support, that want new dongle and they write me, that eshop K24.cz in Czech republic is not official distributor, therefore haven’t chance to get varranty for my mouse and this mouse is 6 months old… My laptop is Lenovo Legion and think that dongles are destroyed with hot ventilatior. I am using Logitech G903 a few years and never get a problem. 

 Mouse is not detected with SW:

RazerUSBHyperspeedDongleUtility_v1.00.03_r1

RazerMousePairingUtility_v1.00.02_r1

Firmware is on last version on mouse. I used for update cabel.

Exp:
1) Razer support is really tragic - maybe comic.
2) Want buy new dongle - RAZER Support don't help me, how to do it in Czech rep.
3) Mouse with cabel is correctly function.
4) Any idea, what to do now?

SAme issue, updated Dongle firmware but mouse only connects to bluetooth, not via the Dongle, also cannot get the green light flashing by pressing the 3 buttons, only by turning off and on again

If it is not on warranty you should maybe try to disassemble and check the connections inside, they might get loose with time or vibration etc. worked for me

Its less than 2 years so should be warranty, but te Razer site wont let me register it so time to take apart

SAme issue, updated Dongle firmware but mouse only connects to bluetooth, not via the Dongle, also cannot get the green light flashing by pressing the 3 buttons, only by turning off and on again

If it is not on warranty you should maybe try to disassemble and check the connections inside, they might get loose with time or vibration etc. worked for me

SAme issue, updated Dongle firmware but mouse only connects to bluetooth, not via the Dongle, also cannot get the green light flashing by pressing the 3 buttons, only by turning off and on again

I had a problem where the mouse light would come on and then disconnect and mouse was unresponsive but the dongle made the sound when connecting. I suspected a physical issue, took the mouse apart, applied some pressure to the sockets where the wires connect to the battery and it started working. Probably a contact issue when I dropped it or something, might be worth a while. Since the wires didn't come off entirely it work sometimes and sometimes didn't. It is an easy disassemble with youtube guides. Give it a try.

meu dongle está com erro no driver, quando conectado fica conectando e desconectando , alguém sabe como resolver ? tem algum driver específico para esse problema?

 

ja mudei de porta USB, desliguei PC, atualizei drives pc, mas na Razer não encontrei informações de atualização driver de mouse

I had the same issue recently and all I could figure out after taking the dongle apart was that there are some electronics on the dongle that broke off. I suspect it broke of from pushing it it to hard or bumping the dongle..

 

no it’s because of heat, mine is the same, shame on Razer

it sounds like your dongle is history same as mine, it’s not detected by both my PC and Mac, when I investigated further I’ve found that the dongle cannot stand heat, will not purchase a new dongle for 22$ so I’m using it only for Mac on Bluetooth, shame how Razer product’s quality is on decline! 

Hi, I had the same issue currently, Who can let me know which the resolve?

simply go to the settings>RESET> and reset everything the mouse. It will delete everything u have done to the macros and stuff but 2.4Ghz will work
at least it worked for me:)

I had the same issue recently and all I could figure out after taking the dongle apart was that there are some electronics on the dongle that broke off. I suspect it broke of from pushing it it to hard or bumping the dongle..

 

Thanks, I used RazerMousePairingUtility_v1.00.03_r1 from How to use the Razer Mouse Pairing Utility and it works

Hi, for me pairing with utility under this link helped

https://mysupport.razer.com/app/answers/detail/a_id/6376/kw/basilisk%20x%20hyperspeed

(Second download)

Go here:

https://mysupport.razer.com/app/answers/detail/a_id/6076/kw/dongle

 

Download the dongle utility and follow the instructions. This is what helped me. I had the same issues and I heard the dongle notification when plugged in and I was already on the latest. Once I got the utility installed it was pretty straight forward.  

Can you tell us software version? Or maybe a link with your version? Thanks

I had the same problem. The 2.4 wasn’t working until I updated the software. It works fine now. I hope this helps.

Same here.
And this reddit thread is three years old!
That’s my first and probably last experience with Razer.
Such a good mouse, tho 😭😥

I recently changed my laptop and now facing the same issue( I didn’t really check if it was detecting in razer on my old laptop). I have the same issue as well. The mouse works over dongle and bluetooth to be used but over dongle it’s not detecting in Razer Synapse to check my battery or to adjust the settings. I can do over bluetooth but I don’t know if it’ll remain the same when I change it to 2.4Ghz dongle to game. I honestly think it’s an issue with the Razer Synapse but Razer what the hell?

Reply